Package Details: perl-glib-object-introspection 0.042-1

Git Clone URL: https://aur.archlinux.org/perl-glib-object-introspection.git (read-only)
Package Base: perl-glib-object-introspection
Description: Dynamically create Perl language bindings
Upstream URL: https://metacpan.org/release/Glib-Object-Introspection
Licenses: GPL, PerlArtistic
Submitter: City-busz
Maintainer: jnbek
Last Packager: jnbek
Votes: 22
Popularity: 1.590800
First Submitted: 2012-01-21 11:20
Last Updated: 2017-04-20 20:51

Latest Comments

0x47 commented on 2017-04-20 15:55

I second cemsbr's comment, package needs makedepends

cemsbr commented on 2017-04-17 20:24

It only worked for me after changing deps to:

depends=('glib-perl>=1.32' 'glib2>=2.50.3' 'gobject-introspection-runtime>=1.50.0+1+gb8d92b0' 'libffi>=3.2.1')
makedepends=('gobject-introspection' 'perl-extutils-depends>=0.3' 'perl-extutils-pkgconfig>=1')

PhotonX commented on 2017-02-19 17:50

0.040 seems to be removed from the server, just bump it to 0.042.

rugaliz commented on 2017-02-17 09:44

There seams to be a problem with downloading the package. I get the following message:

ERROR: Failure while downloading http://search.cpan.org/CPAN/authors/id/X/XA/XAOC/Glib-Object-Introspection-0.040.tar.gz

City-busz commented on 2016-08-09 11:41

I moved gobject-introspection, perl-extutils-depends and perl-extutils-pkgconfig from depends to makedepends, because these are needed only on build. And the correct license is LGPL.

aptx commented on 2016-07-02 19:11

Does not build for me unless I have 'gobject-introspection' installed (without '-runtime'). Should this maybe be added to the build dependencies?

bidulock commented on 2016-06-19 01:13

Dependencies do not also need to be build dependencies: makepkg will not build the package until all the dependencies are in place.

SchrdngrsZombie commented on 2016-06-18 20:53

Please make 'gobject-introspection-runtime' (also?) a build dependency. Won't build if it's not installed

bidulock commented on 2015-06-28 14:12

Please bump pkgrel to 2 to trigger recompile against perl 5.22.0.

jnbek commented on 2015-03-19 23:14

Why yes, it is Spike29, thanks :-P

All comments