Package Details: perl-gnome2-gconf 1.044-4

Git Clone URL: https://aur.archlinux.org/perl-gnome2-gconf.git (read-only, click to copy)
Package Base: perl-gnome2-gconf
Description: Perl interface to the GConf configuration database
Upstream URL: http://search.cpan.org/dist/Gnome2-GConf
Licenses: GPL, PerlArtistic
Provides: gconf-perl
Submitter: jfigueras
Maintainer: figue (jfigueras, figuepluto)
Last Packager: figue
Votes: 9
Popularity: 0.000000
First Submitted: 2017-02-15 10:59 (UTC)
Last Updated: 2017-08-28 10:16 (UTC)

Latest Comments

1 2 Next › Last »

Dan92 commented on 2017-06-21 10:12 (UTC)

Thank you @figue!

figue commented on 2017-06-20 22:10 (UTC)

@JohnnyDeacon @Dan92 do this: pacman -Rdd perl-gnome2-gconf yaourt -Syu yaourt -S --asdeps perl-gnome2-gconf (or replace yaourt with your AUR favourite helper) Basically, we remove perl-gnome2-gconf first, then we update Perl, and then you can install this package again as a dependency.

JohnnyDeacon commented on 2017-06-20 16:23 (UTC)

:: Starting full system upgrade... resolving dependencies... looking for conflicting packages... error: failed to prepare transaction (could not satisfy dependencies) :: perl-gnome2-gconf: installing perl (5.26.0-1) breaks dependency 'perl<5.25' [jairo@archlinux ~]$

Dan92 commented on 2017-06-20 15:44 (UTC) (edited on 2017-06-20 15:45 (UTC) by Dan92)

Hi, I'm also having a weird bug. I need it to get PACManager (https://aur.archlinux.org/packages/pacmanager-git/) but I have this error each time I try to install it: "perl-gnome2-gconf requires perl<" Manjaro - fresh install Perl: This is perl 5, version 26, subversion 0 (v5.26.0) built for x86_64-linux-thread-multi

figue commented on 2017-06-06 23:37 (UTC)

@antisa so you updated to Perl 5.26 and then build perl-gnome2-gconf? Check if dependencies are correct: $ env LC_ALL=C pacman -Qi perl-gnome2-gconf | grep "Depends On" Depends On : gtk2-perl gconf glib-perl perl>=5.26 perl<5.27 If you see perl>=5.24, you should rebuild perl-gnome2-gconf again.

antisa commented on 2017-06-06 16:27 (UTC)

Hey, I have updated to perl 5.26 version, still getting the exact same error when trying to install pacmanager-bin or pacmanager-git

figue commented on 2017-06-04 23:48 (UTC)

@fguerout no, you don't, but this package is already prepared when Perl 5.26 will reach extra ;)

fguerout commented on 2017-06-04 09:06 (UTC)

Hi, Do we really have to upgrade to perl 5.26 that is currently on arch "testing" ? Thx

figue commented on 2017-06-03 14:15 (UTC)

Hi @antisa. Thanks! You can remove package first (pacman -Rdd perl-gnome2-gconf), upgrade perl to 5.26 and then install again. It's not polite, but it works :)