Package Details: perl-gnome2-gconf 1.044-4

Git Clone URL: (read-only, click to copy)
Package Base: perl-gnome2-gconf
Description: Perl interface to the GConf configuration database
Upstream URL:
Licenses: GPL, PerlArtistic
Provides: gconf-perl
Submitter: jfigueras
Maintainer: figue (jfigueras, figuepluto)
Last Packager: figue
Votes: 9
Popularity: 0.000000
First Submitted: 2017-02-15 10:59
Last Updated: 2017-08-28 10:16

Latest Comments

Dan92 commented on 2017-06-21 10:12

Thank you @figue!

figue commented on 2017-06-20 22:10

@JohnnyDeacon @Dan92 do this:

pacman -Rdd perl-gnome2-gconf
yaourt -Syu
yaourt -S --asdeps perl-gnome2-gconf

(or replace yaourt with your AUR favourite helper)

Basically, we remove perl-gnome2-gconf first, then we update Perl, and then you can install this package again as a dependency.

JohnnyDeacon commented on 2017-06-20 16:23

:: Starting full system upgrade...
resolving dependencies...
looking for conflicting packages...
error: failed to prepare transaction (could not satisfy dependencies)
:: perl-gnome2-gconf: installing perl (5.26.0-1) breaks dependency 'perl<5.25'
[jairo@archlinux ~]$

Dan92 commented on 2017-06-20 15:44


I'm also having a weird bug. I need it to get PACManager ( but I have this error each time I try to install it: "perl-gnome2-gconf requires perl<"

Manjaro - fresh install
Perl: This is perl 5, version 26, subversion 0 (v5.26.0) built for x86_64-linux-thread-multi

figue commented on 2017-06-06 23:37

@antisa so you updated to Perl 5.26 and then build perl-gnome2-gconf? Check if dependencies are correct:

$ env LC_ALL=C pacman -Qi perl-gnome2-gconf | grep "Depends On"
Depends On : gtk2-perl gconf glib-perl perl>=5.26 perl<5.27

If you see perl>=5.24, you should rebuild perl-gnome2-gconf again.

antisa commented on 2017-06-06 16:27


I have updated to perl 5.26 version, still getting the exact same error when trying to install pacmanager-bin or pacmanager-git

figue commented on 2017-06-04 23:48

@fguerout no, you don't, but this package is already prepared when Perl 5.26 will reach extra ;)

fguerout commented on 2017-06-04 09:06


Do we really have to upgrade to perl 5.26 that is currently on arch "testing" ?


figue commented on 2017-06-03 14:15

Hi @antisa. Thanks!
You can remove package first (pacman -Rdd perl-gnome2-gconf), upgrade perl to 5.26 and then install again. It's not polite, but it works :)

antisa commented on 2017-06-03 10:02

Hi, thanks for your work!

I'm having trouble upgrading this package to the newest version 1.044-3. The error I get is:

"could not satisfy dependencies: perl-gnome2-gconf requires perl<"

I have the perl package installed version 5.24.1-1