Package Details: perl-gnome2-vte 0.11-5

Git Clone URL: https://aur.archlinux.org/perl-gnome2-vte.git (read-only)
Package Base: perl-gnome2-vte
Description: Perl interface to the Virtual Terminal Emulation library
Upstream URL: http://search.cpan.org/~TSCH/Gnome2-Vte
Licenses: GPL, PerlArtistic
Submitter: jose1711
Maintainer: jose1711
Last Packager: jose1711
Votes: 41
Popularity: 0.051154
First Submitted: 2010-05-20 16:42
Last Updated: 2017-06-16 19:23

Latest Comments

jose1711 commented on 2017-06-16 19:23

thank you, fixed

olace commented on 2017-06-16 18:58

I can build now.
I have to modify in line 21:

"make"
to:
"PERL_USE_UNSAFE_INC=1 make"

https://bbs.archlinux.org/viewtopic.php?id=226971

olace commented on 2017-06-16 13:18

Hi, after upgrade perl to 5.26, I'm getting this:

Can't locate build/doc.pl in @INC (@INC contains: blib/lib blib/arch /usr/lib/perl5/site_perl /usr/share/perl5/site_perl /usr/lib/perl5/vendor_perl /usr/share/perl5/vendor_perl /usr/lib/perl5/core_perl /usr/share/perl5/core_perl) at /usr/lib/perl5/vendor_perl/Glib/GenPod.pm line 247.
make: *** [Makefile:1187: build/podindex] Error 2

Could you help?

figue commented on 2017-06-03 14:28

@jose1711 sorry, it doesn't work. I can build exporting it:


build() {
export PERL_USE_UNSAFE_INC=1
cd $srcdir/${_cpanname}-${pkgver}
sed -i '/^auto_install/d' Makefile.PL
perl Makefile.PL INSTALLDIRS=vendor
make
}

jose1711 commented on 2017-06-02 18:23

thank you, please check

figue commented on 2017-06-02 13:55

Please, add "export PERL_USE_UNSAFE_INC=1" in build() to workaround Perl 5.26 build. Thanks!

jose1711 commented on 2015-12-13 15:14

@adminempire
agreed, fixed

adminempire commented on 2015-11-02 23:27

Dont think this should be an 'any'

perl-gnome2-vte E: ELF file ('usr/lib/perl5/vendor_perl/auto/Gnome2/Vte/Vte.so') found in an 'any' package.

Tested on package built in clean chroot

snark.real commented on 2014-06-23 04:42

Please update source with
source=("http://cpan.metacpan.org/authors/id/X/XA/XAOC/${_cpanname}-${pkgver}.tar.gz")

adminempire commented on 2013-12-13 14:48

Update broke this

Installing /home/USER/gnome-vte/perl-gnome2-vte/pkg/perl-gnome2-vte/usr/share/man/man3/Gnome2::Vte::Terminal.3pm

/perl-gnome2-vte/pkg/perl-gnome2-vte/

Please fix

adminempire commented on 2013-12-12 07:57

v10 returns 404 and v11 is out. Please update or disown if you don't want it any longer. Thanks

cambid commented on 2010-12-29 20:31

This needs the package vte to compile