Package Details: perl-goo-canvas 0.06-11

Git Clone URL: https://aur.archlinux.org/perl-goo-canvas.git (read-only)
Package Base: perl-goo-canvas
Description: Perl bindings for GooCanvas
Upstream URL: https://metacpan.org/pod/Goo::Canvas
Licenses: GPL, PerlArtistic
Submitter: City-busz
Maintainer: PhotonX
Last Packager: PhotonX
Votes: 39
Popularity: 0.016313
First Submitted: 2017-01-24 12:14
Last Updated: 2019-09-22 09:47

Latest Comments

1 2 Next › Last »

zoe commented on 2019-09-21 20:42

I do not longer need this package. I disown it. Notice that archlinuxcn has the binary in its repository. Just add :

    [archlinuxcn]
    SigLevel = Never
    Server = <https://cdn.repo.archlinuxcn.org/>$arch

to your pacman.conf

Of course, do that just if you trust chinese linux-men !!

Ralf_Mardorf commented on 2018-09-18 19:45

It's needed to change url="http://search.cpan.org/dist/Goo-Canvas/" to url="https://metacpan.org/pod/Goo::Canvas" and source=("http://search.cpan.org/CPAN/authors/id/Y/YE/YEWENBIN/Goo-Canvas-$pkgver.tar.gz") to source=("https://cpan.metacpan.org/authors/id/Y/YE/YEWENBIN/Goo-Canvas-$pkgver.tar.gz") to get rid of the known "403 Forbidden".

alfredo.ardito commented on 2017-06-09 13:15

After last the commit, it built successfully. Thx

djringjr commented on 2017-06-07 01:19

Error confirmed. I have it also.

alfredo.ardito commented on 2017-06-06 21:15

Error Building:
==============
Can't locate build/doc.pl in @INC (@INC contains: blib/lib blib/arch /usr/lib/perl5/site_perl /usr/share/perl5/site_perl /usr/lib/perl5/vendor_perl /usr/share/perl5/vendor_perl /usr/lib/perl5/core_perl /usr/share/perl5/core_perl) at /usr/lib/perl5/vendor_perl/Glib/GenPod.pm line 247.
make: *** [Makefile:1361: build/podindex] Error 2
==> ERROR: A failure occurred in build().
Aborting...
==> ERROR: Makepkg was unable to build .
==> Restart building perl-goo-canvas ? [y/N]
==> ----------------------------------------

PhotonX commented on 2017-06-06 20:34

Please bump the pkgrev (after today's perl update the package needs a rebuild). Also add PERL_USE_UNSAFE_INC=1 before the make command (so it is

PERL_USE_UNSAFE_INC=1 make

rather than just make). See also https://bbs.archlinux.org/viewtopic.php?id=226971 for reference.

butler360 commented on 2017-01-29 09:47

Thanks, works fine now!

zoe commented on 2017-01-29 08:40

Thank you, Spyhawk, I did not notice that.
So, I fixed it.

Spyhawk commented on 2017-01-27 15:23

They are indeed in your PKGBUILD:
depends+=("perl>=$_perlver_min" "perl<$_perlver_max")

guiodic commented on 2017-01-27 10:43

no results found for perl<