Package Details: perl-io-aio 4.33-1

Git Clone URL: (read-only)
Package Base: perl-io-aio
Description: Asynchronous Input/Output
Upstream URL:
Licenses: GPL, PerlArtistic
Submitter: Athaba
Maintainer: jnbek
Last Packager: jnbek
Votes: 1
Popularity: 0.000000
First Submitted: 2011-07-09 15:36
Last Updated: 2016-01-18 18:32

Latest Comments

jnbek commented on 2016-01-18 18:31

so, it looks like IO::AIO 4.33 is out, but, it spews the following:
*** The stability canary says: (nothing, it was driven away by harsh weather)
*** It seems you are running perl version 5.022000, likely the "official" or
*** "standard" version. While there is nothing wrong with doing that,
*** standard perl versions 5.022 and up are not supported by IO::AIO.
*** While this might be fatal, it might also be all right - if you run into
*** problems, you might want to downgrade your perl or switch to the
*** stability branch.
*** If everything works fine, you can ignore this message.
*** Stability canary mini-FAQ:
*** Do I need to do anything?
*** With luck, no. While some distributions are known to fail
*** already, most should probably work. This message is here
*** to alert you that your perl is not supported by IO::AIO,
*** and if things go wrong, you either need to downgrade, or
*** sidegrade to the stability variant of your perl version,
*** or simply live with the consequences.
*** What is this canary thing?
*** It's purpose is to check support status of IO::AIO with
*** respect to your perl version.
*** What is this "stability branch"?
*** It's a branch or fork of the official perl, by schmorp, to
*** improve stability and compatibility with existing modules.
*** How can I skip this prompt on automated installs?
*** Set PERL_CANARY_STABILITY_NOPROMPT=1 in your environment.
*** More info is in the Canary::Stability manpage.
*** Long version of this FAQ:
*** Stability Branch homepage:

Continue anyways? [y]

Then tries to install when running cpan2aur. I manually changed the PKGBUILD and it still spewed the above, but successfully build the package, thus I am uploading 4.33, if for some reason the new version breaks things, the PKGBUILD for 4.31 is here: and I've uploaded the tarball to to ease the rollback process

fragfutter commented on 2013-11-13 08:28

should get an updated PKGBUILD:

WARNING: Using a PKGBUILD without a package() function is deprecated.