Package Details: perl-io-pty-easy 0.10-1

Git Clone URL: https://aur.archlinux.org/perl-io-pty-easy.git (read-only)
Package Base: perl-io-pty-easy
Description: Easy interface to IO::Pty
Upstream URL: http://search.cpan.org/dist/IO-Pty-Easy
Licenses: GPL, PerlArtistic
Submitter: None
Maintainer: 1ace
Last Packager: 1ace
Votes: 3
Popularity: 0.000000
First Submitted: 2011-11-25 10:29
Last Updated: 2018-12-26 15:44

Latest Comments

1ace commented on 2016-03-04 23:02

@simon25: Nothing changed upstream in the last 4 years, but I just tested it and it failed for me too.
I guess something it depends on became incompatible, but I'm not interested enough to dig deeper.
It also seems this error has become quite common lately: http://matrix.cpantesters.org/?dist=IO-Pty-Easy+0.09

I've disabled the build-time tests, but be aware that it those fail, other things might fail as well.

simon25 commented on 2016-03-02 21:26

0.09-1 fails to build with:

t/read-write.t ............ 3/?
# Failed test 'write returns undef on timeout'
# at t/read-write.t line 18.
# got: '11'
# expected: undef
t/read-write.t ............ 4/? # Looks like you failed 1 test of 5.
t/read-write.t ............ Dubious, test returned 1 (wstat 256, 0x100)

dracorp commented on 2013-07-02 12:53

"curl: (22) The requested URL returned error: 404 Not Found"
https://wiki.archlinux.org/index.php/Perl_Package_Guidelines#Hardened_example

programmerq commented on 2012-10-23 15:00

Doesn't currently build with version 0.08 (fails to download source). I can build it if I s/0.08/0.09/ and regenerate the checksums. might be a good idea to make use of the $version variable everywhere appropriate in the PKGBUILD