Package Details: perl-lwpx-paranoidagent 1.10-1

Git Clone URL: https://aur.archlinux.org/perl-lwpx-paranoidagent.git (read-only)
Package Base: perl-lwpx-paranoidagent
Description: subclass of LWP::UserAgent that protects you from harm
Upstream URL: http://search.cpan.org/dist/LWPx-ParanoidAgent
Licenses: GPL, PerlArtistic
Submitter: jnbek
Maintainer: jnbek
Last Packager: jnbek
Votes: 0
Popularity: 0.000000
First Submitted: 2014-01-08 00:11
Last Updated: 2015-06-16 21:19

Latest Comments

kmshanah commented on 2018-02-18 00:43

I think perl-bytes-random-secure is required for the check during build, but not for installation. I patched locally like this:

diff --git a/PKGBUILD b/PKGBUILD
index 0e04d41..1d43d38 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -10,6 +10,7 @@ license=('PerlArtistic' 'GPL')
 options=('!emptydirs')
 depends=('perl-crypt-ssleay>=0' 'perl-net-dns>=0' 'perl-libwww>=0')
 makedepends=()
+checkdepends=(perl-bytes-random-secure)
 url='http://search.cpan.org/dist/LWPx-ParanoidAgent'
 source=('http://search.cpan.org/CPAN/authors/id/S/SA/SAXJAZMAN/lwp/LWPx-ParanoidAgent-1.10.tar.gz')
 md5sums=('7a6e764acf3b58d71c149ed877c9cb8a')

Phhere commented on 2016-12-07 08:26

perl-bytes-random-secure is required as dependency