Package Details: perl-math-planepath 123-1

Git Clone URL: https://aur.archlinux.org/perl-math-planepath.git (read-only)
Package Base: perl-math-planepath
Description: Math::PlanePath -- points on a path through the 2-D plane
Upstream URL: https://metacpan.org/release/Math-PlanePath/
Licenses: GPL, PerlArtistic
Submitter: swiftgeek
Maintainer: swiftgeek
Last Packager: swiftgeek
Votes: 21
Popularity: 0.619782
First Submitted: 2012-06-23 10:24
Last Updated: 2016-05-20 06:23

Latest Comments

swiftgeek commented on 2015-07-01 08:01

1. Your reading skills have to improve (log clearly states which module isn't recompiled against perl 5.22)
2. To automate for all perl packages from AUR https://lists.archlinux.org/pipermail/arch-dev-public/2015-June/027236.html

leosw commented on 2015-07-01 07:17

Current version fails to compile : http://pastebin.com/T9aWue7y

kallisti5 commented on 2014-06-23 00:22

Current version is broken.

New version:

pkgver=116
md5sum=f606f26e813615e6f93db21f678a4ab1

swiftgeek commented on 2014-06-10 04:53

But only tests and nobody cares so much about them (the purpose of tests in AUR is just to check if your perl setup is still sane, as it often break itself)

swiftgeek commented on 2014-06-10 04:50

nope

yar commented on 2014-06-10 04:04

Some tests depend on perl-math-numseq

swiftgeek commented on 2013-10-04 16:43

That's not very helpful for solving your problem and also not related to this package
(It still goes through tests fine, ya rly)

gururise commented on 2013-10-04 15:21

t/TheodorusSpiral.t (Wstat: 512 Tests: 0 Failed: 0)
Non-zero exit status: 2
Parse errors: Bad plan. You planned 28 tests but ran 0.
t/VogelFloret.t (Wstat: 512 Tests: 0 Failed: 0)
Non-zero exit status: 2
Parse errors: Bad plan. You planned 29 tests but ran 0.
Files=101, Tests=28781, 6 wallclock secs ( 1.17 usr 0.07 sys + 4.88 cusr 0.08 csys = 6.20 CPU)
Result: FAIL
Failed 15/101 test programs. 0/28781 subtests failed.
make: *** [test_dynamic] Error 255
==> ERROR: A failure occurred in check().
Aborting...
==> ERROR: Makepkg was unable to build perl-math-planepath.

swiftgeek commented on 2013-05-31 08:10

IQ test passed, gz ;)

Anonymous comment on 2013-05-31 08:09

I just reinstall perl-math-libm and it's work...

swiftgeek commented on 2013-05-29 07:24

Perl API version v5.16.0 of Math::Libm does not match v5.18.0 at /usr/lib/perl5/core_perl/DynaLoader.pm line 213.

This is IQ test :/

Anonymous comment on 2013-05-29 07:22

make failed during tests: http://pastebin.com/CGXkED6P
I think it's a bad Perl API version dependancy.

woelfchen commented on 2013-04-04 12:23

version is 100, md5sum 2f3df718138da54e313e48f7695fc48b

awerner commented on 2013-02-18 01:12

version is 99, md5sum a0f87d799a3b971f5e46eae6cbdb8fd9

PPvG commented on 2013-01-10 14:49

Newest version is 96, md5sum 950e997c170909296d35bdbe772816e4.

Anonymous comment on 2012-12-05 20:55

@swiftgeek could you update the pkgbuild?

swiftgeek commented on 2012-11-03 14:25

@Hiroe Who cares about 404? Just post which version is the newest (91) and md5sum (35cd170be0a54395ff2d1fed922892ee)
Applies to any package in AUR

Anonymous comment on 2012-11-03 06:19

http://search.cpan.org/CPAN/authors/id/K/KR/KRYDE/Math-PlanePath-89.tar.gz 404's

swiftgeek commented on 2012-09-26 23:17

Yep

danielpublic commented on 2012-09-26 23:04

Yeah, its a bit off isn't it..
Can you install the 89 version of this package without problems?

swiftgeek commented on 2012-09-26 22:47

Then i do not have any idea why u are able to compile perl-math-libm against perl version that u don't have.
Also reinstalling things on linux doesn't change anything (unless u messed up something directly in hard disk)

swiftgeek commented on 2012-09-26 22:47

Then i do not have any idea why u are able to compile perl-math-libm against perl version that u don't have.
Also reinstalling things on linux doesn't change anything (unless u messed up something directly in hard disk)

swiftgeek commented on 2012-09-26 22:42

Then i do not have any idea why u are able to compile perl-math-libm against perl version that u don't have.
Also reinstalling things on linux doesn't change anything (unless u messed up something directly in hard disk)

danielpublic commented on 2012-09-26 22:38

I'm afraid not, and a barbaric reinstallation of perl does not help.
Installing the version 89 (md5sum: fee8b427d8e0c90f7140e8a09fd3e571) doesn't do much either.

Hm...

swiftgeek commented on 2012-09-26 22:20

Wild guess: try compiling/installing perl-math-libm again?

danielpublic commented on 2012-09-26 22:14

Hi.
I get the following error:

t/ArchimedeanSpiral.t ........... Perl API version v5.14.0 of Math::Libm does not match v5.16.0 at /usr/lib/perl5/core_perl/DynaLoader.pm line 213.
Compilation failed in require at /tmp/yaourt-tmp-daniel/aur-perl-math-planepath/src/Math-PlanePath-88/blib/lib/Math/PlanePath/ArchimedeanChords.pm line 27.
BEGIN failed--compilation aborted at /tmp/yaourt-tmp-daniel/aur-perl-math-planepath/src/Math-PlanePath-88/blib/lib/Math/PlanePath/ArchimedeanChords.pm line 27.
Compilation failed in require at t/ArchimedeanSpiral.t line 32.
t/ArchimedeanSpiral.t ........... Dubious, test returned 2 (wstat 512, 0x200)

Any suggestions to alleviate me this compile error, my Good kind Sir?

Tectu commented on 2012-09-17 20:14

out of date, change PKGBUILD:

pkgver=88
md5sums=('8a9022a2c939c65bc6190feb64a6939e')

swiftgeek commented on 2012-08-04 03:45

@nickoe: Sorry for not noticing this message :(

nickoe commented on 2012-07-20 10:48

swiftgeek this package is out-of-date, pkgver=81, and md5sums=('61acc683c071e9c5e5bcb9b44ead846d'). That works.

swiftgeek commented on 2012-06-23 10:24

A slic3r dependency

Feel free to ask for adoption: i'm not maintaining this package unless it will be needed by slic3r
Cheers