Package Details: perl-module-build-withxspp 0.14-1

Git Clone URL: https://aur.archlinux.org/perl-module-build-withxspp.git (read-only)
Package Base: perl-module-build-withxspp
Description: Module::Build::WithXSpp - XS++ enhanced flavour of Module::Build
Upstream URL: https://metacpan.org/release/Module-Build-WithXSpp/
Licenses: GPL, PerlArtistic
Submitter: swiftgeek
Maintainer: swiftgeek
Last Packager: swiftgeek
Votes: 20
Popularity: 0.565100
First Submitted: 2012-06-23 10:32
Last Updated: 2015-08-16 02:18

Latest Comments

yar commented on 2015-08-11 22:29

Needs to depend on perl-module-build

swiftgeek commented on 2015-07-04 14:59

Fixed, thanks

joposter commented on 2015-07-04 12:06

It would be nice to include
perl-extutils-xspp
as dependency

Ayehow commented on 2014-06-17 21:51

Ah, you mean https://aur.archlinux.org/packages/slic3r-git , I didn't notice it first. Thanks.

swiftgeek commented on 2014-06-17 21:15

perl-boost-geometry-utils is not used anymore by slic3r so nobody cares

Ayehow commented on 2014-06-17 20:07

Sorry, I just realized this bug was in fact while building perl-boost-geometry-utils (lost in yaourt) and it is an upstream bug https://rt.cpan.org/Public/Bug/Display.html?id=96145 - noncompatibility with perl 5.20

swiftgeek commented on 2014-06-17 20:04

Outdated perl modules from AUR (not recompiled against perl)

Ayehow commented on 2014-06-17 19:48

Hi, building on x86_64, tests failed with OOM:
==> Starting check()...
Module::Build will be removed from the Perl core distribution in the next major release. Please install it from CPAN. It is being used at /usr/share/perl5/vendor_perl/Module/Build/WithXSpp.pm, line 5.
t/00-compile.t ............. ok
t/01_basic.t ............... 1/36 Out of memory!
# Looks like you planned 36 tests but ran 2.
# Looks like your test exited with 1 just after 2.
t/01_basic.t ............... Dubious, test returned 1 (wstat 256, 0x100)
Failed 34/36 subtests
t/02_old_api.t ............. 1/3 Out of memory!
# Looks like you planned 3 tests but ran 1.
# Looks like your test exited with 1 just after 1.
t/02_old_api.t ............. Dubious, test returned 1 (wstat 256, 0x100)
Failed 2/3 subtests
t/03_polygon.t ............. ok
t/04_medial_axis_basic.t ... ok
t/05_medial_axis_visual.t .. skipped: author tests
t/release-pod-coverage.t ... skipped: these tests are for release candidate testing
t/release-pod-syntax.t ..... skipped: these tests are for release candidate testing

which is weird since:
$ free -g
total used free shared buffers cached
Mem: 11 1 9 0 0 0
-/+ buffers/cache: 0 10
Swap: 7 0 7

Any clues? Thanks.

swiftgeek commented on 2012-06-23 10:34

A slic3r dependency

Feel free to ask for adoption: i'm not maintaining this package unless it will be needed by slic3r
Cheers