Package Details: perl-moose 2.2004-1

Git Clone URL: https://aur.archlinux.org/perl-moose.git (read-only)
Package Base: perl-moose
Description: A postmodern object system for Perl 5
Upstream URL: https://metacpan.org/release/Moose
Licenses: GPL, PerlArtistic
Submitter: None
Maintainer: jnbek
Last Packager: jnbek
Votes: 73
Popularity: 0.007550
First Submitted: 2009-04-20 16:45
Last Updated: 2017-04-17 23:23

Required by (145)

Sources (1)

Pinned Comments

jnbek commented on 2016-06-07 16:40

Ugh, even after the perl 5.24 upgrade, we're still getting errors in makepkg:

Warning: prerequisite List::Util 1.45 not found. We have 1.4202.

List::Util is a core module... we need this module to be version 1.45 before we can update this pkgbuild and it's millions of reverse-deps

Latest Comments

dracorp commented on 2017-06-20 17:32

And with perl-5.26.0-1:
xs/Moose.c: loadable library and perl binaries are mismatched (got handshake key 0xdb80080, needed 0xde00080)
on Makefile.PL -> check_conflicts()
edit:
After adding to PKGBUILD:
sed '16s/^/#/' -i Makefile.PL
I can install and use this module. How good is it?

bidulock commented on 2017-06-11 04:12

Builds ok with 5.26.0, however this is not an 'any' package.

yar commented on 2017-04-18 00:31

This should makedepend on at least perl-type-tiny and perl-specio, probably others. I'm getting lots of test failures and have to run --nocheck

Vrob commented on 2017-01-02 00:08

Installing community/perl-scalar-list-utils fixed the error complaining about version 1.4202 of List::Util. Maybe this package should be added as a dependency?

005flyof commented on 2016-11-24 23:47

Hi, I tried to install caff-svn, depending on perl-moose, but I've got this error :

Files=473, Tests=2646, 59 wallclock secs ( 1.70 usr 0.52 sys + 53.90 cusr 3.40 csys = 59.52 CPU)
Result: FAIL
Failed 371/473 test programs. 45/2646 subtests failed.
make: *** [Makefile:2858: test_dynamic] Error 255

What can I do ?

somercet commented on 2016-07-20 09:29

I have a PKGBUILD for Scalar-List-Utils 1.45 and can submit it.

It does not appear to conflict with extra/perl-list-moreutils or community/perl-list-allutils.

mbunkus commented on 2016-06-11 08:13

You could create an AUR package for List::Util (perl-list-util) and tell people to install that one manually. That's what I did a couple of months ago in a similar situation.

jnbek commented on 2016-06-07 16:40

Ugh, even after the perl 5.24 upgrade, we're still getting errors in makepkg:

Warning: prerequisite List::Util 1.45 not found. We have 1.4202.

List::Util is a core module... we need this module to be version 1.45 before we can update this pkgbuild and it's millions of reverse-deps

jnbek commented on 2016-06-07 16:40

Ugh, even after the perl 5.24 upgrade, we're still getting errors in makepkg:

Warning: prerequisite List::Util 1.45 not found. We have 1.4202.

List::Util is a core module... we need this module to be version 1.45 before we can update this pkgbuild and it's millions of reverse-deps

mbunkus commented on 2015-10-05 07:41

@gisburne: I used the workaround of removing the package ignoring its dependencies (sudo pacman -Rdd perl-moose) and re-installing it right afterwards.

All comments