Package Details: perl-moosex-getopt 0.68-1

Git Clone URL: https://aur.archlinux.org/perl-moosex-getopt.git (read-only)
Package Base: perl-moosex-getopt
Description: A Moose role for processing command line options
Upstream URL: https://metacpan.org/release/MooseX-Getopt
Licenses: GPL, PerlArtistic
Submitter: None
Maintainer: bunder
Last Packager: bunder
Votes: 11
Popularity: 0.009391
First Submitted: 2009-04-21 18:45
Last Updated: 2015-08-14 07:38

Latest Comments

bunder commented on 2015-08-14 07:40

2gunterb14: Fixed. Thank you!
2gergan_penkov: I've rechecked that module builds successfully without Module::Build. However Module::Build::Tiny is required. Now it should be fixed.

gergan_penkov commented on 2015-08-09 13:35

it depends on perl-module-build for building

gunterb14 commented on 2015-07-12 21:25

builddepends should be makedepends in the PKGBUILD.

jnbek commented on 2015-03-02 18:35

0.67 is out.

jnbek commented on 2014-03-26 22:32

0.63 was uploaded to CPAN yesterday, seems to have propagated to all mirrors.

bunder commented on 2014-03-08 15:33

OK. I've finally updated it, but turned checking off, because Module::Build::Tiny test feature doesn't work without TAP::Harness::Env which will come with new version of perl.

jnbek commented on 2014-03-07 20:52

yay!! MooseX-Getopt-0.62 / MooseX::Getopt was uploaded 15 hours ago, I wonder if this update will now build :D

jnbek commented on 2014-02-12 23:04

Man, this package is a pain in the ass....

==> Starting check()...
t/00-check-deps.t ................... Can't locate object method "merged_requirements" via package "CPAN::Meta::Prereqs" at /usr/share/perl5/vendor_perl/CPAN/Meta/Check.pm line 42.
t/00-check-deps.t ................... Dubious, test returned 255 (wstat 65280, 0xff00)
No subtests run
package is a pain in the ass....

So CPAN::Meta is out of date, but the latest version won't build due to

t/validator.t .......... List::Util version 1.33 required--this is only version 1.27 at /tmp/perl-cpan-meta/src/CPAN-Meta-2.133380/blib/lib/CPAN/Meta/Converter.pm line 12.

and List::Util is a CORE Package.... Since the CPAN::Meta::Prereqs package only seems to be needed in the tests, I recommend each user having these problems to simply remove the:
make test
from the PKGBUILD until List::Util is updated in the next release of perl.

jnbek commented on 2014-02-12 23:04

Man, this==> Starting check()...
t/00-check-deps.t ................... Can't locate object method "merged_requirements" via package "CPAN::Meta::Prereqs" at /usr/share/perl5/vendor_perl/CPAN/Meta/Check.pm line 42.
t/00-check-deps.t ................... Dubious, test returned 255 (wstat 65280, 0xff00)
No subtests run
package is a pain in the ass....

So CPAN::Meta is out of date, but the latest version won't build due to

t/validator.t .......... List::Util version 1.33 required--this is only version 1.27 at /tmp/perl-cpan-meta/src/CPAN-Meta-2.133380/blib/lib/CPAN/Meta/Converter.pm line 12.

and List::Util is a CORE Package.... Since the CPAN::Meta::Prereqs package only seems to be needed in the tests, I recommend each user having these problems to simply remove the:
make test
from the PKGBUILD until List::Util is updated in the next release of perl.

bunder commented on 2013-12-27 05:30

Can't update to v0.59: it requires Module::Build::Tiny v0.030 that is not in AUR yet (see https://aur.archlinux.org/packages/perl-module-build-tiny/).

All comments