Package Details: perl-moosex-object-pluggable 0.0014-1

Git Clone URL: (read-only)
Package Base: perl-moosex-object-pluggable
Description: Make your classes pluggable
Upstream URL:
Licenses: GPL, PerlArtistic
Submitter: xenoterracide
Maintainer: jnbek
Last Packager: jnbek
Votes: 4
Popularity: 0.000000
First Submitted: 2010-05-02 14:49
Last Updated: 2016-04-08 14:19

Latest Comments

mbunkus commented on 2016-04-08 14:26

Great, thanks for the update, jnbek.

jnbek commented on 2016-04-08 14:19

Sorry d00d, should be good nao :D

hexadecagram commented on 2016-04-08 04:44

Still missing a dependency on perl-module-pluggable. Manual installation of that dependency results in a successful build.

jnbek commented on 2014-06-11 16:50

mbunkus, thanks, I'll have a look in a bit when I get to work.

mbunkus commented on 2014-06-11 09:49

Module::Pluggable::Object is required by your module. Until Perl 5.19 it had been in core, but with 5.20 it got dropped. There's the new package perl-module-pluggable in community. Please declare dependencies on it, otherwise tests fail.

jnbek commented on 2013-06-10 21:36

@ mbunkus, yea, this package is one of about 80 that are giving me problems; this one in particular though is proving to be must more difficult. With a number of hte CORE modules removed this release, it's reminiscent of RPM hell on Red Hat 9... it says "Missing dependency... perl-blah-blah" when I upload/update perl-blah-blah, it still errors saying the package is missing. I'm not sure yet where the bug exists, cpanplus, AUR or what. I'll advise upon more knowledge acquisition.

mbunkus commented on 2013-06-10 14:51

The newest Perl 5.18.0 outputs this warning when loading the module:

Module::Pluggable::Object will be removed from the Perl core distribution in the next major release. Please install it from CPAN. It is being used at /usr/share/perl5/vendor_perl/MooseX/Object/, line 7.

I've checked on CPAN and MooseX::Object::Pluggable itself already lists Module::Pluggable::Object as a dependency[1], so that package itself is fine.

However, your package should list perl-module-pluggable-object as a dependency now. It is available from the AUR, too[2]. Yes, it's out of date at the moment, but I've already flagged it accordingly.


jnbek commented on 2012-10-30 15:46

OK, thanks mbunkus I'll see what I can do however I believe the issue resides with the perl-moose package also being out of date. Once that is corrected, this issue will correct itself ;-) I have a cron setup that goes through and slaps all my perl- AURs and informs me when one needs updating. I suggest hopping over to perl-moose and raising hell over there too.

mbunkus commented on 2012-10-30 09:36

This package lists perl-extutils-makemaker>=6.6302 as makedepends. However, the package in the AUR is still at a lower version, and even more importantly, perl 5.16.1 from core includes exactly this version of ExtUtils::MakeMaker. Therefore the makedepends should be dropped.