Package Details: perl-moosex-role-parameterized 1.11-1

Git Clone URL: https://aur.archlinux.org/perl-moosex-role-parameterized.git (read-only, click to copy)
Package Base: perl-moosex-role-parameterized
Description: roles with composition parameters
Upstream URL: http://search.cpan.org/dist/MooseX-Role-Parameterized
Licenses: GPL, PerlArtistic
Submitter: None
Maintainer: bidulock
Last Packager: bidulock
Votes: 14
Popularity: 0.000000
First Submitted: 2009-04-21 18:45 (UTC)
Last Updated: 2021-09-14 20:09 (UTC)

Latest Comments

thaewrapt commented on 2022-01-27 15:57 (UTC)

@dreieck: actually, from the "dependency graph" on CPAN https://cpandeps.grinnz.com/?dist=MooseX-Role-Parameterized I see that Devel::OverloadInfo could be a dependency of Moose, I wonder if Moose should belong to "depends" instead of "makedepends" for this package (and if that will fix this check()-related issue as well).

dreieck commented on 2022-01-25 15:16 (UTC) (edited on 2022-01-25 15:17 (UTC) by dreieck)

You should add perl-devel-overloadinfo to dependencies. Having this installed fixes the following check() error:

==> Starting check()...
PERL_DL_NONLAZY=1 "/usr/bin/perl" "-MExtUtils::Command::MM" "-MTest::Harness" "-e" "undef *Test::Harness::Switches; test_harness(0, 'blib/lib', 'blib/arch')" t/*.t
t/00-report-prereqs.t ............... # 
# Versions for all modules listed in MYMETA.json (including optional ones):
# 
# === Configure Requires ===
# 
#     Module               Want  Have
#     ------------------- ----- -----
#     ExtUtils::MakeMaker   any  7.62
#     Module::Build::Tiny 0.034 0.039
# 
# === Build Requires ===
# 
#     Module              Want Have
#     ------------------- ---- ----
#     ExtUtils::MakeMaker  any 7.62
# 
# === Test Requires ===
# 
#     Module                        Want     Have
#     ---------------------------- ----- --------
#     CPAN::Meta::Check            0.011    0.014
#     CPAN::Meta::Requirements       any    2.140
#     Data::Dumper                   any    2.179
#     File::Spec                     any     3.80
#     Module::Metadata               any 1.000037
#     Moose::Util::TypeConstraints   any   2.2015
#     Storable                       any     3.23
#     Test::Fatal                    any    0.016
#     Test::Moose                    any   2.2015
#     Test::More                    0.96 1.302183
#     Test::Needs                    any 0.002009
#     lib                            any     0.65
#     overload                       any     1.33
# 
# === Test Recommends ===
# 
#     Module         Want     Have
#     ---------- -------- --------
#     CPAN::Meta 2.120900 2.150010
# 
# === Runtime Requires ===
# 
#     Module                 Want   Have
#     -------------------- ------ ------
#     Carp                    any   1.52
#     Module::Runtime         any  0.016
#     Moose                2.0300 2.2015
#     Moose::Exporter         any 2.2015
#     Moose::Meta::Role       any 2.2015
#     Moose::Role             any 2.2015
#     Moose::Util             any 2.2015
#     namespace::autoclean    any   0.29
#     namespace::clean       0.19   0.27
#     strict                  any   1.12
#     warnings                any   1.51
# 
# === Other Modules ===
# 
#     Module                  Have
#     -------------------- -------
#     Dist::CheckConflicts    0.11
#     Encode                  3.08
#     File::Temp            0.2311
#     JSON::PP                4.06
#     Module::Runtime        0.016
#     Pod::Coverage           0.23
#     Sub::Name               0.26
#     YAML                 missing
#     autodie                 2.34
# 
t/00-report-prereqs.t ............... ok   
t/001-parameters.t .................. Can't locate Devel/OverloadInfo.pm in @INC (you may need to install the Devel::OverloadInfo module) (@INC contains: /[...]/perl-moosex-role-parameterized/src/MooseX-Role-Parameterized-1.11/blib/lib /[...]/perl-moosex-role-parameterized/src/MooseX-Role-Parameterized-1.11/blib/arch /usr/lib/perl5/5.34/site_perl /usr/share/perl5/site_perl /usr/lib/perl5/5.34/vendor_perl /usr/share/perl5/vendor_perl /usr/lib/perl5/5.34/core_perl /usr/share/perl5/core_perl .) at /usr/lib/perl5/5.34/vendor_perl/Class/MOP/Mixin/HasOverloads.pm line 9.
BEGIN failed--compilation aborted at /usr/lib/perl5/5.34/vendor_perl/Class/MOP/Mixin/HasOverloads.pm line 9.
Compilation failed in require at /usr/lib/perl5/5.34/vendor_perl/Class/MOP.pm line 17.
BEGIN failed--compilation aborted at /usr/lib/perl5/5.34/vendor_perl/Class/MOP.pm line 17.
Compilation failed in require at /usr/lib/perl5/5.34/vendor_perl/Moose/Exporter.pm line 8.
BEGIN failed--compilation aborted at /usr/lib/perl5/5.34/vendor_perl/Moose/Exporter.pm line 8.
Compilation failed in require at /usr/lib/perl5/5.34/vendor_perl/Moose.pm line 15.
BEGIN failed--compilation aborted at /usr/lib/perl5/5.34/vendor_perl/Moose.pm line 15.
Compilation failed in require at /[...]/perl-moosex-role-parameterized/src/MooseX-Role-Parameterized-1.11/blib/lib/MooseX/Role/Parameterized/Parameters.pm line 6.
BEGIN failed--compilation aborted at /[...]/perl-moosex-role-parameterized/src/MooseX-Role-Parameterized-1.11/blib/lib/MooseX/Role/Parameterized/Parameters.pm line 6.
Compilation failed in require at t/001-parameters.t line 6.
BEGIN failed--compilation aborted at t/001-parameters.t line 6.
t/001-parameters.t .................. Dubious, test returned 2 (wstat 512, 0x200)
No subtests run 
t/002-role-block.t .................. Can't locate Devel/OverloadInfo.pm in @INC (you may need to install the Devel::OverloadInfo module) (@INC contains: /[...]/perl-moosex-role-parameterized/src/MooseX-Role-Parameterized-1.11/blib/lib /[...]/perl-moosex-role-parameterized/src/MooseX-Role-Parameterized-1.11/blib/arch /usr/lib/perl5/5.34/site_perl /usr/share/perl5/site_perl /usr/lib/perl5/5.34/vendor_perl /usr/share/perl5/vendor_perl /usr/lib/perl5/5.34/core_perl /usr/share/perl5/core_perl .) at /usr/lib/perl5/5.34/vendor_perl/Class/MOP/Mixin/HasOverloads.pm line 9.
BEGIN failed--compilation aborted at /usr/lib/perl5/5.34/vendor_perl/Class/MOP/Mixin/HasOverloads.pm line 9.
Compilation failed in require at /usr/lib/perl5/5.34/vendor_perl/Class/MOP.pm line 17.
BEGIN failed--compilation aborted at /usr/lib/perl5/5.34/vendor_perl/Class/MOP.pm line 17.
Compilation failed in require at /usr/lib/perl5/5.34/vendor_perl/Moose/Exporter.pm line 8.
BEGIN failed--compilation aborted at /usr/lib/perl5/5.34/vendor_perl/Moose/Exporter.pm line 8.
Compilation failed in require at /usr/lib/perl5/5.34/vendor_perl/Moose.pm line 15.
BEGIN failed--compilation aborted at /usr/lib/perl5/5.34/vendor_perl/Moose.pm line 15.
Compilation failed in require at /[...]/perl-moosex-role-parameterized/src/MooseX-Role-Parameterized-1.11/blib/lib/MooseX/Role/Parameterized.pm line 8.
BEGIN failed--compilation aborted at /[...]/perl-moosex-role-parameterized/src/MooseX-Role-Parameterized-1.11/blib/lib/MooseX/Role/Parameterized.pm line 8.
Compilation failed in require at t/002-role-block.t line 9.
BEGIN failed--compilation aborted at t/002-role-block.t line 9.
t/002-role-block.t .................. Dubious, test returned 2 (wstat 512, 0x200)
No subtests run 
t/003-apply.t ....................... Can't locate Devel/OverloadInfo.pm in @INC (you may need to install the Devel::OverloadInfo module) (@INC contains: /[...]/perl-moosex-role-parameterized/src/MooseX-Role-Parameterized-1.11/blib/lib /[...]/perl-moosex-role-parameterized/src/MooseX-Role-Parameterized-1.11/blib/arch /usr/lib/perl5/5.34/site_perl /usr/share/perl5/site_perl /usr/lib/perl5/5.34/vendor_perl /usr/share/perl5/vendor_perl /usr/lib/perl5/5.34/core_perl /usr/share/perl5/core_perl .) at /usr/lib/perl5/5.34/vendor_perl/Class/MOP/Mixin/HasOverloads.pm line 9.
BEGIN failed--compilation aborted at /usr/lib/perl5/5.34/vendor_perl/Class/MOP/Mixin/HasOverloads.pm line 9.
Compilation failed in require at /usr/lib/perl5/5.34/vendor_perl/Class/MOP.pm line 17.
BEGIN failed--compilation aborted at /usr/lib/perl5/5.34/vendor_perl/Class/MOP.pm line 17.
Compilation failed in require at /usr/lib/perl5/5.34/vendor_perl/Moose/Exporter.pm line 8.
BEGIN failed--compilation aborted at /usr/lib/perl5/5.34/vendor_perl/Moose/Exporter.pm line 8.
Compilation failed in require at /usr/lib/perl5/5.34/vendor_perl/Moose.pm line 15.
BEGIN failed--compilation aborted at /usr/lib/perl5/5.34/vendor_perl/Moose.pm line 15.
Compilation failed in require at /[...]/perl-moosex-role-parameterized/src/MooseX-Role-Parameterized-1.11/blib/lib/MooseX/Role/Parameterized.pm line 8.
BEGIN failed--compilation aborted at /[...]/perl-moosex-role-parameterized/src/MooseX-Role-Parameterized-1.11/blib/lib/MooseX/Role/Parameterized.pm line 8.
Compilation failed in require at t/003-apply.t line 9.
BEGIN failed--compilation aborted at t/003-apply.t line 9.
t/003-apply.t ....................... Dubious, test returned 2 (wstat 512, 0x200)
No subtests run 
t/004-with.t ........................ Can't locate Devel/OverloadInfo.pm in @INC (you may need to install the Devel::OverloadInfo module) (@INC contains: /[...]/perl-moosex-role-parameterized/src/MooseX-Role-Parameterized-1.11/blib/lib /[...]/perl-moosex-role-parameterized/src/MooseX-Role-Parameterized-1.11/blib/arch /usr/lib/perl5/5.34/site_perl /usr/share/perl5/site_perl /usr/lib/perl5/5.34/vendor_perl /usr/share/perl5/vendor_perl /usr/lib/perl5/5.34/core_perl /usr/share/perl5/core_perl .) at /usr/lib/perl5/5.34/vendor_perl/Class/MOP/Mixin/HasOverloads.pm line 9.
BEGIN failed--compilation aborted at /usr/lib/perl5/5.34/vendor_perl/Class/MOP/Mixin/HasOverloads.pm line 9.
Compilation failed in require at /usr/lib/perl5/5.34/vendor_perl/Class/MOP.pm line 17.
BEGIN failed--compilation aborted at /usr/lib/perl5/5.34/vendor_perl/Class/MOP.pm line 17.
Compilation failed in require at /usr/lib/perl5/5.34/vendor_perl/Moose/Exporter.pm line 8.
BEGIN failed--compilation aborted at /usr/lib/perl5/5.34/vendor_perl/Moose/Exporter.pm line 8.
Compilation failed in require at /usr/lib/perl5/5.34/vendor_perl/Moose.pm line 15.
BEGIN failed--compilation aborted at /usr/lib/perl5/5.34/vendor_perl/Moose.pm line 15.
Compilation failed in require at /usr/lib/perl5/5.34/vendor_perl/Moose/Role.pm line 13.
BEGIN failed--compilation aborted at /usr/lib/perl5/5.34/vendor_perl/Moose/Role.pm line 13.
Compilation failed in require at t/004-with.t line 7.
BEGIN failed--compilation aborted at t/004-with.t line 7.
t/004-with.t ........................ Dubious, test returned 2 (wstat 512, 0x200)
No subtests run 
t/005-with-parameterized.t .......... Can't locate Devel/OverloadInfo.pm in @INC (you may need to install the Devel::OverloadInfo module) (@INC contains: /[...]/perl-moosex-role-parameterized/src/MooseX-Role-Parameterized-1.11/blib/lib /[...]/perl-moosex-role-parameterized/src/MooseX-Role-Parameterized-1.11/blib/arch /usr/lib/perl5/5.34/site_perl /usr/share/perl5/site_perl /usr/lib/perl5/5.34/vendor_perl /usr/share/perl5/vendor_perl /usr/lib/perl5/5.34/core_perl /usr/share/perl5/core_perl .) at /usr/lib/perl5/5.34/vendor_perl/Class/MOP/Mixin/HasOverloads.pm line 9.
BEGIN failed--compilation aborted at /usr/lib/perl5/5.34/vendor_perl/Class/MOP/Mixin/HasOverloads.pm line 9.
Compilation failed in require at /usr/lib/perl5/5.34/vendor_perl/Class/MOP.pm line 17.
BEGIN failed--compilation aborted at /usr/lib/perl5/5.34/vendor_perl/Class/MOP.pm line 17.
Compilation failed in require at /usr/lib/perl5/5.34/vendor_perl/Moose/Exporter.pm line 8.
BEGIN failed--compilation aborted at /usr/lib/perl5/5.34/vendor_perl/Moose/Exporter.pm line 8.
Compilation failed in require at /usr/lib/perl5/5.34/vendor_perl/Moose.pm line 15.
BEGIN failed--compilation aborted at /usr/lib/perl5/5.34/vendor_perl/Moose.pm line 15.
Compilation failed in require at /[...]/perl-moosex-role-parameterized/src/MooseX-Role-Parameterized-1.11/blib/lib/MooseX/Role/Parameterized.pm line 8.
BEGIN failed--compilation aborted at /[...]/perl-moosex-role-parameterized/src/MooseX-Role-Parameterized-1.11/blib/lib/MooseX/Role/Parameterized.pm line 8.
Compilation failed in require at t/005-with-parameterized.t line 7.
BEGIN failed--compilation aborted at t/005-with-parameterized.t line 7.
t/005-with-parameterized.t .......... Dubious, test returned 2 (wstat 512, 0x200)
No subtests run 
t/006-requires.t .................... Can't locate Devel/OverloadInfo.pm in @INC (you may need to install the Devel::OverloadInfo module) (@INC contains: /[...]/perl-moosex-role-parameterized/src/MooseX-Role-Parameterized-1.11/blib/lib /[...]/perl-moosex-role-parameterized/src/MooseX-Role-Parameterized-1.11/blib/arch /usr/lib/perl5/5.34/site_perl /usr/share/perl5/site_perl /usr/lib/perl5/5.34/vendor_perl /usr/share/perl5/vendor_perl /usr/lib/perl5/5.34/core_perl /usr/share/perl5/core_perl .) at /usr/lib/perl5/5.34/vendor_perl/Class/MOP/Mixin/HasOverloads.pm line 9.
BEGIN failed--compilation aborted at /usr/lib/perl5/5.34/vendor_perl/Class/MOP/Mixin/HasOverloads.pm line 9.
Compilation failed in require at /usr/lib/perl5/5.34/vendor_perl/Class/MOP.pm line 17.
BEGIN failed--compilation aborted at /usr/lib/perl5/5.34/vendor_perl/Class/MOP.pm line 17.
Compilation failed in require at /usr/lib/perl5/5.34/vendor_perl/Moose/Exporter.pm line 8.
BEGIN failed--compilation aborted at /usr/lib/perl5/5.34/vendor_perl/Moose/Exporter.pm line 8.
Compilation failed in require at /usr/lib/perl5/5.34/vendor_perl/Moose.pm line 15.
BEGIN failed--compilation aborted at /usr/lib/perl5/5.34/vendor_perl/Moose.pm line 15.
Compilation failed in require at /[...]/perl-moosex-role-parameterized/src/MooseX-Role-Parameterized-1.11/blib/lib/MooseX/Role/Parameterized.pm line 8.
BEGIN failed--compilation aborted at /[...]/perl-moosex-role-parameterized/src/MooseX-Role-Parameterized-1.11/blib/lib/MooseX/Role/Parameterized.pm line 8.
Compilation failed in require at t/006-requires.t line 8.
BEGIN failed--compilation aborted at t/006-requires.t line 8.
t/006-requires.t .................... Dubious, test returned 2 (wstat 512, 0x200)
No subtests run 
t/007-excludes.t .................... Can't locate Devel/OverloadInfo.pm in @INC (you may need to install the Devel::OverloadInfo module) (@INC contains: /[...]/perl-moosex-role-parameterized/src/MooseX-Role-Parameterized-1.11/blib/lib /[...]/perl-moosex-role-parameterized/src/MooseX-Role-Parameterized-1.11/blib/arch /usr/lib/perl5/5.34/site_perl /usr/share/perl5/site_perl /usr/lib/perl5/5.34/vendor_perl /usr/share/perl5/vendor_perl /usr/lib/perl5/5.34/core_perl /usr/share/perl5/core_perl .) at /usr/lib/perl5/5.34/vendor_perl/Class/MOP/Mixin/HasOverloads.pm line 9.
BEGIN failed--compilation aborted at /usr/lib/perl5/5.34/vendor_perl/Class/MOP/Mixin/HasOverloads.pm line 9.
Compilation failed in require at /usr/lib/perl5/5.34/vendor_perl/Class/MOP.pm line 17.
BEGIN failed--compilation aborted at /usr/lib/perl5/5.34/vendor_perl/Class/MOP.pm line 17.
Compilation failed in require at /usr/lib/perl5/5.34/vendor_perl/Moose/Exporter.pm line 8.
BEGIN failed--compilation aborted at /usr/lib/perl5/5.34/vendor_perl/Moose/Exporter.pm line 8.
Compilation failed in require at /usr/lib/perl5/5.34/vendor_perl/Moose.pm line 15.
BEGIN failed--compilation aborted at /usr/lib/perl5/5.34/vendor_perl/Moose.pm line 15.
Compilation failed in require at /[...]/perl-moosex-role-parameterized/src/MooseX-Role-Parameterized-1.11/blib/lib/MooseX/Role/Parameterized.pm line 8.
BEGIN failed--compilation aborted at /[...]/perl-moosex-role-parameterized/src/MooseX-Role-Parameterized-1.11/blib/lib/MooseX/Role/Parameterized.pm line 8.
Compilation failed in require at t/007-excludes.t line 8.
BEGIN failed--compilation aborted at t/007-excludes.t line 8.
t/007-excludes.t .................... Dubious, test returned 2 (wstat 512, 0x200)
No subtests run 
t/008-method-modifers.t ............. Can't locate Devel/OverloadInfo.pm in @INC (you may need to install the Devel::OverloadInfo module) (@INC contains: /[...]/perl-moosex-role-parameterized/src/MooseX-Role-Parameterized-1.11/blib/lib /[...]/perl-moosex-role-parameterized/src/MooseX-Role-Parameterized-1.11/blib/arch /usr/lib/perl5/5.34/site_perl /usr/share/perl5/site_perl /usr/lib/perl5/5.34/vendor_perl /usr/share/perl5/vendor_perl /usr/lib/perl5/5.34/core_perl /usr/share/perl5/core_perl .) at /usr/lib/perl5/5.34/vendor_perl/Class/MOP/Mixin/HasOverloads.pm line 9.
BEGIN failed--compilation aborted at /usr/lib/perl5/5.34/vendor_perl/Class/MOP/Mixin/HasOverloads.pm line 9.
Compilation failed in require at /usr/lib/perl5/5.34/vendor_perl/Class/MOP.pm line 17.
BEGIN failed--compilation aborted at /usr/lib/perl5/5.34/vendor_perl/Class/MOP.pm line 17.
Compilation failed in require at /usr/lib/perl5/5.34/vendor_perl/Moose/Exporter.pm line 8.
BEGIN failed--compilation aborted at /usr/lib/perl5/5.34/vendor_perl/Moose/Exporter.pm line 8.
Compilation failed in require at /usr/lib/perl5/5.34/vendor_perl/Moose.pm line 15.
BEGIN failed--compilation aborted at /usr/lib/perl5/5.34/vendor_perl/Moose.pm line 15.
Compilation failed in require at /[...]/perl-moosex-role-parameterized/src/MooseX-Role-Parameterized-1.11/blib/lib/MooseX/Role/Parameterized.pm line 8.
BEGIN failed--compilation aborted at /[...]/perl-moosex-role-parameterized/src/MooseX-Role-Parameterized-1.11/blib/lib/MooseX/Role/Parameterized.pm line 8.
Compilation failed in require at t/008-method-modifers.t line 9.
BEGIN failed--compilation aborted at t/008-method-modifers.t line 9.
t/008-method-modifers.t ............. Dubious, test returned 2 (wstat 512, 0x200)
No subtests run 
t/009-override-super.t .............. Can't locate Devel/OverloadInfo.pm in @INC (you may need to install the Devel::OverloadInfo module) (@INC contains: /[...]/perl-moosex-role-parameterized/src/MooseX-Role-Parameterized-1.11/blib/lib /[...]/perl-moosex-role-parameterized/src/MooseX-Role-Parameterized-1.11/blib/arch /usr/lib/perl5/5.34/site_perl /usr/share/perl5/site_perl /usr/lib/perl5/5.34/vendor_perl /usr/share/perl5/vendor_perl /usr/lib/perl5/5.34/core_perl /usr/share/perl5/core_perl .) at /usr/lib/perl5/5.34/vendor_perl/Class/MOP/Mixin/HasOverloads.pm line 9.
BEGIN failed--compilation aborted at /usr/lib/perl5/5.34/vendor_perl/Class/MOP/Mixin/HasOverloads.pm line 9.
Compilation failed in require at /usr/lib/perl5/5.34/vendor_perl/Class/MOP.pm line 17.
BEGIN failed--compilation aborted at /usr/lib/perl5/5.34/vendor_perl/Class/MOP.pm line 17.
Compilation failed in require at /usr/lib/perl5/5.34/vendor_perl/Moose/Exporter.pm line 8.
BEGIN failed--compilation aborted at /usr/lib/perl5/5.34/vendor_perl/Moose/Exporter.pm line 8.
Compilation failed in require at /usr/lib/perl5/5.34/vendor_perl/Moose.pm line 15.
BEGIN failed--compilation aborted at /usr/lib/perl5/5.34/vendor_perl/Moose.pm line 15.
Compilation failed in require at /[...]/perl-moosex-role-parameterized/src/MooseX-Role-Parameterized-1.11/blib/lib/MooseX/Role/Parameterized.pm line 8.
BEGIN failed--compilation aborted at /[...]/perl-moosex-role-parameterized/src/MooseX-Role-Parameterized-1.11/blib/lib/MooseX/Role/Parameterized.pm line 8.
Compilation failed in require at t/009-override-super.t line 9.
BEGIN failed--compilation aborted at t/009-override-super.t line 9.
t/009-override-super.t .............. Dubious, test returned 2 (wstat 512, 0x200)
No subtests run 
t/010-blessed-confess.t ............. Can't locate Devel/OverloadInfo.pm in @INC (you may need to install the Devel::OverloadInfo module) (@INC contains: /[...]/perl-moosex-role-parameterized/src/MooseX-Role-Parameterized-1.11/blib/lib /[...]/perl-moosex-role-parameterized/src/MooseX-Role-Parameterized-1.11/blib/arch /usr/lib/perl5/5.34/site_perl /usr/share/perl5/site_perl /usr/lib/perl5/5.34/vendor_perl /usr/share/perl5/vendor_perl /usr/lib/perl5/5.34/core_perl /usr/share/perl5/core_perl .) at /usr/lib/perl5/5.34/vendor_perl/Class/MOP/Mixin/HasOverloads.pm line 9.
BEGIN failed--compilation aborted at /usr/lib/perl5/5.34/vendor_perl/Class/MOP/Mixin/HasOverloads.pm line 9.
Compilation failed in require at /usr/lib/perl5/5.34/vendor_perl/Class/MOP.pm line 17.
BEGIN failed--compilation aborted at /usr/lib/perl5/5.34/vendor_perl/Class/MOP.pm line 17.
Compilation failed in require at /usr/lib/perl5/5.34/vendor_perl/Moose/Exporter.pm line 8.
BEGIN failed--compilation aborted at /usr/lib/perl5/5.34/vendor_perl/Moose/Exporter.pm line 8.
Compilation failed in require at /usr/lib/perl5/5.34/vendor_perl/Moose.pm line 15.
BEGIN failed--compilation aborted at /usr/lib/perl5/5.34/vendor_perl/Moose.pm line 15.
Compilation failed in require at /[...]/perl-moosex-role-parameterized/src/MooseX-Role-Parameterized-1.11/blib/lib/MooseX/Role/Parameterized.pm line 8.
BEGIN failed--compilation aborted at /[...]/perl-moosex-role-parameterized/src/MooseX-Role-Parameterized-1.11/blib/lib/MooseX/Role/Parameterized.pm line 8.
Compilation failed in require at t/010-blessed-confess.t line 7.
BEGIN failed--compilation aborted at t/010-blessed-confess.t line 7.
t/010-blessed-confess.t ............. Dubious, test returned 2 (wstat 512, 0x200)
No subtests run 
t/011-reference-parameters.t ........ Can't locate Devel/OverloadInfo.pm in @INC (you may need to install the Devel::OverloadInfo module) (@INC contains: /[...]/perl-moosex-role-parameterized/src/MooseX-Role-Parameterized-1.11/blib/lib /[...]/perl-moosex-role-parameterized/src/MooseX-Role-Parameterized-1.11/blib/arch /usr/lib/perl5/5.34/site_perl /usr/share/perl5/site_perl /usr/lib/perl5/5.34/vendor_perl /usr/share/perl5/vendor_perl /usr/lib/perl5/5.34/core_perl /usr/share/perl5/core_perl .) at /usr/lib/perl5/5.34/vendor_perl/Class/MOP/Mixin/HasOverloads.pm line 9.
BEGIN failed--compilation aborted at /usr/lib/perl5/5.34/vendor_perl/Class/MOP/Mixin/HasOverloads.pm line 9.
Compilation failed in require at /usr/lib/perl5/5.34/vendor_perl/Class/MOP.pm line 17.
BEGIN failed--compilation aborted at /usr/lib/perl5/5.34/vendor_perl/Class/MOP.pm line 17.
Compilation failed in require at /usr/lib/perl5/5.34/vendor_perl/Moose/Exporter.pm line 8.
BEGIN failed--compilation aborted at /usr/lib/perl5/5.34/vendor_perl/Moose/Exporter.pm line 8.
Compilation failed in require at /usr/lib/perl5/5.34/vendor_perl/Moose.pm line 15.
BEGIN failed--compilation aborted at /usr/lib/perl5/5.34/vendor_perl/Moose.pm line 15.
Compilation failed in require at /[...]/perl-moosex-role-parameterized/src/MooseX-Role-Parameterized-1.11/blib/lib/MooseX/Role/Parameterized.pm line 8.
BEGIN failed--compilation aborted at /[...]/perl-moosex-role-parameterized/src/MooseX-Role-Parameterized-1.11/blib/lib/MooseX/Role/Parameterized.pm line 8.
Compilation failed in require at t/011-reference-parameters.t line 7.
BEGIN failed--compilation aborted at t/011-reference-parameters.t line 7.
t/011-reference-parameters.t ........ Dubious, test returned 2 (wstat 512, 0x200)
No subtests run 
t/012-rename-role.t ................. Can't locate Devel/OverloadInfo.pm in @INC (you may need to install the Devel::OverloadInfo module) (@INC contains: /[...]/perl-moosex-role-parameterized/src/MooseX-Role-Parameterized-1.11/blib/lib /[...]/perl-moosex-role-parameterized/src/MooseX-Role-Parameterized-1.11/blib/arch /usr/lib/perl5/5.34/site_perl /usr/share/perl5/site_perl /usr/lib/perl5/5.34/vendor_perl /usr/share/perl5/vendor_perl /usr/lib/perl5/5.34/core_perl /usr/share/perl5/core_perl .) at /usr/lib/perl5/5.34/vendor_perl/Class/MOP/Mixin/HasOverloads.pm line 9.
BEGIN failed--compilation aborted at /usr/lib/perl5/5.34/vendor_perl/Class/MOP/Mixin/HasOverloads.pm line 9.
Compilation failed in require at /usr/lib/perl5/5.34/vendor_perl/Class/MOP.pm line 17.
BEGIN failed--compilation aborted at /usr/lib/perl5/5.34/vendor_perl/Class/MOP.pm line 17.
Compilation failed in require at /usr/lib/perl5/5.34/vendor_perl/Moose/Exporter.pm line 8.
BEGIN failed--compilation aborted at /usr/lib/perl5/5.34/vendor_perl/Moose/Exporter.pm line 8.
Compilation failed in require at /usr/lib/perl5/5.34/vendor_perl/Moose.pm line 15.
BEGIN failed--compilation aborted at /usr/lib/perl5/5.34/vendor_perl/Moose.pm line 15.
Compilation failed in require at /[...]/perl-moosex-role-parameterized/src/MooseX-Role-Parameterized-1.11/blib/lib/MooseX/Role/Parameterized.pm line 8.
BEGIN failed--compilation aborted at /[...]/perl-moosex-role-parameterized/src/MooseX-Role-Parameterized-1.11/blib/lib/MooseX/Role/Parameterized.pm line 8.
Compilation failed in require at t/012-rename-role.t line 10.
BEGIN failed--compilation aborted at t/012-rename-role.t line 10.
t/012-rename-role.t ................. Dubious, test returned 2 (wstat 512, 0x200)
No subtests run 
t/013-does.t ........................ Can't locate Devel/OverloadInfo.pm in @INC (you may need to install the Devel::OverloadInfo module) (@INC contains: /[...]/perl-moosex-role-parameterized/src/MooseX-Role-Parameterized-1.11/blib/lib /[...]/perl-moosex-role-parameterized/src/MooseX-Role-Parameterized-1.11/blib/arch /usr/lib/perl5/5.34/site_perl /usr/share/perl5/site_perl /usr/lib/perl5/5.34/vendor_perl /usr/share/perl5/vendor_perl /usr/lib/perl5/5.34/core_perl /usr/share/perl5/core_perl .) at /usr/lib/perl5/5.34/vendor_perl/Class/MOP/Mixin/HasOverloads.pm line 9.
BEGIN failed--compilation aborted at /usr/lib/perl5/5.34/vendor_perl/Class/MOP/Mixin/HasOverloads.pm line 9.
Compilation failed in require at /usr/lib/perl5/5.34/vendor_perl/Class/MOP.pm line 17.
BEGIN failed--compilation aborted at /usr/lib/perl5/5.34/vendor_perl/Class/MOP.pm line 17.
Compilation failed in require at /usr/lib/perl5/5.34/vendor_perl/Moose/Util.pm line 42.
Compilation failed in require at /usr/lib/perl5/5.34/vendor_perl/Test/Moose.pm line 11.
BEGIN failed--compilation aborted at /usr/lib/perl5/5.34/vendor_perl/Test/Moose.pm line 11.
Compilation failed in require at t/013-does.t line 4.
BEGIN failed--compilation aborted at t/013-does.t line 4.
t/013-does.t ........................ Dubious, test returned 2 (wstat 512, 0x200)
No subtests run 
t/014-compose-parameterizable.t ..... Can't locate Devel/OverloadInfo.pm in @INC (you may need to install the Devel::OverloadInfo module) (@INC contains: /[...]/perl-moosex-role-parameterized/src/MooseX-Role-Parameterized-1.11/blib/lib /[...]/perl-moosex-role-parameterized/src/MooseX-Role-Parameterized-1.11/blib/arch /usr/lib/perl5/5.34/site_perl /usr/share/perl5/site_perl /usr/lib/perl5/5.34/vendor_perl /usr/share/perl5/vendor_perl /usr/lib/perl5/5.34/core_perl /usr/share/perl5/core_perl .) at /usr/lib/perl5/5.34/vendor_perl/Class/MOP/Mixin/HasOverloads.pm line 9.
BEGIN failed--compilation aborted at /usr/lib/perl5/5.34/vendor_perl/Class/MOP/Mixin/HasOverloads.pm line 9.
Compilation failed in require at /usr/lib/perl5/5.34/vendor_perl/Class/MOP.pm line 17.
BEGIN failed--compilation aborted at /usr/lib/perl5/5.34/vendor_perl/Class/MOP.pm line 17.
Compilation failed in require at /usr/lib/perl5/5.34/vendor_perl/Moose/Exporter.pm line 8.
BEGIN failed--compilation aborted at /usr/lib/perl5/5.34/vendor_perl/Moose/Exporter.pm line 8.
Compilation failed in require at /usr/lib/perl5/5.34/vendor_perl/Moose.pm line 15.
BEGIN failed--compilation aborted at /usr/lib/perl5/5.34/vendor_perl/Moose.pm line 15.
Compilation failed in require at /[...]/perl-moosex-role-parameterized/src/MooseX-Role-Parameterized-1.11/blib/lib/MooseX/Role/Parameterized.pm line 8.
BEGIN failed--compilation aborted at /[...]/perl-moosex-role-parameterized/src/MooseX-Role-Parameterized-1.11/blib/lib/MooseX/Role/Parameterized.pm line 8.
Compilation failed in require at t/014-compose-parameterizable.t line 7.
BEGIN failed--compilation aborted at t/014-compose-parameterizable.t line 7.
t/014-compose-parameterizable.t ..... Dubious, test returned 2 (wstat 512, 0x200)
No subtests run 
t/015-compose-keywords.t ............ Can't locate Devel/OverloadInfo.pm in @INC (you may need to install the Devel::OverloadInfo module) (@INC contains: /[...]/perl-moosex-role-parameterized/src/MooseX-Role-Parameterized-1.11/blib/lib /[...]/perl-moosex-role-parameterized/src/MooseX-Role-Parameterized-1.11/blib/arch /usr/lib/perl5/5.34/site_perl /usr/share/perl5/site_perl /usr/lib/perl5/5.34/vendor_perl /usr/share/perl5/vendor_perl /usr/lib/perl5/5.34/core_perl /usr/share/perl5/core_perl .) at /usr/lib/perl5/5.34/vendor_perl/Class/MOP/Mixin/HasOverloads.pm line 9.
BEGIN failed--compilation aborted at /usr/lib/perl5/5.34/vendor_perl/Class/MOP/Mixin/HasOverloads.pm line 9.
Compilation failed in require at /usr/lib/perl5/5.34/vendor_perl/Class/MOP.pm line 17.
BEGIN failed--compilation aborted at /usr/lib/perl5/5.34/vendor_perl/Class/MOP.pm line 17.
Compilation failed in require at /usr/lib/perl5/5.34/vendor_perl/Moose/Exporter.pm line 8.
BEGIN failed--compilation aborted at /usr/lib/perl5/5.34/vendor_perl/Moose/Exporter.pm line 8.
Compilation failed in require at /usr/lib/perl5/5.34/vendor_perl/Moose.pm line 15.
BEGIN failed--compilation aborted at /usr/lib/perl5/5.34/vendor_perl/Moose.pm line 15.
Compilation failed in require at /usr/lib/perl5/5.34/vendor_perl/Moose/Role.pm line 13.
BEGIN failed--compilation aborted at /usr/lib/perl5/5.34/vendor_perl/Moose/Role.pm line 13.
Compilation failed in require at t/015-compose-keywords.t line 7.
BEGIN failed--compilation aborted at t/015-compose-keywords.t line 7.
t/015-compose-keywords.t ............ Dubious, test returned 2 (wstat 512, 0x200)
No subtests run 
t/016-trait.t ....................... Can't locate Devel/OverloadInfo.pm in @INC (you may need to install the Devel::OverloadInfo module) (@INC contains: /[...]/perl-moosex-role-parameterized/src/MooseX-Role-Parameterized-1.11/blib/lib /[...]/perl-moosex-role-parameterized/src/MooseX-Role-Parameterized-1.11/blib/arch /usr/lib/perl5/5.34/site_perl /usr/share/perl5/site_perl /usr/lib/perl5/5.34/vendor_perl /usr/share/perl5/vendor_perl /usr/lib/perl5/5.34/core_perl /usr/share/perl5/core_perl .) at /usr/lib/perl5/5.34/vendor_perl/Class/MOP/Mixin/HasOverloads.pm line 9.
BEGIN failed--compilation aborted at /usr/lib/perl5/5.34/vendor_perl/Class/MOP/Mixin/HasOverloads.pm line 9.
Compilation failed in require at /usr/lib/perl5/5.34/vendor_perl/Class/MOP.pm line 17.
BEGIN failed--compilation aborted at /usr/lib/perl5/5.34/vendor_perl/Class/MOP.pm line 17.
Compilation failed in require at /usr/lib/perl5/5.34/vendor_perl/Moose/Exporter.pm line 8.
BEGIN failed--compilation aborted at /usr/lib/perl5/5.34/vendor_perl/Moose/Exporter.pm line 8.
Compilation failed in require at /usr/lib/perl5/5.34/vendor_perl/Moose.pm line 15.
BEGIN failed--compilation aborted at /usr/lib/perl5/5.34/vendor_perl/Moose.pm line 15.
Compilation failed in require at /[...]/perl-moosex-role-parameterized/src/MooseX-Role-Parameterized-1.11/blib/lib/MooseX/Role/Parameterized.pm line 8.
BEGIN failed--compilation aborted at /[...]/perl-moosex-role-parameterized/src/MooseX-Role-Parameterized-1.11/blib/lib/MooseX/Role/Parameterized.pm line 8.
Compilation failed in require at t/016-trait.t line 8.
BEGIN failed--compilation aborted at t/016-trait.t line 8.
t/016-trait.t ....................... Dubious, test returned 2 (wstat 512, 0x200)
No subtests run 
t/017-current_metaclass.t ........... Can't locate Devel/OverloadInfo.pm in @INC (you may need to install the Devel::OverloadInfo module) (@INC contains: /[...]/perl-moosex-role-parameterized/src/MooseX-Role-Parameterized-1.11/blib/lib /[...]/perl-moosex-role-parameterized/src/MooseX-Role-Parameterized-1.11/blib/arch /usr/lib/perl5/5.34/site_perl /usr/share/perl5/site_perl /usr/lib/perl5/5.34/vendor_perl /usr/share/perl5/vendor_perl /usr/lib/perl5/5.34/core_perl /usr/share/perl5/core_perl .) at /usr/lib/perl5/5.34/vendor_perl/Class/MOP/Mixin/HasOverloads.pm line 9.
BEGIN failed--compilation aborted at /usr/lib/perl5/5.34/vendor_perl/Class/MOP/Mixin/HasOverloads.pm line 9.
Compilation failed in require at /usr/lib/perl5/5.34/vendor_perl/Class/MOP.pm line 17.
BEGIN failed--compilation aborted at /usr/lib/perl5/5.34/vendor_perl/Class/MOP.pm line 17.
Compilation failed in require at /usr/lib/perl5/5.34/vendor_perl/Moose/Exporter.pm line 8.
BEGIN failed--compilation aborted at /usr/lib/perl5/5.34/vendor_perl/Moose/Exporter.pm line 8.
Compilation failed in require at /usr/lib/perl5/5.34/vendor_perl/Moose.pm line 15.
BEGIN failed--compilation aborted at /usr/lib/perl5/5.34/vendor_perl/Moose.pm line 15.
Compilation failed in require at /[...]/perl-moosex-role-parameterized/src/MooseX-Role-Parameterized-1.11/blib/lib/MooseX/Role/Parameterized.pm line 8.
BEGIN failed--compilation aborted at /[...]/perl-moosex-role-parameterized/src/MooseX-Role-Parameterized-1.11/blib/lib/MooseX/Role/Parameterized.pm line 8.
Compilation failed in require at t/017-current_metaclass.t line 7.
BEGIN failed--compilation aborted at t/017-current_metaclass.t line 7.
t/017-current_metaclass.t ........... Dubious, test returned 2 (wstat 512, 0x200)
No subtests run 
t/018-parameter-roles.t ............. skipped: Not implemented yet
t/020-metaclass-reinitialize.t ...... Can't locate Devel/OverloadInfo.pm in @INC (you may need to install the Devel::OverloadInfo module) (@INC contains: /[...]/perl-moosex-role-parameterized/src/MooseX-Role-Parameterized-1.11/blib/lib /[...]/perl-moosex-role-parameterized/src/MooseX-Role-Parameterized-1.11/blib/arch /usr/lib/perl5/5.34/site_perl /usr/share/perl5/site_perl /usr/lib/perl5/5.34/vendor_perl /usr/share/perl5/vendor_perl /usr/lib/perl5/5.34/core_perl /usr/share/perl5/core_perl .) at /usr/lib/perl5/5.34/vendor_perl/Class/MOP/Mixin/HasOverloads.pm line 9.
BEGIN failed--compilation aborted at /usr/lib/perl5/5.34/vendor_perl/Class/MOP/Mixin/HasOverloads.pm line 9.
Compilation failed in require at /usr/lib/perl5/5.34/vendor_perl/Class/MOP.pm line 17.
BEGIN failed--compilation aborted at /usr/lib/perl5/5.34/vendor_perl/Class/MOP.pm line 17.
Compilation failed in require at /usr/lib/perl5/5.34/vendor_perl/Moose/Exporter.pm line 8.
BEGIN failed--compilation aborted at /usr/lib/perl5/5.34/vendor_perl/Moose/Exporter.pm line 8.
Compilation failed in require at /usr/lib/perl5/5.34/vendor_perl/Moose.pm line 15.
BEGIN failed--compilation aborted at /usr/lib/perl5/5.34/vendor_perl/Moose.pm line 15.
Compilation failed in require at t/020-metaclass-reinitialize.t line 6.
BEGIN failed--compilation aborted at t/020-metaclass-reinitialize.t line 10.
t/020-metaclass-reinitialize.t ...... Dubious, test returned 2 (wstat 512, 0x200)
No subtests run 
t/021-parameter-trait.t ............. Can't locate Devel/OverloadInfo.pm in @INC (you may need to install the Devel::OverloadInfo module) (@INC contains: /[...]/perl-moosex-role-parameterized/src/MooseX-Role-Parameterized-1.11/blib/lib /[...]/perl-moosex-role-parameterized/src/MooseX-Role-Parameterized-1.11/blib/arch /usr/lib/perl5/5.34/site_perl /usr/share/perl5/site_perl /usr/lib/perl5/5.34/vendor_perl /usr/share/perl5/vendor_perl /usr/lib/perl5/5.34/core_perl /usr/share/perl5/core_perl .) at /usr/lib/perl5/5.34/vendor_perl/Class/MOP/Mixin/HasOverloads.pm line 9.
BEGIN failed--compilation aborted at /usr/lib/perl5/5.34/vendor_perl/Class/MOP/Mixin/HasOverloads.pm line 9.
Compilation failed in require at /usr/lib/perl5/5.34/vendor_perl/Class/MOP.pm line 17.
BEGIN failed--compilation aborted at /usr/lib/perl5/5.34/vendor_perl/Class/MOP.pm line 17.
Compilation failed in require at /usr/lib/perl5/5.34/vendor_perl/Moose/Exporter.pm line 8.
BEGIN failed--compilation aborted at /usr/lib/perl5/5.34/vendor_perl/Moose/Exporter.pm line 8.
Compilation failed in require at /usr/lib/perl5/5.34/vendor_perl/Moose.pm line 15.
BEGIN failed--compilation aborted at /usr/lib/perl5/5.34/vendor_perl/Moose.pm line 15.
Compilation failed in require at /usr/lib/perl5/5.34/vendor_perl/Moose/Role.pm line 13.
BEGIN failed--compilation aborted at /usr/lib/perl5/5.34/vendor_perl/Moose/Role.pm line 13.
Compilation failed in require at t/021-parameter-trait.t line 7.
BEGIN failed--compilation aborted at t/021-parameter-trait.t line 7.
t/021-parameter-trait.t ............. Dubious, test returned 2 (wstat 512, 0x200)
No subtests run 
t/022-export-p-trait.t .............. Can't locate Devel/OverloadInfo.pm in @INC (you may need to install the Devel::OverloadInfo module) (@INC contains: /[...]/perl-moosex-role-parameterized/src/MooseX-Role-Parameterized-1.11/blib/lib /[...]/perl-moosex-role-parameterized/src/MooseX-Role-Parameterized-1.11/blib/arch /usr/lib/perl5/5.34/site_perl /usr/share/perl5/site_perl /usr/lib/perl5/5.34/vendor_perl /usr/share/perl5/vendor_perl /usr/lib/perl5/5.34/core_perl /usr/share/perl5/core_perl .) at /usr/lib/perl5/5.34/vendor_perl/Class/MOP/Mixin/HasOverloads.pm line 9.
BEGIN failed--compilation aborted at /usr/lib/perl5/5.34/vendor_perl/Class/MOP/Mixin/HasOverloads.pm line 9.
Compilation failed in require at /usr/lib/perl5/5.34/vendor_perl/Class/MOP.pm line 17.
BEGIN failed--compilation aborted at /usr/lib/perl5/5.34/vendor_perl/Class/MOP.pm line 17.
Compilation failed in require at /usr/lib/perl5/5.34/vendor_perl/Moose/Exporter.pm line 8.
BEGIN failed--compilation aborted at /usr/lib/perl5/5.34/vendor_perl/Moose/Exporter.pm line 8.
Compilation failed in require at /usr/lib/perl5/5.34/vendor_perl/Moose.pm line 15.
BEGIN failed--compilation aborted at /usr/lib/perl5/5.34/vendor_perl/Moose.pm line 15.
Compilation failed in require at /[...]/perl-moosex-role-parameterized/src/MooseX-Role-Parameterized-1.11/blib/lib/MooseX/Role/Parameterized.pm line 8.
BEGIN failed--compilation aborted at /[...]/perl-moosex-role-parameterized/src/MooseX-Role-Parameterized-1.11/blib/lib/MooseX/Role/Parameterized.pm line 8.
Compilation failed in require at t/022-export-p-trait.t line 7.
BEGIN failed--compilation aborted at t/022-export-p-trait.t line 7.
t/022-export-p-trait.t .............. Dubious, test returned 2 (wstat 512, 0x200)
No subtests run 
t/023-metarole-import-params.t ...... skipped: Not implemented yet
t/024-named-anonymous.t ............. Can't locate Devel/OverloadInfo.pm in @INC (you may need to install the Devel::OverloadInfo module) (@INC contains: /[...]/perl-moosex-role-parameterized/src/MooseX-Role-Parameterized-1.11/blib/lib /[...]/perl-moosex-role-parameterized/src/MooseX-Role-Parameterized-1.11/blib/arch /usr/lib/perl5/5.34/site_perl /usr/share/perl5/site_perl /usr/lib/perl5/5.34/vendor_perl /usr/share/perl5/vendor_perl /usr/lib/perl5/5.34/core_perl /usr/share/perl5/core_perl .) at /usr/lib/perl5/5.34/vendor_perl/Class/MOP/Mixin/HasOverloads.pm line 9.
BEGIN failed--compilation aborted at /usr/lib/perl5/5.34/vendor_perl/Class/MOP/Mixin/HasOverloads.pm line 9.
Compilation failed in require at /usr/lib/perl5/5.34/vendor_perl/Class/MOP.pm line 17.
BEGIN failed--compilation aborted at /usr/lib/perl5/5.34/vendor_perl/Class/MOP.pm line 17.
Compilation failed in require at /usr/lib/perl5/5.34/vendor_perl/Moose/Exporter.pm line 8.
BEGIN failed--compilation aborted at /usr/lib/perl5/5.34/vendor_perl/Moose/Exporter.pm line 8.
Compilation failed in require at /usr/lib/perl5/5.34/vendor_perl/Moose.pm line 15.
BEGIN failed--compilation aborted at /usr/lib/perl5/5.34/vendor_perl/Moose.pm line 15.
Compilation failed in require at /[...]/perl-moosex-role-parameterized/src/MooseX-Role-Parameterized-1.11/blib/lib/MooseX/Role/Parameterized.pm line 8.
BEGIN failed--compilation aborted at /[...]/perl-moosex-role-parameterized/src/MooseX-Role-Parameterized-1.11/blib/lib/MooseX/Role/Parameterized.pm line 8.
Compilation failed in require at t/024-named-anonymous.t line 7.
BEGIN failed--compilation aborted at t/024-named-anonymous.t line 7.
t/024-named-anonymous.t ............. Dubious, test returned 2 (wstat 512, 0x200)
No subtests run 
t/100-erroneous-keywords.t .......... Can't locate Devel/OverloadInfo.pm in @INC (you may need to install the Devel::OverloadInfo module) (@INC contains: /[...]/perl-moosex-role-parameterized/src/MooseX-Role-Parameterized-1.11/blib/lib /[...]/perl-moosex-role-parameterized/src/MooseX-Role-Parameterized-1.11/blib/arch /usr/lib/perl5/5.34/site_perl /usr/share/perl5/site_perl /usr/lib/perl5/5.34/vendor_perl /usr/share/perl5/vendor_perl /usr/lib/perl5/5.34/core_perl /usr/share/perl5/core_perl .) at /usr/lib/perl5/5.34/vendor_perl/Class/MOP/Mixin/HasOverloads.pm line 9.
BEGIN failed--compilation aborted at /usr/lib/perl5/5.34/vendor_perl/Class/MOP/Mixin/HasOverloads.pm line 9.
Compilation failed in require at /usr/lib/perl5/5.34/vendor_perl/Class/MOP.pm line 17.
BEGIN failed--compilation aborted at /usr/lib/perl5/5.34/vendor_perl/Class/MOP.pm line 17.
Compilation failed in require at /usr/lib/perl5/5.34/vendor_perl/Moose/Exporter.pm line 8.
BEGIN failed--compilation aborted at /usr/lib/perl5/5.34/vendor_perl/Moose/Exporter.pm line 8.
Compilation failed in require at /usr/lib/perl5/5.34/vendor_perl/Moose.pm line 15.
BEGIN failed--compilation aborted at /usr/lib/perl5/5.34/vendor_perl/Moose.pm line 15.
Compilation failed in require at /[...]/perl-moosex-role-parameterized/src/MooseX-Role-Parameterized-1.11/blib/lib/MooseX/Role/Parameterized.pm line 8.
BEGIN failed--compilation aborted at /[...]/perl-moosex-role-parameterized/src/MooseX-Role-Parameterized-1.11/blib/lib/MooseX/Role/Parameterized.pm line 8.
Compilation failed in require at t/100-erroneous-keywords.t line 8.
BEGIN failed--compilation aborted at t/100-erroneous-keywords.t line 8.
t/100-erroneous-keywords.t .......... Dubious, test returned 2 (wstat 512, 0x200)
No subtests run 
t/101-alias-excludes.t .............. Can't locate Devel/OverloadInfo.pm in @INC (you may need to install the Devel::OverloadInfo module) (@INC contains: /[...]/perl-moosex-role-parameterized/src/MooseX-Role-Parameterized-1.11/blib/lib /[...]/perl-moosex-role-parameterized/src/MooseX-Role-Parameterized-1.11/blib/arch /usr/lib/perl5/5.34/site_perl /usr/share/perl5/site_perl /usr/lib/perl5/5.34/vendor_perl /usr/share/perl5/vendor_perl /usr/lib/perl5/5.34/core_perl /usr/share/perl5/core_perl .) at /usr/lib/perl5/5.34/vendor_perl/Class/MOP/Mixin/HasOverloads.pm line 9.
BEGIN failed--compilation aborted at /usr/lib/perl5/5.34/vendor_perl/Class/MOP/Mixin/HasOverloads.pm line 9.
Compilation failed in require at /usr/lib/perl5/5.34/vendor_perl/Class/MOP.pm line 17.
BEGIN failed--compilation aborted at /usr/lib/perl5/5.34/vendor_perl/Class/MOP.pm line 17.
Compilation failed in require at /usr/lib/perl5/5.34/vendor_perl/Moose/Exporter.pm line 8.
BEGIN failed--compilation aborted at /usr/lib/perl5/5.34/vendor_perl/Moose/Exporter.pm line 8.
Compilation failed in require at /usr/lib/perl5/5.34/vendor_perl/Moose.pm line 15.
BEGIN failed--compilation aborted at /usr/lib/perl5/5.34/vendor_perl/Moose.pm line 15.
Compilation failed in require at /[...]/perl-moosex-role-parameterized/src/MooseX-Role-Parameterized-1.11/blib/lib/MooseX/Role/Parameterized.pm line 8.
BEGIN failed--compilation aborted at /[...]/perl-moosex-role-parameterized/src/MooseX-Role-Parameterized-1.11/blib/lib/MooseX/Role/Parameterized.pm line 8.
Compilation failed in require at t/101-alias-excludes.t line 8.
BEGIN failed--compilation aborted at t/101-alias-excludes.t line 8.
t/101-alias-excludes.t .............. Dubious, test returned 2 (wstat 512, 0x200)
No subtests run 
t/102-nested.t ...................... Can't locate Devel/OverloadInfo.pm in @INC (you may need to install the Devel::OverloadInfo module) (@INC contains: t/lib /[...]/perl-moosex-role-parameterized/src/MooseX-Role-Parameterized-1.11/blib/lib /[...]/perl-moosex-role-parameterized/src/MooseX-Role-Parameterized-1.11/blib/arch /usr/lib/perl5/5.34/site_perl /usr/share/perl5/site_perl /usr/lib/perl5/5.34/vendor_perl /usr/share/perl5/vendor_perl /usr/lib/perl5/5.34/core_perl /usr/share/perl5/core_perl .) at /usr/lib/perl5/5.34/vendor_perl/Class/MOP/Mixin/HasOverloads.pm line 9.
BEGIN failed--compilation aborted at /usr/lib/perl5/5.34/vendor_perl/Class/MOP/Mixin/HasOverloads.pm line 9.
Compilation failed in require at /usr/lib/perl5/5.34/vendor_perl/Class/MOP.pm line 17.
BEGIN failed--compilation aborted at /usr/lib/perl5/5.34/vendor_perl/Class/MOP.pm line 17.
Compilation failed in require at /usr/lib/perl5/5.34/vendor_perl/Moose/Exporter.pm line 8.
BEGIN failed--compilation aborted at /usr/lib/perl5/5.34/vendor_perl/Moose/Exporter.pm line 8.
Compilation failed in require at /usr/lib/perl5/5.34/vendor_perl/Moose.pm line 15.
BEGIN failed--compilation aborted at /usr/lib/perl5/5.34/vendor_perl/Moose.pm line 15.
Compilation failed in require at /[...]/perl-moosex-role-parameterized/src/MooseX-Role-Parameterized-1.11/blib/lib/MooseX/Role/Parameterized.pm line 8.
BEGIN failed--compilation aborted at /[...]/perl-moosex-role-parameterized/src/MooseX-Role-Parameterized-1.11/blib/lib/MooseX/Role/Parameterized.pm line 8.
Compilation failed in require at t/102-nested.t line 10.
BEGIN failed--compilation aborted at t/102-nested.t line 10.
t/102-nested.t ...................... Dubious, test returned 2 (wstat 512, 0x200)
No subtests run 
t/150-composite-role-application.t .. Can't locate Devel/OverloadInfo.pm in @INC (you may need to install the Devel::OverloadInfo module) (@INC contains: /[...]/perl-moosex-role-parameterized/src/MooseX-Role-Parameterized-1.11/blib/lib /[...]/perl-moosex-role-parameterized/src/MooseX-Role-Parameterized-1.11/blib/arch /usr/lib/perl5/5.34/site_perl /usr/share/perl5/site_perl /usr/lib/perl5/5.34/vendor_perl /usr/share/perl5/vendor_perl /usr/lib/perl5/5.34/core_perl /usr/share/perl5/core_perl .) at /usr/lib/perl5/5.34/vendor_perl/Class/MOP/Mixin/HasOverloads.pm line 9.
BEGIN failed--compilation aborted at /usr/lib/perl5/5.34/vendor_perl/Class/MOP/Mixin/HasOverloads.pm line 9.
Compilation failed in require at /usr/lib/perl5/5.34/vendor_perl/Class/MOP.pm line 17.
BEGIN failed--compilation aborted at /usr/lib/perl5/5.34/vendor_perl/Class/MOP.pm line 17.
Compilation failed in require at /usr/lib/perl5/5.34/vendor_perl/Moose/Exporter.pm line 8.
BEGIN failed--compilation aborted at /usr/lib/perl5/5.34/vendor_perl/Moose/Exporter.pm line 8.
Compilation failed in require at /usr/lib/perl5/5.34/vendor_perl/Moose.pm line 15.
BEGIN failed--compilation aborted at /usr/lib/perl5/5.34/vendor_perl/Moose.pm line 15.
Compilation failed in require at /[...]/perl-moosex-role-parameterized/src/MooseX-Role-Parameterized-1.11/blib/lib/MooseX/Role/Parameterized.pm line 8.
BEGIN failed--compilation aborted at /[...]/perl-moosex-role-parameterized/src/MooseX-Role-Parameterized-1.11/blib/lib/MooseX/Role/Parameterized.pm line 8.
Compilation failed in require at t/150-composite-role-application.t line 7.
BEGIN failed--compilation aborted at t/150-composite-role-application.t line 7.
t/150-composite-role-application.t .. Dubious, test returned 2 (wstat 512, 0x200)
No subtests run 
t/200-cooperative.t ................. skipped: Need MooseX::Role::WithOverloading 0.14
t/zzz-check-breaks.t ................ 1/3 Warning: MooseX::Role::Parameterized did not compile at /usr/share/perl5/vendor_perl/Dist/CheckConflicts.pm line 184.
Warning: Class::MOP did not compile at /usr/share/perl5/vendor_perl/Dist/CheckConflicts.pm line 184.
# Conflicts detected for Moose:
#   Class::MOP is version unknown, but must be greater than version 1.08
#   MooseX::Role::Parameterized is version unknown, but must be greater than version 1.00
t/zzz-check-breaks.t ................ ok   

Test Summary Report
-------------------
t/001-parameters.t                (Wstat: 512 Tests: 0 Failed: 0)
  Non-zero exit status: 2
  Parse errors: No plan found in TAP output
t/002-role-block.t                (Wstat: 512 Tests: 0 Failed: 0)
  Non-zero exit status: 2
  Parse errors: No plan found in TAP output
t/003-apply.t                     (Wstat: 512 Tests: 0 Failed: 0)
  Non-zero exit status: 2
  Parse errors: No plan found in TAP output
t/004-with.t                      (Wstat: 512 Tests: 0 Failed: 0)
  Non-zero exit status: 2
  Parse errors: No plan found in TAP output
t/005-with-parameterized.t        (Wstat: 512 Tests: 0 Failed: 0)
  Non-zero exit status: 2
  Parse errors: No plan found in TAP output
t/006-requires.t                  (Wstat: 512 Tests: 0 Failed: 0)
  Non-zero exit status: 2
  Parse errors: No plan found in TAP output
t/007-excludes.t                  (Wstat: 512 Tests: 0 Failed: 0)
  Non-zero exit status: 2
  Parse errors: No plan found in TAP output
t/008-method-modifers.t           (Wstat: 512 Tests: 0 Failed: 0)
  Non-zero exit status: 2
  Parse errors: No plan found in TAP output
t/009-override-super.t            (Wstat: 512 Tests: 0 Failed: 0)
  Non-zero exit status: 2
  Parse errors: No plan found in TAP output
t/010-blessed-confess.t           (Wstat: 512 Tests: 0 Failed: 0)
  Non-zero exit status: 2
  Parse errors: No plan found in TAP output
t/011-reference-parameters.t      (Wstat: 512 Tests: 0 Failed: 0)
  Non-zero exit status: 2
  Parse errors: No plan found in TAP output
t/012-rename-role.t               (Wstat: 512 Tests: 0 Failed: 0)
  Non-zero exit status: 2
  Parse errors: No plan found in TAP output
t/013-does.t                      (Wstat: 512 Tests: 0 Failed: 0)
  Non-zero exit status: 2
  Parse errors: No plan found in TAP output
t/014-compose-parameterizable.t   (Wstat: 512 Tests: 0 Failed: 0)
  Non-zero exit status: 2
  Parse errors: No plan found in TAP output
t/015-compose-keywords.t          (Wstat: 512 Tests: 0 Failed: 0)
  Non-zero exit status: 2
  Parse errors: No plan found in TAP output
t/016-trait.t                     (Wstat: 512 Tests: 0 Failed: 0)
  Non-zero exit status: 2
  Parse errors: No plan found in TAP output
t/017-current_metaclass.t         (Wstat: 512 Tests: 0 Failed: 0)
  Non-zero exit status: 2
  Parse errors: No plan found in TAP output
t/020-metaclass-reinitialize.t    (Wstat: 512 Tests: 0 Failed: 0)
  Non-zero exit status: 2
  Parse errors: No plan found in TAP output
t/021-parameter-trait.t           (Wstat: 512 Tests: 0 Failed: 0)
  Non-zero exit status: 2
  Parse errors: No plan found in TAP output
t/022-export-p-trait.t            (Wstat: 512 Tests: 0 Failed: 0)
  Non-zero exit status: 2
  Parse errors: No plan found in TAP output
t/024-named-anonymous.t           (Wstat: 512 Tests: 0 Failed: 0)
  Non-zero exit status: 2
  Parse errors: No plan found in TAP output
t/100-erroneous-keywords.t        (Wstat: 512 Tests: 0 Failed: 0)
  Non-zero exit status: 2
  Parse errors: No plan found in TAP output
t/101-alias-excludes.t            (Wstat: 512 Tests: 0 Failed: 0)
  Non-zero exit status: 2
  Parse errors: No plan found in TAP output
t/102-nested.t                    (Wstat: 512 Tests: 0 Failed: 0)
  Non-zero exit status: 2
  Parse errors: No plan found in TAP output
t/150-composite-role-application.t (Wstat: 512 Tests: 0 Failed: 0)
  Non-zero exit status: 2
  Parse errors: No plan found in TAP output
Files=30, Tests=4,  5 wallclock secs ( 0.15 usr  0.05 sys +  4.00 cusr  0.62 csys =  4.82 CPU)
Result: FAIL
Failed 25/30 test programs. 0/4 subtests failed.
make: *** [Makefile:928: test_dynamic] Error 255
==> ERROR: A failure occurred in check().

Thanks for maintaining!

3ED_0 commented on 2018-02-22 17:38 (UTC)

Please, add prevention from installing into Local::Lib directory... https://wiki.archlinux.org/index.php/Perl_package_guidelines#PKGBUILD_Examples

hexadecagram commented on 2017-08-13 03:25 (UTC)

If I bump $pkgver and $source to 1.10 and set $md5sums and $sha512sums to ('SKIP'), the package builds and installs fine. @bidulock could we get an updated PKGBUILD with the correct checksums?

thaewrapt commented on 2017-07-10 19:27 (UTC)

http://www.cpan.org/authors/id/E/ET/ETHER/MooseX-Role-Parameterized-1.09.tar.gz http://www.cpan.org/authors/id/E/ET/ETHER/MooseX-Role-Parameterized-1.10.tar.gz Those files do actually exist now, while 1.08 version does not.

xRemaLx commented on 2015-10-18 13:42 (UTC)

Please add perl-namespace-autoclean to depends

ryvasy commented on 2013-05-31 15:17 (UTC)

$srcdir is no longer available outside build()

chimeracoder commented on 2013-05-07 20:13 (UTC)

Apparently this is a bug that was introduced in makepkg 4.1 (see https://aur.archlinux.org/packages/perl-moosex-types/). Let me take a look and see if I can fix it with the new version of cpan2aur.

seschwar commented on 2013-04-18 15:00 (UTC)

Does not build with makepkg from pacman 4.1.0: ==> Starting build()... /tmp/makepkg-seschwar/perl-moosex-role-parameterized/PKGBUILD: line 26: cd: /MooseX-Role-Parameterized-1.00: No such file or directory ==> ERROR: A failure occurred in build(). Aborting...

sholmes88 commented on 2011-06-15 05:33 (UTC)

yES, THE PACKAGE BUILDS NOW; THANKS MUCH FOR THE FIX.

commented on 2011-06-15 03:07 (UTC)

Uploaded the new version. Sorry I forgot to check my mail for awhile.

sholmes88 commented on 2011-06-06 06:11 (UTC)

It also fails to build for me too and I'm running perl 5.12. 5 tests run; 3 failed. Failing tests are 1, 3, 4. Since this is broken, I cannot continue any further with building perl-net-twitter as iot depends on this package.

commented on 2011-06-02 02:29 (UTC)

Failing to build for me with the new perl 5.14 in [testing] makepkg output: http://paste.pocoo.org/show/399221/