Package Details: perl-moosex-role-parameterized 1.08-2

Git Clone URL: https://aur.archlinux.org/perl-moosex-role-parameterized.git (read-only)
Package Base: perl-moosex-role-parameterized
Description: roles with composition parameters
Upstream URL: http://search.cpan.org/dist/MooseX-Role-Parameterized
Licenses: GPL, PerlArtistic
Submitter: None
Maintainer: bidulock
Last Packager: bidulock
Votes: 14
Popularity: 0.020252
First Submitted: 2009-04-21 18:45
Last Updated: 2015-10-18 15:57

Latest Comments

xRemaLx commented on 2015-10-18 13:42

Please add perl-namespace-autoclean to depends

ryvasy commented on 2013-05-31 15:17

$srcdir is no longer available outside build()

chimeracoder commented on 2013-05-07 20:13

Apparently this is a bug that was introduced in makepkg 4.1 (see https://aur.archlinux.org/packages/perl-moosex-types/).

Let me take a look and see if I can fix it with the new version of cpan2aur.

seschwar commented on 2013-04-18 15:00

Does not build with makepkg from pacman 4.1.0:

==> Starting build()...
/tmp/makepkg-seschwar/perl-moosex-role-parameterized/PKGBUILD: line 26: cd: /MooseX-Role-Parameterized-1.00: No such file or directory
==> ERROR: A failure occurred in build().
Aborting...

sholmes88 commented on 2011-06-15 05:33

yES, THE PACKAGE BUILDS NOW; THANKS MUCH FOR THE FIX.

Anonymous comment on 2011-06-15 03:07

Uploaded the new version. Sorry I forgot to check my mail for awhile.

sholmes88 commented on 2011-06-06 06:11

It also fails to build for me too and I'm running perl 5.12. 5 tests run; 3 failed. Failing tests are 1, 3, 4. Since this is broken, I cannot continue any further with building perl-net-twitter as iot depends on this package.

Anonymous comment on 2011-06-02 02:29

Failing to build for me with the new perl 5.14 in [testing]

makepkg output: http://paste.pocoo.org/show/399221/