Package Details: perl-net-cups 0.64-1

Git Clone URL: https://aur.archlinux.org/perl-net-cups.git (read-only, click to copy)
Package Base: perl-net-cups
Description: Common Unix Printing System Interface
Upstream URL: https://metacpan.org/release/Net-CUPS
Licenses: GPL, PerlArtistic
Submitter: sputnick
Maintainer: guzzisti
Last Packager: guzzisti
Votes: 5
Popularity: 0.000001
First Submitted: 2010-03-19 18:26 (UTC)
Last Updated: 2020-07-03 06:20 (UTC)

Latest Comments

1 2 Next › Last »

nukedupe commented on 2024-02-19 16:18 (UTC)

Build is broken. In file included from CUPS.xs:27: const-c.inc: In function ‘constant_14’: const-c.inc:730:20: error: ‘CUPS_IMAGE_RGB’ undeclared (first use in this function); did you mean ‘CF_IMAGE_RGB’? 730 | *iv_return = CUPS_IMAGE_RGB; | ^~~~~~~~~~~~~~ | CF_IMAGE_RGB

Looks like this: https://rt.cpan.org/Public/Bug/Display.html?id=150529

Markus.N commented on 2020-07-12 17:15 (UTC)

I've found my mistake ... I didn't do a clean rebuild. I'm using yay for AUR packages, and I usually like to see the differences in the packages, that's why I'm used to build without cleaning. In this case, a clean was needed.

guzzisti commented on 2020-07-03 06:20 (UTC)

@jakeobsen Thanks for the hint, i've added the dep.

jakeobsen commented on 2020-07-02 17:19 (UTC) (edited on 2020-07-02 17:26 (UTC) by jakeobsen)

Hi, I'm on a fresh install of arch and I'm trying to install perl-net-cups, however it fails to build. I have tracked it down to a missing dependency of: cups-filters

Please add this package as a dependency.

Markus.N commented on 2020-06-30 13:16 (UTC)

Yes, I've rebuilt.

Markus.N commented on 2020-06-29 21:00 (UTC)

Yes, the perl update was several weeks ago. And several reboots. :-) I just tried to fix the pacman warning about remaining perl packages in 5.30. All packages except this one succeeded by reinstalling.

severach commented on 2020-06-29 19:39 (UTC)

then reinstalled

A reboot isn't necessary. Does reinstalled mean installed same package or rebuild? You need to rebuild.

guzzisti commented on 2020-06-29 08:52 (UTC)

@Markus.N: Just tried myself and it successfully installs in /usr/lib/perl5/5.32/

Have you rebooted after updating to Perl 5.32?

Markus.N commented on 2020-06-29 07:40 (UTC)

Always installs into /usr/lib/perl5/5.30, even though perl has been updated to 5.32. Just did pacman -R perl-net-cups, then reinstalled, and is still in 5.30.

leong commented on 2015-01-18 13:32 (UTC)

Should be flagged out of date