Package Details: perl-net-cups 0.61-1

Git Clone URL: https://aur.archlinux.org/perl-net-cups.git (read-only)
Package Base: perl-net-cups
Description: Common Unix Printing System Interface
Upstream URL: http://search.cpan.org/dist/Net-CUPS
Licenses: GPL, PerlArtistic
Submitter: sputnick
Maintainer: jnbek
Last Packager: jnbek
Votes: 3
Popularity: 0.000000
First Submitted: 2010-03-19 18:26
Last Updated: 2015-06-16 21:34

Dependencies (6)

Required by (0)

Sources (1)

Latest Comments

leong commented on 2015-01-18 13:32

Should be flagged out of date

leong commented on 2015-01-18 13:31

cups version too old ????

cups and libcups Version: 2.0.1-1
cups-filters Version: 1.0.62-1

prompt$ yaourt -S perl-net-cups

Net::CUPS Configuration
Running cups-config ... 2.0.1
The version of the Common Unix Printing System installed
on your system is too old for this module to work properly.
Please upgrade the version of CUPS on your system to version
1.2.2 or higher and re-run Makefile.PL to install this module.

2.0.1 > 1.2.2 How could my cups version be too old ?

I tried to force my cups version to 1.2.2 in Makefile.pl but the compilation stops with many warnings and errors.

jnbek commented on 2013-10-15 21:29

yea, it won't build for me either:
[1] + continued yaourt -S perl-net-cups
==> perl-net-cups dependencies:
- e2fsprogs>=1.42.8 (already installed)
- glibc>=2.17 (already installed)
- krb5>=1.11.3 (already installed)
- libcups (already installed)
- perl (already installed)
- zlib>=1.2.8 (already installed)


==> Edit PKGBUILD ? [Y/n] ("A" to abort)
==> ------------------------------------
==> n

==> Continue building perl-net-cups ? [Y/n]
==> ---------------------------------------
==>
==> Building and installing package
==> Making package: perl-net-cups 0.61-1 (Tue Oct 15 15:28:47 MDT 2013)
==> Checking runtime dependencies...
==> Checking buildtime dependencies...
==> Retrieving sources...
-> Found Net-CUPS-0.61.tar.gz
==> Validating source files with md5sums...
Net-CUPS-0.61.tar.gz ... Passed
==> Validating source files with sha512sums...
Net-CUPS-0.61.tar.gz ... Passed
==> Extracting sources...
-> Extracting Net-CUPS-0.61.tar.gz with bsdtar
==> Removing existing pkg/ directory...
==> Starting build()...
Net::CUPS Configuration
Running cups-config ... 1.6.4
Writing Makefile for Net::CUPS
Writing MYMETA.yml and MYMETA.json
Skip blib/lib/Net/CUPS/Destination.pm (unchanged)
Skip blib/lib/Net/CUPS/PPD.pm (unchanged)
Skip blib/lib/Net/CUPS/IPP.pm (unchanged)
Skip blib/lib/Net/CUPS.pm (unchanged)
cc -c -D_REENTRANT -D_GNU_SOURCE -fno-strict-aliasing -pipe -fstack-protector -I/usr/local/include -D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64 -march=x86-64 -mtune=generic -O2 -pipe -fstack-protector --param=ssp-buffer-size=4 -DVERSION=\"0.61\" -DXS_VERSION=\"0.61\" -fPIC "-I/usr/lib/perl5/core_perl/CORE" CUPS.c
CUPS.xs:10:24: fatal error: cups/image.h: No such file or directory
#include <cups/image.h>
^
compilation terminated.
make: *** [CUPS.o] Error 1
==> ERROR: A failure occurred in build().
Aborting...
==> ERROR: Makepkg was unable to build perl-net-cups.
==> Restart building perl-net-cups ? [y/N]
==> --------------------------------------
==>

But we must wait for upstream as sputnick previously mentioned.

sputnick commented on 2013-10-15 20:01

@kolcon, Waiting for a response in your post from upstream https://rt.cpan.org/Public/Bug/Display.html?id=88789

Anonymous comment on 2013-09-18 13:00

The package cannot be built... details here:
http://bpaste.net/show/133416/
and after symlinking image.h from cupsfilters directory:
http://bpaste.net/show/133414/