Package Details: perl-net-upnp 1.4.6-1

Git Clone URL: https://aur.archlinux.org/perl-net-upnp.git (read-only, click to copy)
Package Base: perl-net-upnp
Description: Perl Module UPnP
Upstream URL: https://metacpan.org/release/Net-UPnP
Licenses: BSD, PerlArtistic
Submitter: Barthalion
Maintainer: matth
Last Packager: matth
Votes: 5
Popularity: 0.000331
First Submitted: 2018-01-07 17:59
Last Updated: 2019-04-05 15:28

Dependencies (1)

Required by (3)

Sources (1)

Latest Comments

ck2katAUR commented on 2020-06-24 15:27

@matth . My newbie mistake! I've been recalling a previous makepkg invokation from bash history - not knowing that the '--needed' flag it contained would have that effect. Re-tried using; 'makepkg -cfisL' & pacman -U re-installed the package OK this time. I'm going to try to sort out mythtv (AUR) with a similar procedure. Many thanks for your help.

matth commented on 2020-06-24 15:11

pacman -U should say it is up to date since it is still the same version, but it should still let you re-install it. The "nothing to do" should only happen if you are passing the --needed flag

I can run this which prompts to install which I can say Yes to.

sudo pacman -U --asdeps perl-net-upnp-1.4.6-1-x86_64.pkg.tar.xz

loading packages... warning: perl-net-upnp-1.4.6-1 is up to date -- reinstalling resolving dependencies... looking for conflicting packages...

Package (1) Old Version New Version Net Change

perl-net-upnp 1.4.6-1 1.4.6-1 0.00 MiB

Total Installed Size: 0.11 MiB Net Upgrade Size: 0.00 MiB

:: Proceed with installation? [Y/n]

ck2katAUR commented on 2020-06-24 15:00

@matth. Thankyou for your quick response. Further info: 1) I have posted a similar comment against; mythtv (AUR) & have had a reply from; bigcajun826. 2) The 'nothing to do' response comes after makepkg invokes pacman -U. Presumably because (judging by what is on my terminal), makepkg did not update anything to generate a new package (correct?). 3) My research into this threw up another forum post (see; https://unix.stackexchange.com/questions/391076/rebuild-old-perl-modules ) from someone that appears to be as confused by this as me! As per your suggestion; I invoked; makepkg -cfisL . I see on the terminal; 'Manifying 14 pod documents', plus a series of 'Installing /home/..../vendor-perl/Net/UPnP/... .pm' and 'Installing /home/..../Net::UPnP::... .3pm' messages. But pacman -U again says; 'perl-net-upnp-1.4.6-1 is up to date -- skipping there is nothing to do'. Should I have used pacman to remove the package before re-building? If so, what is the correct sequence of commands - bearing in mind this package is a dependancy of mythtv? All my research gets me deeper into unknown territory, so detailed help would be much appreciated. Thanks

matth commented on 2020-06-24 14:14

@ck2katAUR you should rebuild this package. I'm not sure what the "Nothing to do" is from, but if you pass the -f flag to makepkg it will force a rebuild even if you've already built it before.

ck2katAUR commented on 2020-06-24 13:31

Newbie question. Background: Today, a 'pacman -Syu' invokation updated perl from; 5.30.3-1 to; 5.32.0-1. As expected, I got the warning in the pacman log from the; 'detect-old-perl-modules.hook'. Invoking; pacman -Qo 'usr/lib/perl5/5.30/' , listed this package. I have read; https://www.archlinux.org/news/perl-library-path-change/ . I am not (yet) experienced enough to understand/carry-out the suggestion regarding adding the; perl -V:vendorarch clause to PKGBUILD. So, without that mod, I attempted a package re-build with a; 'git pull' followed by a; 'makepkg -cisL' which returned a; 'nothing to do' response. Question: Is there more to do, or is this package OK to carry-on working with, as it is? I look forward to your help. Thanks.

simona commented on 2018-10-01 06:59

pacman -Qqo '/usr/lib/perl5/5.26' perl-net-upnp

t.langlois commented on 2018-03-26 14:23

SOLVED. Ignoring the architecture (makepkg -Acsi).

t.langlois commented on 2018-03-24 22:24

I get the following error tying to build the package for ARM:

$ makepkg -si ==> ERROR: perl-net-upnp is not available for the 'armv7h' architecture.

==> ERROR: An unknown error has occurred. Exiting...

The hardware is a Wandboard QUAD.

Is there a particular reason why it does not build on this architecture ?