Package Details: perl-opengl 0.6704-2

Git Clone URL: https://aur.archlinux.org/perl-opengl.git (read-only)
Package Base: perl-opengl
Description: Interface to OpenGL drawing/imaging library
Upstream URL: https://metacpan.org/release/OpenGL/
Licenses: GPL, PerlArtistic
Submitter: zoulnix
Maintainer: swiftgeek
Last Packager: swiftgeek
Votes: 29
Popularity: 0.182756
First Submitted: 2009-02-28 22:39
Last Updated: 2015-07-22 15:10

Latest Comments

swiftgeek commented on 2015-07-22 15:22

Thanks for doing that, bumped pkgbuild with patch

byte commented on 2015-07-22 15:17

Good question. Either the Red Hat guy forgot or perhaps he thought that such a current mesa/libgl wouldn't be a problem for most people for quite a while.

Reported myself: https://sourceforge.net/p/pogl/bugs/21/

swiftgeek commented on 2015-07-22 14:52

@byte: Why isn't that posted to the issue tracker of the project?
http://sourceforge.net/p/pogl/bugs/

byte commented on 2015-07-22 14:30

This should help:
http://pkgs.fedoraproject.org/cgit/perl-OpenGL.git/plain/OpenGL-0.6704-Delete-functions-removed-from-Mesa.patch?id=7498635332872268a0d4519723b44725e9a496dc

bricewge commented on 2015-07-22 13:25

I can't compile this package neither under Gnome nor a tty, a test always fail. I have tried to fix it but I didn't managed to. Here are the logs https://paste.linuxdistrocommunity.com/view/1074fa88

swiftgeek commented on 2015-05-19 16:02

Fixed compiling on headless with use of xvfb

jnbek commented on 2013-12-27 21:28

yea, I had alot of misery with this module, the last cpl of updates gave me plenty of heartburn, lol. @ swiftgeek, thank you for stepping up and taking this module. Give it all the love and nurturing it deserves.

swiftgeek commented on 2013-12-27 21:12

Patches welcome as i'm not a perl dev ;)

swiftgeek commented on 2013-12-27 21:10

Should be fixed now (no more random x11 windows with teapots and cubes), but it still needs to be compiled under X11, because of retarded "Makefile.pl"

swiftgeek commented on 2013-12-27 20:55

Should be fixed now

swiftgeek commented on 2013-12-27 20:55

Should be fixed now

nickoe commented on 2013-12-11 17:50

Why does it have the same depends multiple times?

I think the mesa-libgl can be replaced with libgl, since bothe mesa-libgl and nvidia-libgl provides libgl. And it works with nvidia-libgl aswell.

jnbek commented on 2013-12-10 03:16

OK, bunder, I've uploaded the untouched file... let me know if there's any problems all...

bunder commented on 2013-11-16 13:23

I tried your updated and untouched PKGBUILD and it looks good except an error at check stage (I've already opened a bug for this error, see http://sourceforge.net/p/pogl/bugs/8/). I have neither junk characters in Makefile nor errors at build stage. My environment: Arch linux x86_64, perl 5.18.1-1, make 4.0-1, freeglut 2.8.1-1, mesa-libgl 9.2.2-1.

jnbek commented on 2013-11-14 02:40

Seems there might be an upstream bug with the Makefile.PL file, once the Makefile is generated it fails:

([J:0]jjones@jjones-lappy[/tmp/perl-opengl]% makepkg [11/13/13][19:27:39])
==> Making package: perl-opengl 0.6703-1 (Wed Nov 13 19:27:43 MST 2013)
==> Checking runtime dependencies...
==> Checking buildtime dependencies...
==> Retrieving sources...
-> Downloading OpenGL-0.6703.tar.gz...
% Total % Received % Xferd Average Speed Time Time Time Current
Dload Upload Total Spent Left Speed
0 0 0 0 0 0 0 0 --:--:-- --:--:-- --:--:-- 0
100 655k 100 655k 0 0 670k 0 --:--:-- --:--:-- --:--:-- 5593k
==> Validating source files with md5sums...
OpenGL-0.6703.tar.gz ... Passed
==> Validating source files with sha512sums...
OpenGL-0.6703.tar.gz ... Passed
==> Extracting sources...
-> Extracting OpenGL-0.6703.tar.gz with bsdtar
==> Starting build()...
Found FreeGLUT v20801

Using interface: FREEGLUT

Checking if your kit is complete...
Looks good
Writing Makefile for OpenGL
Writing MYMETA.yml and MYMETA.json
Makefile:1: *** missing separator. Stop.
==> ERROR: A failure occurred in build().
Aborting...
It seems that there are junk characters added to the first line and last line of the Makefile. I've added some sed hacks to remove these spews but then the make fails with other problems:

([J:1]jjones@perlgeeks4u[/tmp/perl-opengl]% makepkg [11/13/13][19:34:30])
==> Making package: perl-opengl 0.6703-1 (Wed Nov 13 19:34:32 MST 2013)
==> Checking runtime dependencies...
==> Checking buildtime dependencies...
==> Retrieving sources...
-> Downloading OpenGL-0.6703.tar.gz...
% Total % Received % Xferd Average Speed Time Time Time Current
Dload Upload Total Spent Left Speed
0 0 0 0 0 0 0 0 --:--:-- --:--:-- --:--:-- 0
100 655k 100 655k 0 0 306k 0 0:00:02 0:00:02 --:--:-- 311k
==> Validating source files with md5sums...
OpenGL-0.6703.tar.gz ... Passed
==> Validating source files with sha512sums...
OpenGL-0.6703.tar.gz ... Passed
==> Extracting sources...
-> Extracting OpenGL-0.6703.tar.gz with bsdtar
==> Starting build()...
Found FreeGLUT v20801

Using interface: FREEGLUT

Checking if your kit is complete...
Looks good
Writing Makefile for OpenGL
Writing MYMETA.yml and MYMETA.json
cp OpenGL.pod blib/lib/OpenGL.pod
cp Array.pod blib/lib/OpenGL/Array.pod
cp OpenGL.pm blib/lib/OpenGL.pm
AutoSplitting blib/lib/OpenGL.pm (blib/lib/auto/OpenGL)
cp Tessellation.pod blib/lib/OpenGL/Tessellation.pod
cp Config.pm blib/lib/OpenGL/Config.pm
/usr/bin/perl /usr/share/perl5/core_perl/ExtUtils/xsubpp -noprototypes -typemap /usr/share/perl5/core_perl/ExtUtils/typemap -typemap typemap OpenGL.xs > OpenGL.xsc && mv OpenGL.xsc OpenGL.c
make: *** No rule to make target '', needed by 'OpenGL.o'. Stop.
==> ERROR: A failure occurred in build().
Aborting...

The updated and untouched PKGBUILD etc is located here:
https://dl.dropboxusercontent.com/u/95216987/perl-opengl-0.6703-1.src.tar.gz

The PKGBUILD with the 'hack' is located here:

https://dl.dropboxusercontent.com/u/95216987/PKGBUILD

It may be a problem with ExtUtils::MakeMaker as well, but this is the only package I've had the problems with it on. Anyone want to take a crack at it?

jnbek commented on 2013-08-27 23:15

I wonder if there's an ancillary dependency that hasn't been rebuilt for Perl 5.18. I've had a number of my perl modules fail that way. Or sometimes, the author has yet to fix the test to be 5.18 compliant, which could also be the case. Lastly, this module during make test will attempt to test the graphical aspects and if you're on a headless server, or logged in as root on a terminal and the test can't connect to the X session, make test barfs in your lap like a 5 month old infant with influenza. For a time, I kept make test commented out, but the tests are fairly important and it's just wrong and against the Perl way to force skip the tests. Let me know if any of the above assisted you with regard to your problem.

xyem commented on 2013-08-27 15:09

@cgx: The 'make test' fails because 'test.pl' returns an exit code of 9 instead of 0, (seemingly) regardless of how it exits. For example, in cbRenderScene there is an explicit 'exit(0);' when the test hits timeout, but the exit code is still 9.

I am (with some help) trying to isolate the cause of this and will post my findings/a patch if I succeed.

dracorp commented on 2013-08-19 14:31

Could you change mesa-libgl to libgl in the makedepends? Nvidia-libgl and mesa-libgl provides libgl.

cgx commented on 2013-07-16 20:14

Hmm, the "make test" is not commented out anymore and the build is failing because of that here... Is it really needed?

swiftgeek commented on 2013-07-06 21:17

"mesa-libgl>=9.1.3"

Well it works on nvidia too -.-

jnbek commented on 2012-07-19 16:29

Removed the version constraint, also, I commented out make test too, since even though the test works, when i go to exit it, it kicks out of the build as a failure... If you reeeally want the tests, you can uncomment it from the PKGBUILD.

jnbek commented on 2012-07-11 14:28

Sure, I'll look into that. I just got to work, so it will be this evening before i get a chance to look.

dracorp commented on 2012-07-11 07:44

Could you modify depend libgl>=8.0.3 to the libgl (e.g. nvidia-utils provides libgl)?

Anonymous comment on 2010-10-05 18:15

OpenGL-0.62 no longer exists. Looks like it should be 0.63 or 0.64 now.