Package Details: perl-plack 1.0048-1

Git Clone URL: https://aur.archlinux.org/perl-plack.git (read-only, click to copy)
Package Base: perl-plack
Description: Perl Superglue for Web frameworks and Web Servers
Upstream URL: https://metacpan.org/release/Plack
Licenses: GPL, PerlArtistic
Submitter: Athaba
Maintainer: bunder
Last Packager: bunder
Votes: 13
Popularity: 0.000176
First Submitted: 2010-04-15 10:04 (UTC)
Last Updated: 2021-01-07 09:39 (UTC)

Latest Comments

1 2 3 Next › Last »

MarsSeed commented on 2022-06-03 03:47 (UTC)

Needed checkdepends: perl-cgi-compile, perl-log-log4perl, perl-module-refresh, perl-cgi-emulate-psgi

Evidence: check() log.

sl1pkn07 commented on 2018-10-18 14:46 (UTC) (edited on 2018-10-18 14:50 (UTC) by sl1pkn07)

checkdepends() is ok @bunder

also:

t/Plack-Request/cookie.t ............................. 1/? 
#   Failed test at t/Plack-Request/cookie.t line 16.
#          got: '"spaced out"'
#     expected: 'spaced out'

#   Failed test at t/Plack-Request/cookie.t line 18.
#          got: '""internal quotes""'
#     expected: '"internal quotes"'

#   Failed test at t/Plack-Request/cookie.t line 19.
#          got: '""'
#     expected: ''
# Looks like you failed 3 tests of 13.
t/Plack-Request/cookie.t ............................. Dubious, test returned 3 (wstat 768, 0x300)

apetresc commented on 2018-10-13 16:21 (UTC)

The most recent update broke this build - it depends on perl-cookie-baker>=0.07, but that doesn't exist on the AUR yet.

Pauligrinder commented on 2015-12-21 08:58 (UTC) (edited on 2015-12-21 09:01 (UTC) by Pauligrinder)

Some dependencies are missing, I had to install them manually to make this package build (otherwise yaourt would've built and installed those automatically). error: target not found: perl-http-request-ascgi error: target not found: perl-fcgi-procmanager error: target not found: perl-http-server-simple-psgi error: target not found: perl-authen-simple-passwd error: target not found: perl-io-handle-util error: target not found: perl-log-dispatch-array error: target not found: perl-lwp-protocol-http10 error: target not found: perl-module-refresh error: target not found: perl-test-tcp>=2.00

bunder commented on 2015-02-14 20:11 (UTC)

sl1pkn07, these are not errors. Dependencies are optional. Do not want to require everything to be installed at build time. Can add then to optdepends. Reasonable?

sl1pkn07 commented on 2015-02-14 12:35 (UTC)

t/Plack-Middleware/cgibin.t .......................... skipped: Test requires module 'CGI::Emulate::PSGI' but it's not found t/Plack-Middleware/cgibin_exec.t ..................... skipped: Test requires module 'CGI::Emulate::PSGI' but it's not found t/Plack-Middleware/wrapcgi.t ......................... skipped: Test requires module 'CGI::Emulate::PSGI' but it's not found t/Plack-Middleware/wrapcgi_exec.t .................... skipped: Test requires module 'CGI::Emulate::PSGI' but it's not found needs 'perl-cgi-emulate-psgi' chackdepend and after install t/Plack-Middleware/cgibin.t .......................... skipped: Test requires module 'CGI::Compile' but it's not found t/Plack-Middleware/cgibin_exec.t ..................... skipped: Test requires module 'CGI::Compile' but it's not found t/Plack-Middleware/wrapcgi.t ......................... skipped: Test requires module 'CGI::Compile' but it's not found t/Plack-Middleware/wrapcgi_exec.t .................... skipped: Test requires module 'CGI::Compile' but it's not found missing 'perl-cgi-compile' (http://search.cpan.org/dist/CGI-Compile/lib/CGI/Compile.pm) greetings

bunder commented on 2014-02-08 08:39 (UTC)

Updated according to Synthead comment. Thank you!

sl1pkn07 commented on 2014-02-07 05:56 (UTC)

@bunder you can update PKGBUILD (NOT package) to update depends/makedepends/checkdepend? greetings