Package Details: perl-rpc-xml 0.82-1

Git Clone URL: https://aur.archlinux.org/perl-rpc-xml.git (read-only, click to copy)
Package Base: perl-rpc-xml
Description: A set of classes for core data, message and XML handling
Upstream URL: https://metacpan.org/dist/RPC-XML
Keywords: perl xml-rpc xml-rpc-client xml-rpc-server
Licenses: LGPL, PerlArtistic
Submitter: None
Maintainer: fungible
Last Packager: fungible
Votes: 78
Popularity: 0.000309
First Submitted: 2007-04-16 06:52 (UTC)
Last Updated: 2021-12-21 00:41 (UTC)

Dependencies (5)

Sources (1)

Latest Comments

1 2 3 4 5 Next › Last »

vanyasem commented on 2018-09-18 11:26 (UTC)

Oh, I apologize, I removed 40_server.t, but left 40_server_xmllibxml.t there, because it was not run for me (I don't have perl-xml-libxml installed)

vguarnaccia commented on 2018-09-18 04:30 (UTC)

Even with the patch, test 40 fails on my machine.

https://asciinema.org/a/2MW62zTTdIxCHU2SkZPLjO7lJ

vanyasem commented on 2018-09-17 16:08 (UTC)

Patched the package to remove the broken test, as it seems to be abandoned upstream

jnbek commented on 2018-09-17 14:50 (UTC)

I apologize for not getting to this, I just started a new job and I just don't have the time necessary to maintain this right now. Setting loose to the wild so someone else can get it updated.

vanyasem commented on 2018-09-17 11:11 (UTC) (edited on 2018-09-17 11:11 (UTC) by vanyasem)

add rm t/40_server.t to check() after cd to remove the broken test.

Also opt depends on perl-xml-libxml.

sabbath commented on 2018-07-31 15:48 (UTC)

I got the Checksum error.

Basxto commented on 2018-05-10 09:13 (UTC) (edited on 2018-05-10 09:13 (UTC) by Basxto)

Workaround:

Comment out ::1 in /etc/hosts, since the tests have trouble with IPv6

kevinkjt2000 commented on 2017-12-20 21:14 (UTC)

I reported https://github.com/rjray/rpc-xml/issues/14 since I see the same problem as Skynet. I would recommend to anyone, to NOT comment out make test. Make test is very important to verifying installation of perl packages.

mannp commented on 2017-12-12 14:13 (UTC)

Tried again today and it built fine ..... perhaps upstream changes, not sure, but it built.