Package Details: perl-sane 0.05-1

Git Clone URL: (read-only)
Package Base: perl-sane
Description: Perl extension for the SANE (Scanner Access Now Easy) Project
Upstream URL:
Licenses: GPL, PerlArtistic
Submitter: leidola
Maintainer: jnbek
Last Packager: jnbek
Votes: 106
Popularity: 2.159122
First Submitted: 2009-01-27 19:08
Last Updated: 2015-06-16 21:51

Latest Comments

jnbek commented on 2015-08-18 20:46


FadeMind commented on 2015-06-30 13:54

Please bump rev version against perl new release. This package need to be rebuilt against it.

jnbek commented on 2015-04-15 17:08

Sorry, I keep forgetting to update the depends when I update this package... missing deps; added.

djringjr commented on 2015-04-15 00:25

Bonjour, ArnaudNux,

Pour corriger l'erreur, installer ces paquets.

sudo pacman -S perl-extutils-depends perl-extutils-pkgconfig



ArnaudNux commented on 2015-04-14 18:18

-> Extraction de Sane-0.05.tar.gz avec bsdtar
==> Lancement de build()...
Can't locate ExtUtils/ in @INC (you may need to install the ExtUtils::Depends module) (@INC contains: /usr/lib/perl5/site_perl /usr/share/perl5/site_perl /usr/lib/perl5/vendor_perl /usr/share/perl5/vendor_perl /usr/lib/perl5/core_perl /usr/share/perl5/core_perl .) at Makefile.PL line 3.
BEGIN failed--compilation aborted at Makefile.PL line 3.
==> ERREUR : Une erreur s’est produite dans build().

mavrix commented on 2015-04-01 16:03

Good point, christianc. Thanks for the reminder about aur prerequisites.

christianc commented on 2015-03-31 23:44

Please add "perl-extutils-pkgconfig" [1] and "perl-extutils-depends" [2] as dependencies.
This version won't build if these packages aren't installed, as fluteyoshi previously said.
The "perl" package must be removed from makedepends since these packages already have it as a dependency.

Further, I don't think "gcc" is needed in makedepends since "base-devel" [3] group is supposed to be installed when building a package from AUR [4].


mavrix commented on 2015-03-23 21:07

I believe 'gcc' should be added to makedepends as well. I got the following installation error:

/bin/sh: cc: command not found
Makefile:338: recipe for target 'Sane.o' failed
make: *** [Sane.o] Error 127
==> ERROR: A failure occurred in build().
==> ERROR: Makepkg was unable to build perl-sane.

Installing gcc took care of that.

Jarshvor commented on 2014-10-21 19:32

I also concur with fluteyoshi and wchouser3.
I was able to build successfully after installing 'perl-extutils-pkgconfig' and 'perl-extutils-depends'.

ZeroCool commented on 2014-10-20 22:45

There is missspelling in the PKGBUILD it sould should be called makedepends not makedepend.

jnbek commented on 2014-10-01 21:18

Let's give that a try.

wchouser3 commented on 2014-10-01 20:08

I concur with fluteyoshi. those two packages need to be added as makedepends. The package will not build without them.

fluteyoshi commented on 2014-09-20 08:12

I think that 'perl-extutils-pkgconfig' and 'perl-extutils-depends' need to be added as makedepends? I just tried building this and wasn't able to do it until these packages were installed.

fluteyoshi commented on 2014-09-20 08:12

I think that 'perl-extutils-pkgconfig' and 'perl-extutils-depends' need to be added as makedepends?

djringjr commented on 2014-07-05 18:14

Source location is incorrect, edit PKGBUILD and put actual location of source:

perl-sane will then install.

dsagra commented on 2013-06-28 08:45

package updated

zman0900 commented on 2013-06-28 00:39

Please bump the release version to force a rebuild against perl 5.18

dsagra commented on 2012-04-08 10:12


i18nde commented on 2012-04-08 06:26

Architecture should be renamed from x86 into


dsagra commented on 2012-04-07 19:28

adopted and updated

Anonymous comment on 2012-01-29 16:00

What are you rambling about viniavila? I know the difference between makedepends and depends. Do you have a specific problem or are you just trying to show off?

viniavila commented on 2012-01-27 10:56

If your package crash or not work or lost funcionality when you remove the makedepends packages, there are packages those needed to be in depends array.

A Suggestion: install your package and remove the makedepends packages. If your package crash or lost funcionality, reinstall packages one by one until your package will be restored. Verify what packages restore the funcionality of yours. Move them to depends array.

viniavila commented on 2012-01-27 10:52

Put them in MAKEDEPENDS is very different than put them in DEPENDS or OPTDEPENDS.

From "man PKGBUILD":

depends() => An array of packages this package depends on to RUN.

makedepends() => An array of packages this package depends ON THE BUILD BUT ARE NOT NEEDED AT RUNTIME.

optdepends() => An array of packages (and accompanying reasons) that are not essential for base functionality, but may be necessary to make full use of the contents of this package.

So, verify what option is the best for that packages.

Anonymous comment on 2010-12-04 19:19

Done. Thanks! I added them as makedepends so they don't show up above but they are in the PKGBUILD.

nbryskin commented on 2010-12-04 09:58

Hi, add this dependencies please: 'perl-extutils-depends' 'perl-extutils-pkgconfig'