Package Details: perl-sys-virt 3.0.0-3

Git Clone URL: https://aur.archlinux.org/perl-sys-virt.git (read-only)
Package Base: perl-sys-virt
Description: Represent and manage a libvirt hypervisor connection
Upstream URL: http://search.cpan.org/dist/Sys-Virt/
Licenses: GPL, PerlArtistic
Submitter: chenxiaolong
Maintainer: bidulock
Last Packager: bidulock
Votes: 27
Popularity: 1.352678
First Submitted: 2011-12-11 07:13
Last Updated: 2017-06-09 21:45

Latest Comments

bidulock commented on 2017-07-07 17:16

pkg-config is part of base-devel, which needs to be loaded to build AUR packages.

r7v commented on 2017-07-07 15:05

Please add pkg-config as build dependency

Ichimonji10 commented on 2017-06-11 17:09

Thanks. I can confirm that perl-sys-virt can now be installed with AUR package managers. For what it's worth, I can also verify that several of the libguestfs tools (such as virt-sysprep) work.

bidulock commented on 2017-06-10 22:50

I think that I fixed this now for all my perl packages. I placed the dependency template in a subroutine where mksrcinfo will not find it, but where it winds up correctly in the binary. You don't see any more perl dependencies above, but the binary has.

yaourt -Sia aur/perl-sys-virt

only show dependencies on libvirt.

yaourt -Si custom/perl-sys-virt

shows libvirt perl>=5.26 perl<5.27

Ichimonji10 commented on 2017-06-09 21:19

The new depends() added by https://aur.archlinux.org/cgit/aur.git/commit/?h=perl-sys-virt&id=a0bdb4efa1272911c7044669e44cc60b7f5fd821 break unofficial AUR package managers like pacaur and yaourt. Example:

$ pacaur -S perl-sys-virt
:: Package perl-sys-virt not found in repositories, trying AUR...
:: resolving dependencies...
:: no results found for perl< (dependency tree: perl-sys-virt perl)

Another example of this issue and a possible solution is described in: https://bbs.archlinux.org/viewtopic.php?id=223589

aurdelkind commented on 2015-10-26 01:51

Since some users may have set INSTALL_BASE in PERL_MM_OPT, you should consider adding 'unset PERL_MM_OPT' before generating the Makefile.

bvanheu commented on 2014-06-11 16:58

This works out-of-the-box:

--- a/perl-sys-virt/PKGBUILD 2014-03-24 10:42:37.000000000 -0400
+++ b/perl-sys-virt/PKGBUILD 2014-06-11 12:56:40.539070629 -0400
@@ -4,7 +4,7 @@
_author="Daniel P. Berrange"
_perlmod="sys-virt"
pkgname=perl-${_perlmod}
-pkgver=1.2.2
+pkgver=1.2.5
pkgrel=1
pkgdesc="Represent and manage a libvirt hypervisor connection"
arch=('any')
@@ -37,4 +37,4 @@
find "${pkgdir}" -type f \( -name .packlist -o -name '*.bs' -empty \) | xargs rm -vf
}

-md5sums=('acfaf1fb0e2d708522458b97eb28bcd3')
+md5sums=('3aa0a899c69582e0118eeb242f15248c')

jnbek commented on 2014-03-04 02:08

https://metacpan.org/release/Sys-Virt 1.2.2 just released 12 hours ago, should be propagated to all the mirrors any time.

patryk commented on 2014-01-25 10:20

You have libvirt in makedepens :)

jnbek commented on 2014-01-21 22:12

Heads up: https://metacpan.org/release/Sys-Virt jsut released 1.2.1 9 hours ago and is propagating to the CPAN mirrors; it should be there in the next couple hours. Also should add libvirt to the depends, since it won't install without it.

All comments