Package Details: perl-test-checkdeps 0.010-1

Git Clone URL: https://aur.archlinux.org/perl-test-checkdeps.git (read-only)
Package Base: perl-test-checkdeps
Description: Check for presence of dependencies
Upstream URL: http://search.cpan.org/dist/Test-CheckDeps
Licenses: GPL, PerlArtistic
Submitter: harleypig
Maintainer: jnbek
Last Packager: jnbek
Votes: 19
Popularity: 0.009035
First Submitted: 2012-06-02 00:57
Last Updated: 2015-06-16 22:00

Latest Comments

dracorp commented on 2015-03-21 13:21

t/10-basics.t ............. 1/?
# Failed test 'Pod::Coverage::TrustPod satisfies '0''
# at t/10-basics.t line 15.
# Module 'Pod::Coverage::TrustPod' is not installed

hexadecagram commented on 2013-11-17 21:06

_pkgname='Test-CheckDeps'
pkgver='0.010'
pkgrel='1'
source=("http://search.cpan.org/CPAN/authors/id/L/LE/LEONT/${_pkgname}-${pkgver}.tar.gz")
md5sums=('c1893b187e9b2efee7d40b1799218576')
sha512sums=('9683b81aa6bce358fa1abc9b2337b9b15b274742f08a3fd71e80df0bfd20619406cdded191aafdd103db8d514bdc20d36a0b60aefbd72d3de6cb117c17461697')
_distdir="${_pkgname}-${pkgver}"

build() {
...
/usr/bin/perl Makefile.PL --installdirs vendor --destdir "$pkgdir"
/usr/bin/perl Makefile
...
}

check() {
...
/usr/bin/perl Makefile test
...
}

package() {
...
/usr/bin/perl Makefile install
...
}

This results in:

Can't modify negation (-) in scalar assignment at Makefile line 37, near "Wl,"
...
Makefile has too many errors.

The offending line is:

CCDLFLAGS = -Wl,-E -Wl,-rpath,/usr/lib/perl5/core_perl/CORE

jnbek commented on 2013-09-01 03:20

Very Odd... none of these comments came to my email... Thx bunder for the direct mailing.. Updated and bumped for yaourt users. Sorry for the past 33 days.

seschwar commented on 2013-08-18 14:38

I can confirm that bunder's PKGBUILD works well.

bunder commented on 2013-08-17 06:00

Updated PKGBUILD uploaded to http://pastebin.com/AqELX4YT

seschwar commented on 2013-08-02 14:27

There is another error after installing perl-module-build-tiny:

==> Starting package()...
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
ERROR: Can't create '/usr/share/man/man3'
Do not have write permissions on '/usr/share/man/man3'
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
at /usr/share/perl5/vendor_perl/Module/Build/Tiny.pm line 104.
==> ERROR: A failure occurred in package().
Aborting...

seschwar commented on 2013-08-02 12:04

I get the same error as Leonidas XIV:

Can't locate Module/Build/Tiny.pm in @INC (you may need to install the Module::Build::Tiny module) (@INC contains: /usr/lib/perl5/site_perl /usr/share/perl5/site_perl /usr/lib/perl5/vendor_perl /usr/share/perl5/vendor_perl /usr/lib/perl5/core_perl /usr/share/perl5/core_perl .) at Build.PL line 2.
BEGIN failed--compilation aborted at Build.PL line 2.

This is due to the perl-test-checkdeps PKGBUILD missing a dependency on perl-module-build-tiny.

LeonidasXIV commented on 2013-07-29 09:50

Building it fails with:

Can't locate Module/Build/Tiny.pm in @INC (you may need to install the Module::Build::Tiny module) (@INC contains: /usr/lib/perl5/site_perl /usr/share/perl5/site_perl /usr/lib/perl5/vendor_perl /usr/share/perl5/vendor_perl /usr/lib/perl5/core_perl /usr/share/perl5/core_perl .) at Build.PL line 2.
BEGIN failed--compilation aborted at Build.PL line 2.