Package Details: perl-test-corpus-audio-mpd 1.120990-1

Git Clone URL: https://aur.archlinux.org/perl-test-corpus-audio-mpd.git (read-only)
Package Base: perl-test-corpus-audio-mpd
Description: automate launching of fake mdp for testing purposes
Upstream URL: http://search.cpan.org/dist/Test-Corpus-Audio-MPD
Licenses: GPL, PerlArtistic
Submitter: None
Maintainer: 3ED_0
Last Packager: 3ED_0
Votes: 7
Popularity: 0.000000
First Submitted: 2010-05-01 22:17
Last Updated: 2015-07-02 08:40

Latest Comments

3ED_0 commented on 2012-08-14 08:14

"could not start fake mpd: Failed to bind to '127.0.0.1:6600': Address already in use"

turnoff all at port 6600 and try again?

3ED_0 commented on 2012-08-14 08:13

"could not start fake mpd: Failed to bind to '127.0.0.1:6600': Address already in use"

3ED_0 commented on 2012-08-14 08:09

Do not switch package to out of date unless there is new version.

I don't know why this happen for you. I can't reproduce. But seems to be a bug in source.
Try: makepkg --nocheck (and maybe cpan bug tracker?)

Anonymous comment on 2012-08-12 19:18

==> Building and installing package
==> Making package: perl-test-corpus-audio-mpd 1.120990-1 (Sun Aug 12 14:14:17 CDT 2012)
==> Checking runtime dependencies...
==> Checking buildtime dependencies...
==> Retrieving Sources...
-> Downloading Test-Corpus-Audio-MPD-1.120990.tar.gz...
% Total % Received % Xferd Average Speed Time Time Time Current
Dload Upload Total Spent Left Speed
0 0 0 0 0 0 0 0 --:--:-- --:--:-- --:--:-- 0
100 32794 100 32794 0 0 53467 0 --:--:-- --:--:-- --:--:-- 53467
==> Validating source files with sha256sums...
Test-Corpus-Audio-MPD-1.120990.tar.gz ... Passed
==> Extracting Sources...
-> Extracting Test-Corpus-Audio-MPD-1.120990.tar.gz with bsdtar
==> Starting build()...
Created MYMETA.yml and MYMETA.json
Creating new 'Build' script for 'Test-Corpus-Audio-MPD' version '1.120990'
Building Test-Corpus-Audio-MPD
==> Starting check()...
t/00-compile.t ................ 1/1
# Failed test 'module loads ok'
# at t/00-compile.t line 17.
# got: 'could not start fake mpd: Failed to bind to '127.0.0.1:6600': Address already in use
#
# Compilation failed in require at (eval 4) line 2.
# BEGIN failed--compilation aborted at (eval 4) line 2.
# '
# expected: ''
# Looks like you failed 1 test of 1.
t/00-compile.t ................ Dubious, test returned 1 (wstat 256, 0x100)
Failed 1/1 subtests
t/000-report-versions-tiny.t .. #
#
# perl: v5.16.1 (wanted 5.008) on linux from /usr/bin/perl
#
# Exporter => 5.66 (want any version)
# File::Copy => 2.23 (want any version)
# File::ShareDir::PathClass => 1.112440 (want any version)
# File::Temp => 0.22 (want any version)
# Module::Build => 0.3901 (want 0.3601)
# Path::Class => 0.26 (want any version)
# Readonly => 1.03 (want any version)
# Test::More => 0.98 (want 0.88)
# base => 2.18 (want any version)
# strict => 1.07 (want any version)
# warnings => 1.13 (want any version)
#
# Thanks for using my code. I hope it works for you.
# If not, please try and include this output in the bug report.
# That will help me reproduce the issue and solve you problem.
#
t/000-report-versions-tiny.t .. ok
t/release-has-version.t ....... skipped: these tests are for release candidate testing
t/release-kwalitee.t .......... skipped: these tests are for release candidate testing
t/release-minimum-version.t ... skipped: these tests are for release candidate testing
t/release-pod-coverage.t ...... skipped: these tests are for release candidate testing
t/release-pod-syntax.t ........ skipped: these tests are for release candidate testing

Test Summary Report
-------------------
t/00-compile.t (Wstat: 256 Tests: 1 Failed: 1)
Failed test: 1
Non-zero exit status: 1
Files=7, Tests=2, 0 wallclock secs ( 0.03 usr 0.01 sys + 0.30 cusr 0.08 csys = 0.42 CPU)
Result: FAIL
Failed 1/7 test programs. 1/2 subtests failed.