Package Details: perl-test-use-ok 0.11-5

Git Clone URL: https://aur.archlinux.org/perl-test-use-ok.git (read-only, click to copy)
Package Base: perl-test-use-ok
Description: Alternative to Test::More::use_ok
Upstream URL: https://search.mcpan.org/dist/Test-use-ok
Licenses: GPL, PerlArtistic
Submitter: None
Maintainer: alerque
Last Packager: alerque
Votes: 17
Popularity: 0.000080
First Submitted: 2008-09-21 23:47 (UTC)
Last Updated: 2020-05-28 23:59 (UTC)

Latest Comments

micwoj92 commented on 2021-04-12 19:31 (UTC)

perl-test-use-ok: /usr/share/man/man3/Test::use::ok.3pm.gz exists in filesystem (owned by perl-test-simple)
perl-test-use-ok: /usr/share/man/man3/ok.3pm.gz exists in filesystem (owned by perl-test-simple)
perl-test-use-ok: /usr/share/perl5/vendor_perl/Test/use/ok.pm exists in filesystem (owned by perl-test-simple)
perl-test-use-ok: /usr/share/perl5/vendor_perl/ok.pm exists in filesystem (owned by perl-test-simple)

Should conflict with perl-test-simple

Martchus commented on 2019-05-28 14:40 (UTC)

makedepends must not contain an empty string.

sl1pkn07 commented on 2019-03-15 15:39 (UTC)

superseeded by perl-test-simple in [community]

droped by my side

greetings

bidulock commented on 2017-09-25 01:29 (UTC)

namcap shows: perl-test-use-ok E: perl is not a common license (it's not in /usr/share/licenses/common/) did you mean "PerlArtistic"?

sl1pkn07 commented on 2017-08-15 13:24 (UTC)

need set: PERL5LIB="${srcdir}/${_realname}-${pkgver}" in build()

Yurashina commented on 2017-08-08 10:56 (UTC)

still can't build, the maintainer of this package seen not longer online...

commented on 2017-07-26 01:24 (UTC)

cant build this package perl-test-use-ok wont build cause Can't locate inc/Module/Package.pm in @INC (you may need to install the inc::Module::Package module) (@INC contains: /usr/lib/perl5/site_perl /usr/share/perl5/site_perl /usr/lib/perl5/vendor_perl /usr/share/perl5/vendor_perl /usr/lib/perl5/core_perl /usr/share/perl5/core_perl) at Makefile.PL line 2. BEGIN failed--compilation aborted at Makefile.PL line 2.

godofgrunts commented on 2015-03-16 13:50 (UTC)

Also this isn't out of date. Latest release from cpan is 0.11

godofgrunts commented on 2015-03-15 20:48 (UTC)

replace everything after md5sum with the following build() { cd "$_realname-$pkgver" # install module in vendor directories. export PERL_MM_USE_DEFAULT=1 perl Makefile.PL make } package() { cd "$_realname-$pkgver" make install INSTALLDIRS=vendor DESTDIR=${pkgdir} # remove perllocal.pod and .packlist find ${pkgdir} -name perllocal.pod -delete find ${pkgdir} -name .packlist -delete }

qqqqqqqqq9 commented on 2015-01-06 11:27 (UTC)

Hi, please add a package()-function, pacman-4.2 needs it.