Package Details: perl-test-use-ok 0.11-3

Git Clone URL: https://aur.archlinux.org/perl-test-use-ok.git (read-only)
Package Base: perl-test-use-ok
Description: Alternative to Test::More::use_ok
Upstream URL: http://search.cpan.org/~audreyt/Test-use-ok
Licenses: GPL, PerlArtistic
Submitter: None
Maintainer: None
Last Packager: sl1pkn07
Votes: 16
Popularity: 0.000000
First Submitted: 2008-09-21 23:47
Last Updated: 2018-08-08 13:34

Latest Comments

sl1pkn07 commented on 2019-03-15 15:39

superseeded by perl-test-simple in [community]

droped by my side

greetings

bidulock commented on 2017-09-25 01:29

namcap shows:

perl-test-use-ok E: perl is not a common license (it's not in /usr/share/licenses/common/)

did you mean "PerlArtistic"?

sl1pkn07 commented on 2017-08-15 13:24

need set:

PERL5LIB="${srcdir}/${_realname}-${pkgver}"

in build()

Yurashina commented on 2017-08-08 10:56

still can't build, the maintainer of this package seen not longer online...

InvisibleRasta commented on 2017-07-26 01:24

cant build this package perl-test-use-ok wont build cause
Can't locate inc/Module/Package.pm in @INC (you may need to install the inc::Module::Package module) (@INC contains: /usr/lib/perl5/site_perl /usr/share/perl5/site_perl /usr/lib/perl5/vendor_perl /usr/share/perl5/vendor_perl /usr/lib/perl5/core_perl /usr/share/perl5/core_perl) at Makefile.PL line 2.
BEGIN failed--compilation aborted at Makefile.PL line 2.

godofgrunts commented on 2015-03-16 13:50

Also this isn't out of date. Latest release from cpan is 0.11

godofgrunts commented on 2015-03-15 20:48

replace everything after md5sum with the following

build() {
cd "$_realname-$pkgver"
# install module in vendor directories.
export PERL_MM_USE_DEFAULT=1
perl Makefile.PL
make
}
package() {
cd "$_realname-$pkgver"
make install INSTALLDIRS=vendor DESTDIR=${pkgdir}

# remove perllocal.pod and .packlist
find ${pkgdir} -name perllocal.pod -delete
find ${pkgdir} -name .packlist -delete
}

qqqqqqqqq9 commented on 2015-01-06 11:27

Hi,
please add a package()-function, pacman-4.2 needs it.