Package Details: perl-text-bidi 2.12-2

Git Clone URL: https://aur.archlinux.org/perl-text-bidi.git (read-only)
Package Base: perl-text-bidi
Description: Perl/CPAN Module Text::Bidi: Unicode bidi algorithm using libfribidi
Upstream URL: https://metacpan.org/release/Text-Bidi
Licenses: GPL, PerlArtistic
Submitter: ak-il
Maintainer: int
Last Packager: int
Votes: 2
Popularity: 0.147131
First Submitted: 2016-10-02 11:47
Last Updated: 2017-11-15 23:01

Dependencies (2)

Required by (0)

Sources (1)

Latest Comments

emmerkar commented on 2019-03-15 13:28

@int

Hi, for the 0.19.7 version go to https://archive.org/details/archlinux_pkg_fribidi

here you will find all the outdated packages of fribidi prior 1.00 version. I downloaded it and installed 0.19.7 version then I installed Text::Bidi 2.12 and all was ok

Or, as I found right now, go to https://ifz.ru/x86_64-2018-01-16/extra/x86_64/

Thanks a lot

Gian Paolo

int commented on 2019-01-16 12:02

I thought about providing a fribidi0197 package. If somebody wants to help, he can drop me an e-mail.

wallace11 commented on 2019-01-15 16:02

For reference in the meantime:

Dependency fribidi must be downgraded for this package to compile in its current form. However, my system would crash on boot if v0.19.7 was installed. This package won't work on v1.0.5.

My solution:

  1. Downgrade fribidi to v0.19.7.

  2. Install this package (v2.12).

  3. "Upgrade" to fribidi v1.0.1 (package name fribidi-1.0.1+8%2Bgdf7252b-1)

int commented on 2019-01-10 18:52

Building fails for me of any of the newer Text::Bidi CPAN-modules (2.13 - 2.15). At least version 2.15 supportes fribidi >= 1.0.0. I filled a bug request for it: https://rt.cpan.org/Public/Bug/Display.html?id=127389

wallace11 commented on 2019-01-10 07:27

v2.15 was released

int commented on 2018-06-27 10:19

Depending what out-of-date means this package is not out-dated in the sense that it is the latest version of the CPAN-module Text::Bidi available. Or it is out-dated because the latest version of the CPAN-module doesn't build against the newest fribidi verion (1.0.4) anymore. For now I would wait if Text::Bidi gets updated. As a workaround one could downgrade fribidi (if this doesn't break things).