Package Details: perl-text-csv-xs 1.28-1

Git Clone URL: https://aur.archlinux.org/perl-text-csv-xs.git (read-only)
Package Base: perl-text-csv-xs
Description: comma-separated values manipulation routines
Upstream URL: https://metacpan.org/release/Text-CSV_XS
Licenses: GPL, PerlArtistic
Submitter: None
Maintainer: jnbek
Last Packager: jnbek
Votes: 31
Popularity: 0.921985
First Submitted: 2007-02-18 02:36
Last Updated: 2017-04-16 16:05

Latest Comments

WFV commented on 2017-09-10 16:02

PKGBUILD and .SRCINFO are still set to 1.28 and fail to build, editing them to 1.31 (as harrysummer shows) pulls in the correct package, makes and installs good. Otherwise it will fail if running an AUR helper. see http://www.cpan.org/authors/id/H/HM/HMBRAND/ for details.

harrysummer commented on 2017-09-04 00:25

Working PKGBUILD for 1.31:

# Contributor: John D Jones III AKA jnbek <jnbek1972 -_AT_- g m a i l -_Dot_- com>
# Generator : CPANPLUS::Dist::Arch 1.32

pkgname='perl-text-csv-xs'
pkgver='1.31'
pkgrel='1'
pkgdesc="comma-separated values manipulation routines"
arch=('i686' 'x86_64')
license=('PerlArtistic' 'GPL')
options=('!emptydirs')
depends=('perl')
makedepends=()
url='https://metacpan.org/release/Text-CSV_XS'
source=('http://search.cpan.org/CPAN/authors/id/H/HM/HMBRAND/Text-CSV_XS-1.31.tgz')
md5sums=('8a5773da8a61018463789a6c92dba448')
sha512sums=('904dec178cbeb94b2c8bbd2c07c13472ed84000a8efe65625f43441eadc682f11f48c5904cecfb69e3cfd9ae86b559e2f72515bcbd47561de557cbc28083a00a')
_distdir="Text-CSV_XS-1.31"

build() {
( export PERL_MM_USE_DEFAULT=1 PERL5LIB="" \
PERL_AUTOINSTALL=--skipdeps \
PERL_MM_OPT="INSTALLDIRS=vendor DESTDIR='$pkgdir'" \
PERL_MB_OPT="--installdirs vendor --destdir '$pkgdir'" \
MODULEBUILDRC=/dev/null

cd "$srcdir/$_distdir"
/usr/bin/perl Makefile.PL
make
)
}

check() {
cd "$srcdir/$_distdir"
( export PERL_MM_USE_DEFAULT=1 PERL5LIB=""
make test
)
}

package() {
cd "$srcdir/$_distdir"
make install

find "$pkgdir" -name .packlist -o -name perllocal.pod -delete
}

# Local Variables:
# mode: shell-script
# sh-basic-offset: 2
# End:
# vim:set ts=2 sw=2 et:

amish commented on 2017-09-03 09:15

Package is out of date from long. Plus new version is released 1.31. Please update

bidulock commented on 2017-06-10 10:45

Here is a PKGBUILD that works for 1.30 release:

https://gist.github.com/bbidulock/e4225f04311e74ecb52ae015d79b08f6

amish commented on 2017-06-07 17:13

Yes I have already done that. But since I do it via git. My local git tree differs from AUR git. Plus bumping pkgver or pkgrel will make sure that AUR helpers will detect that it needs to be recompiled (for example against new perl 5.26) and also update automatically.

mgd commented on 2017-06-07 16:57

Updating to 1.29 is trivial. Replacing the checksums in PKGBUILD should do the job. Recompiling vs perl 5.26 worked out-of-the-box yesterday.

FYC here the checksums:
md5sums=('2c9cc323dd40f2096172027dc4512abc')
sha512sums=('fb71d44c8ec8420d7f80a8c7a9a0fc5db5023303f6317a6e49b06681df2ebb7b88af14a43e50f97cc328921a636453fb6a9840f6251d0a2c48205cd48b1d529d')

amish commented on 2017-06-07 16:39

Please update to latest version to 1.29 and also for recompiling against perl 5.26

jnbek commented on 2015-08-03 20:34

Updating the package. Sorry for the wait.

bidulock commented on 2015-06-28 15:11

Please update package to 1,19 to trigger recompile against perl 5.22.0.

jnbek commented on 2014-06-10 05:37

I will update this in an hour or so. Knock off all the cheap sources :-P I've been busy

All comments