Package Details: perl-www-shorten 3.06-1

Git Clone URL: https://aur.archlinux.org/perl-www-shorten.git (read-only)
Package Base: perl-www-shorten
Description: Interface to URL shortening sites
Upstream URL: https://metacpan.org/release/WWW-Shorten
Licenses: GPL, PerlArtistic
Submitter: None
Maintainer: bunder
Last Packager: bunder
Votes: 3
Popularity: 0.000000
First Submitted: 2010-10-09 14:42
Last Updated: 2015-08-16 04:42

Dependencies (3)

Required by (0)

Sources (1)

Latest Comments

mhellwig commented on 2012-10-16 10:18

sorry for the long delay, just had time again to look at this.
the only thing in site_perl is File/MMagic.pm
I've also checked whether there are other "cpanplus" or "makemaker" related files on my system but there aren't. The only ones that are there are owned by the perl package itself, according to pacman -Qo.

So I continue being confused. Currently I can't seem to build any aur packages related to perl, they all fail with this same error.

bunder commented on 2012-09-23 05:47

Check if you have /usr/share/perl5/site_perl directory with old version of CPANPlus or MakeMaker packages, which can interfere with default ones during build.

mhellwig commented on 2012-09-19 07:47

/usr/share/perl5/core_perl/CPAN/Meta/Converter.pm is owned by perl 5.16.1-1

bunder commented on 2012-09-18 18:09

pacman -Qo /usr/share/perl5/core_perl/CPAN/Meta/Converter.pm

mhellwig commented on 2012-09-17 13:17

whichever one is currently available in ARCH? The packages on the computer are up to date.

mhellwig commented on 2012-09-17 12:36

whichever one is currently available in ARCH? The packages on the computer are up to date.

bunder commented on 2012-09-12 08:46

What version of Perl package is installed on your machine?

mhellwig commented on 2012-09-12 08:32

currently doesn't build for me. Error I get is:
==> Starting build()...
Checking if your kit is complete...
Looks good
Warning: prerequisite Config::Auto 0 not found.
Can't locate object method "add_string_requirement" via package "CPAN::Meta::Requirements" at /usr/share/perl5/core_perl/CPAN/Meta/Converter.pm line 358.
at /usr/share/perl5/core_perl/ExtUtils/MM_Any.pm line 824.
Can't locate object method "add_string_requirement" via package "CPAN::Meta::Requirements" at /usr/share/perl5/core_perl/CPAN/Meta/Converter.pm line 358.
==> ERROR: A failure occurred in build().