Package Details: pgadmin4-last 5.2-5

Git Clone URL: https://aur.archlinux.org/pgadmin4-last.git (read-only, click to copy)
Package Base: pgadmin4-last
Description: Comprehensive design and management interface for PostgreSQL
Upstream URL: https://www.pgadmin.org/
Licenses: custom
Conflicts: pgadmin4
Provides: pgadmin4=5.2
Replaces: pgadmin4
Submitter: i.ivanov
Maintainer: i.ivanov
Last Packager: i.ivanov
Votes: 4
Popularity: 1.72
First Submitted: 2021-04-26 14:04
Last Updated: 2021-05-21 09:07

Required by (0)

Sources (6)

Latest Comments

FabioLolix commented on 2021-06-09 15:05

Hello, please re-upload this pkgbuild as pgadmin4-5.x or similar (pgadmin5, pgadmin-5), I have seen that repo version is flagged OOD since 02-25 but using -last, latest suffix is not acceptable.

sflor commented on 2021-05-27 08:32

Getting the same error as voyen…

voyen commented on 2021-05-24 00:08

When trying to run from term, I'm getting a flask-security error: "ValueError: User model must contain fs_uniquifier as of 4.0.0" I'm no python dev though so can't really do much to help from my end.

i.ivanov commented on 2021-05-21 08:17

Now it builds with last Flask update. I added some patches

i.ivanov commented on 2021-05-18 07:38

Hi guys, I'll try to dedicate some time and to make this build even with Flask v2.
Though I'm not python developer too, I'm not sure if it will be so easy.
Any help will be appreciated.

archcomp commented on 2021-05-17 23:14

THANK YOU!!!

This works for the time being.

Hopefully, this package gets updated. This build process runs smoothly. So smoothly, that we would not need an update of pgAdmin4 in the official repository, if this build process is maintained.

Kind regards, Andre Hasekamp.

petrzjunior commented on 2021-05-17 09:38

python-flask got upgraded to 2.0 and broke startup of pgAdmin. I managed to downgrade from local pacman cache, but this might not be the optimal solution.

archcomp commented on 2021-05-16 14:01

Trying to build package pgadmin4-last, but it terminates as follows:

==> Starting build()... LC_ALL=en_US.UTF-8 LANG=en_US.UTF-8 make -C docs/en_US -f Makefile.sphinx html make[1]: Entering directory '/home/pub/Downloads/pgAdmin4/pgadmin4-last/src/pgadmin4-5.2/docs/en_US' Generating code-snippet.rst for some of the important classes... Traceback (most recent call last): File "/home/pub/Downloads/pgAdmin4/pgadmin4-last/src/pgadmin4-5.2/docs/en_US/build_code_snippet.py", line 67, in <module> from pgadmin.browser.utils import NodeView File "/home/pub/Downloads/pgAdmin4/pgadmin4-last/src/pgadmin4-5.2/web/pgadmin/browser/utils.py", line 16, in <module> from flask.views import View, MethodViewType, with_metaclass ImportError: cannot import name 'with_metaclass' from 'flask.views' (/usr/lib/python3.9/site-packages/flask/views.py) make[1]: [Makefile.sphinx:22: code_snippet] Error 1 (ignored) sphinx-build -W -b html -d _build/doctrees -d /tmp/ . _build/html Running Sphinx v4.0.1 making output directory... done building [mo]: targets for 0 po files that are out of date building [html]: targets for 158 source files that are out of date updating environment: [new config] 158 added, 0 changed, 0 removed reading sources... [100%] viewdata_filter

Warning, treated as error: /home/pub/Downloads/pgAdmin4/pgadmin4-last/src/pgadmin4-5.2/docs/en_US/code_snippets.rst:10:Unknown target name: "nodeview". make[1]: [Makefile.sphinx:47: html] Error 2 make[1]: Leaving directory '/home/pub/Downloads/pgAdmin4/pgadmin4-last/src/pgadmin4-5.2/docs/en_US' make: [Makefile:137: docs] Error 2 ==> ERROR: A failure occurred in build(). Aborting...

[andre@X299 ~]$ uname -r 5.12.3-arch1-1

My guess is that this is caused by the many updates of python lately. Unfortunately, I am not familiar with python (I'm a C++ programmer). Yes, I see the statement "import NodeView" in line 67 of build_code_snippet.py, but I really don't know what to do with it.

Can you please help me?

Kind regards, Andre Hasekamp.