Package Details: pgcli 2.1.1-4

Git Clone URL: (read-only)
Package Base: pgcli
Description: a command line interface for Postgres with auto-completion and syntax highlighting
Upstream URL:
Keywords: dbcli postgres
Licenses: BSD
Conflicts: pgcli-git
Provides: pgcli
Submitter: fzerorubigd
Maintainer: asm0dey
Last Packager: asm0dey
Votes: 34
Popularity: 0.34
First Submitted: 2016-03-16 16:15
Last Updated: 2019-06-01 13:40

Pinned Comments

asm0dey commented on 2019-06-01 13:54

@Quatro updated requirement version, so waiting for sqlparse to update version

Latest Comments

« First ‹ Previous 1 2 3 4 5 6 7 Next › Last »

rodweb commented on 2019-01-04 19:28

pgspecial dependency need to be updated?

Traceback (most recent call last):
  File "/usr/bin/pgcli", line 6, in <module>
    from pkg_resources import load_entry_point
  File "/usr/lib/python3.7/site-packages/pkg_resources/", line 3126, in <module>
  File "/usr/lib/python3.7/site-packages/pkg_resources/", line 3110, in _call_aside
    f(*args, **kwargs)
  File "/usr/lib/python3.7/site-packages/pkg_resources/", line 3139, in _initialize_master_working_set
    working_set = WorkingSet._build_master()
  File "/usr/lib/python3.7/site-packages/pkg_resources/", line 583, in _build_master
    return cls._build_from_requirements(__requires__)
  File "/usr/lib/python3.7/site-packages/pkg_resources/", line 596, in _build_from_requirements
    dists = ws.resolve(reqs, Environment())
  File "/usr/lib/python3.7/site-packages/pkg_resources/", line 784, in resolve
    raise DistributionNotFound(req, requirers)
pkg_resources.DistributionNotFound: The 'pgspecial>=1.11.5' distribution was not found and is required by pgcli

Markus00000 commented on 2018-12-02 07:28

@asm0dey Awesome! Special thanks for letting me know.

asm0dey commented on 2018-12-02 06:39

@Markus00000 I've updated my package to provide python-prompt_toolkit, not python-prompt_toolkit-2, now you should be able to select what you need

Markus00000 commented on 2018-11-20 07:27

@asm0dey It is now 2.0.7:

asm0dey commented on 2018-11-19 14:54

@blueyed for me it looks like community/python-prompt_toolkit 1.0.15-2. For you?

blueyed commented on 2018-11-19 12:54

community/python-prompt_toolkit has been updated to 2.0.7-1, so python-prompt_toolkit-2 should not be needed anymore I guess?!

Markus00000 commented on 2018-11-12 08:21

@asm0dey Much appreciated, thanks a lot!

asm0dey commented on 2018-11-11 21:41

@Markus00000 I've created package ipython-7 which works with new version of prompt_toolkit

asm0dey commented on 2018-10-09 10:07

@Markus00000 then you can offer maintainer of ipython to upgrade to 7th version and use my version of python-prompt_toolkit

Markus00000 commented on 2018-10-09 09:35

@asm0dey Thank you, I wasn’t sure if there was another solution.

Seems to be resolved in ipython 7: