Package Details: pgcli 2.1.1-4

Git Clone URL: (read-only)
Package Base: pgcli
Description: a command line interface for Postgres with auto-completion and syntax highlighting
Upstream URL:
Keywords: dbcli postgres
Licenses: BSD
Conflicts: pgcli-git
Provides: pgcli
Submitter: fzerorubigd
Maintainer: asm0dey
Last Packager: asm0dey
Votes: 34
Popularity: 0.30
First Submitted: 2016-03-16 16:15
Last Updated: 2019-06-01 13:40

Pinned Comments

asm0dey commented on 2019-06-01 13:54

@Quatro updated requirement version, so waiting for sqlparse to update version

Latest Comments

« First ‹ Previous 1 2 3 4 5 6 7 Next › Last »

asm0dey commented on 2018-10-09 09:27

@Markus00000 Well, yes, now pgcli uses new version of python-prompt_toolkit which is incompatible with old one, so you'll need to choose which thing you need more: ipython or pgcli. I've chosen pgcli.

Markus00000 commented on 2018-10-09 09:07

I can’t upgrade because of a dependency conflict.

looking for conflicting packages...
:: python-prompt_toolkit-2 and python-prompt_toolkit are in conflict. Remove python-prompt_toolkit? [y/N] y
error: failed to prepare transaction (could not satisfy dependencies)
:: removing python-prompt_toolkit breaks dependency 'python-prompt_toolkit' required by ipython
:: removing python-prompt_toolkit breaks dependency 'python-prompt_toolkit' required by pgcli

rodweb commented on 2018-09-07 00:11

@asm0dey @ftheile Worked like a charm guys, thanks!

asm0dey commented on 2018-09-05 20:44

@ftheile thank you for clue, added version of dependency

ftheile commented on 2018-09-05 20:33

@rodweb I had the same issue, but after updating python-cli_helpers to 1.0.2-1 it's working again.

rodweb commented on 2018-09-04 13:15

No. It stopped working after an update about 2 weeks ago. I tried removing and installing again but the error persists (pacman -Rns pgcli, yay -S pgcli).

asm0dey commented on 2018-09-04 13:01

@rodweb have no any idea. Is it fresh installation?

rodweb commented on 2018-09-04 12:53

any tips on what's happening?

Traceback (most recent call last):
  File "/usr/bin/pgcli", line 6, in <module>
    from pkg_resources import load_entry_point
  File "/usr/lib/python3.7/site-packages/pkg_resources/", line 3105, in <module>
  File "/usr/lib/python3.7/site-packages/pkg_resources/", line 3089, in _call_aside
    f(*args, **kwargs)
  File "/usr/lib/python3.7/site-packages/pkg_resources/", line 3118, in _initialize_master_working_set
    working_set = WorkingSet._build_master()
  File "/usr/lib/python3.7/site-packages/pkg_resources/", line 578, in _build_master
  File "/usr/lib/python3.7/site-packages/pkg_resources/", line 895, in require
    needed = self.resolve(parse_requirements(requirements))
  File "/usr/lib/python3.7/site-packages/pkg_resources/", line 781, in resolve
    raise DistributionNotFound(req, requirers)
pkg_resources.DistributionNotFound: The 'pgcli==1.10.3' distribution was not found and is required by the application

asm0dey commented on 2018-08-01 12:37

@blueyed fixed

blueyed commented on 2018-07-30 09:13

Currently broken due to requiring pgspecial 1.11.2 ( Flagged it out of date, but it would be good if that would not happen, of course.