Package Details: phatch 0.2.7.1-11

Git Clone URL: https://aur.archlinux.org/phatch.git (read-only, click to copy)
Package Base: phatch
Description: A simple to use cross-platform GUI Photo Batch Processor.
Upstream URL: http://photobatch.stani.be
Licenses: GPL
Provides: phatch=0.2.7.1
Submitter: Mymaud
Maintainer: None
Last Packager: blubbblubb
Votes: 105
Popularity: 0.034600
First Submitted: 2007-10-07 08:52
Last Updated: 2019-04-30 13:21

Dependencies (6)

Required by (0)

Sources (2)

Latest Comments

« First ‹ Previous ... 2 3 4 5 6 7 8 9 Next › Last »

anish commented on 2010-11-14 20:13

Sorry, I've been meaning up update the package for a while now, done.

Evilandi666 commented on 2010-11-14 19:55

I found another - easier - solution:

Install python2, sudo pacman -S python2

after makepkg failed,

change in phatch-0.2.7.1.tar.gz in file setup.py and /phatch/phatch.py the first line from
#!/usr/bin/env python
to
#!/usr/bin/env python2

and in the PKGBUILD

from python setup.py install --root=${startdir}/pkg/ || return 1
to python2 setup.py install --root=${startdir}/pkg/ || return 1

make new md5sum of phatch-0.2.7.1.tar.gz (md5sum phatch-0.2.7.1.tar.gz)

and put it in md5sums=('')

works fine!

https://wiki.archlinux.org/index.php/Python

Evilandi666 commented on 2010-11-14 19:42

I ment "edit the File /phatch/data/info.py in phatch-0.2.7.1.tar.gz"

instead of "edit in phatch-0.2.7.1.tar.gz:" ..

sry :)

Evilandi666 commented on 2010-11-14 19:41

How to get it working:

After makepkg failed,

edit in phatch-0.2.7.1.tar.gz:

replace every string like u'bla' with 'bla', because u'<string>' is not allowed in python 3 (unicode() also!)) (in 2 both were possible)

replace from version import VERSION, DATE
with:
BASE = "0.2.7"
VERSION = "0.2.7"
DATE = "Wed, 10 Mar 2010 18:49:51"

make new md5sum of phatch-0.2.7.1.tar.gz (md5sum phatch-0.2.7.1.tar.gz)

and put it in md5sums=('')

After that it installs fine!

Evilandi666 commented on 2010-11-14 19:04

oh..

Traceback (most recent call last):
File "setup.py", line 42, in <module>
from data import info
File "phatch/data/info.py", line 55
{'name': u'Erich Heine',
^
SyntaxError: invalid syntax

phatch/data/info.py has a problem :(

Evilandi666 commented on 2010-11-14 19:00

Error in
optdepends=("python-nautilus : Provides better [..]")

changed to

optdepends=("python-nautilus")

error gone. :)

serabob commented on 2010-11-11 15:30

Traceback (most recent call last):
File "setup.py", line 42, in <module>
from data import info
File "phatch/data/info.py", line 55
{'name': u'Erich Heine',
^
SyntaxError: invalid syntax

whats the problem ?

tchgefest commented on 2010-11-01 16:31

$phatch
Traceback (most recent call last):
File "/usr/bin/phatch", line 10, in <module>
import phatch
ImportError: No module named phatch

cat /usr/bin/phatch | grep python
#!/usr/bin/python2

tchgefest commented on 2010-11-01 16:29

yaourt -S phatch
Continue building phatch ? [Y/n]
==> --------------------------------
==>
==> Building and installing package
==> ОШИБКА: Неправильный синтаксис для optdepend : 'python-nautilus : allow a better integration in nautilus'
==> Сборка пакета: phatch 0.2.7.1-2 (Пнд Ноя 1 21:28:17 YEKT 2010)
==> Проверяю необходимые для запуска зависимости...
==> Проверяю необходимые для сборки зависимости...
==> Получение исходных файлов...
-> Найден phatch-0.2.7.1.tar.gz
==> Проверка исходных файлов с помощью md5sums...
phatch-0.2.7.1.tar.gz ... Готово
==> Распаковка исходных файлов...
-> Извлечение phatch-0.2.7.1.tar.gz с помощью bsdtar
==> Вход в fakeroot окружение...
==> ОШИБКА: Неправильный синтаксис для optdepend : 'python-nautilus : allow a better integration in nautilus'
==> Запускается build()...
Traceback (most recent call last):
File "setup.py", line 42, in <module>
from data import info
File "phatch/data/info.py", line 55
{'name': u'Erich Heine',
^
SyntaxError: invalid syntax
Преждевременный выход...
==> ERROR: Makepkg was unable to build phatch.

unhammer commented on 2010-10-19 13:55

I had to edit the first line of phatch to say

#!/usr/bin/python2

since it doesn't work with the new python package (version 3), also depends should say python2.


Also, http://photobatch.wikidot.com/install says that pyexiv2 is optional, and I really think it should be as I and others have had problems with phatch when having that installed.