Package Details: phatch 0.2.7.1-11

Git Clone URL: https://aur.archlinux.org/phatch.git (read-only, click to copy)
Package Base: phatch
Description: A simple to use cross-platform GUI Photo Batch Processor.
Upstream URL: http://photobatch.stani.be
Licenses: GPL
Provides: phatch=0.2.7.1
Submitter: Mymaud
Maintainer: None
Last Packager: blubbblubb
Votes: 105
Popularity: 0.034540
First Submitted: 2007-10-07 08:52
Last Updated: 2019-04-30 13:21

Dependencies (6)

Required by (0)

Sources (2)

Latest Comments

« First ‹ Previous ... 3 4 5 6 7 8 9 Next › Last »

Anonymous comment on 2010-08-15 20:16

the package pil does not exist, it is named python24-pil

TiborB commented on 2010-05-24 20:13

Anish, you just posted the current version of pyexiv2 MAKEPKG, that did not work for me. I tried it now once more - the same, it dont work...
Never mind - it is not urgent for me....

anish commented on 2010-05-23 23:05

This works for me :
pkgname=pyexiv2
pkgver=0.2.1
pkgrel=1
pkgdesc="a python binding to exiv2"
depends=('python' 'boost' 'exiv2')
makedepends=('scons')
arch=('i686' 'x86_64')
license=('GPL')
source=(http://launchpad.net/$pkgname/0.2.x/$pkgver/+download/$pkgname-$pkgver.tar.bz2)
url="http://tilloy.net/dev/pyexiv2"
md5sums=('17f0c36f64bc33c3bbc1f978628acd48')

anish commented on 2010-05-23 21:06

@TiborB, I just tried it on a new machine, and it compiles and work fine for me, maybe there is something else missing here. Can you try setting your CFLAGS to the defaults in makepkg.conf and see if it makes a difference ?

TiborB commented on 2010-05-23 21:03

I don't remember editing makepkg.conf (maybe during installation of OS?), so that line looks like this:
CFLAGS="-march=i686 -mtune=generic -O2 -pipe"

But problem might be with PKGBUILD, I dont know where to get older version (if possible at all), so I just modified current one, and changed following lines:
pkgver=0.1.3
source=(http://launchpad.net/$pkgname/0.1.x/$pkgver/+download/$pkgname-$pkgver.tar.bz2)
md5sums=('dfc28a6f5f098f88926e8e1de6b925c0')

If there are more differencies, please let me know...

anish commented on 2010-05-23 20:52

@TiborB, I just tried it on a new machine, and it compiles and work fine for me, maybe there is something else missing here. Can you try setting your CFLAGS to the defaults in makepkg.conf and see if it makes a difference ?

TiborB commented on 2010-05-23 20:47

I see.
But I have no older packages of pyexiv2 on my box, and v 0.1.3 failed to compile:

g++ -o build/libpyexiv2.os -c -fPIC -I/usr/include/python2.6 src/libpyexiv2.cpp
src/libpyexiv2.cpp: In member function 'boost::python::tuple LibPyExiv2::Image::setIptcTag(std::string, std::string, unsigned int)':
src/libpyexiv2.cpp:231: error: 'Exiv2::FindMetadatumById' has not been declared
src/libpyexiv2.cpp: In member function 'boost::python::tuple LibPyExiv2::Image::deleteIptcTag(std::string, unsigned int)':
src/libpyexiv2.cpp:269: error: 'Exiv2::FindMetadatumById' has not been declared
scons: *** [build/libpyexiv2.os] Error 1
scons: building terminated because of errors.
==> ERROR: Build Failed.

Anyway, I'm not going to investigate what is wrong and will just wait till it is fixed 'upstream', I hope it will not take too long... and thanks for very fast answer...

anish commented on 2010-05-23 20:32

@TiborB you are getting that error because pyexiv changed their API a bit, can't be fixed till phatch updates. In the meantime, try an older version of pyexiv

TiborB commented on 2010-05-23 20:25

Hi, I run into this error:

Traceback (most recent call last):
File "/usr/lib/python2.6/site-packages/phatch/core/api.py", line 493, in get_photo
photo = pil.Photo(info_file, info_not_file)
File "/usr/lib/python2.6/site-packages/phatch/core/pil.py", line 457, in __init__
layer.image)
File "/usr/lib/python2.6/site-packages/phatch/core/pil.py", line 183, in __init__
self.pyexiv2 = pyexiv2.Image(path)
AttributeError: 'module' object has no attribute 'Image'

Or is it problem with pyexiv? No images are of course processed.....

anish commented on 2010-05-04 23:55

@stani @dinux dependencies are fixed now