Package Details: photivo-hg 1124+.41a1d55bb275+-1

Git Clone URL: https://aur.archlinux.org/photivo-hg.git (read-only, click to copy)
Package Base: photivo-hg
Description: Free and open source photo processor
Upstream URL: http://photivo.org/
Licenses: GPL3
Conflicts: photivo
Provides: photivo
Submitter: stativ
Maintainer: stativ
Last Packager: stativ
Votes: 41
Popularity: 0.000014
First Submitted: 2010-10-30 10:09
Last Updated: 2018-04-01 15:03

Latest Comments

« First ‹ Previous 1 2 3 4 5 6 7 8 Next › Last »

Anonymous comment on 2012-02-06 17:35

Downgrading mercurial to version 2.0.2 allowed me to compile Photivo successfully.

Anonymous comment on 2012-02-06 17:06

Photivo won't build after recent Arch Linux system upgrade. I started to post that I thought the problem was a result of the libpng upgrade as this caused build problems for me with other packages. But after further investigation I think the problem is a result of the makepkg/mecurial bug mentioned below.

stativ commented on 2012-02-05 09:16

Well, then you are most likely hitting the bug in makepkg: https://bugs.archlinux.org/task/28248

Anonymous comment on 2012-02-05 06:50

I tried again today and i obtain the same error.

stativ commented on 2012-02-04 09:48

alelinuxbsdalelinuxbsd: looks like the mercurial server was down, it works fine.

Anonymous comment on 2012-02-02 17:07

Few days ago i tried this package on archlinux at 32 bit and everything work fine.
Now i tried the same package on the 64 bit platform and I obtain this message:

Connecting to Mercurial server....
warning: photivo.googlecode.com certificate with fingerprint e9:f0:26:b1:ff:27:28:33:81:8e:51:7b:fd:a7:de:df:4c:1e:ee:14 not verified (check hostfingerprints or web.cacerts config setting)
il vero URL è https://photivo.googlecode.com/hg/
sto facendo pull da https://photivo.googlecode.com/hg//photivo
sto cercando modifiche
nessuna modifica trovata
==> ERRORE: Si è verificato un errore in build().
L'operazione sta per essere interrotta...
==> ERRORE: Makepkg non è riuscito a compilare photivo-hg.

Essentially the compilation of photivo-hg fails.

stativ commented on 2011-11-28 13:57

kayou: Thank you very much, your help is very appreciated! I've updated the depends to require graphicsmagick-qd16 instead of graphicsmagick.

Anonymous comment on 2011-11-26 15:38

I've make a PKGBUILD https://aur.archlinux.org/packages.php?ID=54329 , for GraphicsMagick with the 2 missing options --with-quantum-depth=16 and --without-lcms wich are needed tu run photivo

stativ commented on 2011-10-25 07:28

chenxing: it seems so. It should be configured with "--with-quantum-depth 16" or "--with-quantum-depth 32". I'll make a PKGBUILD for it when I have a bit more time.

chenxing commented on 2011-10-24 03:08

Got this error when trying to run photivo:
$ photivo
Photivo version 2011-10-21 (rev 6bb9ea6f60aa)+
Fatal error: Wrong GraphicsMagick quantum depth!
Found quantum depth 8. Photivo needs at least 16.


Do I have to compile GraphicsMagick myself?