Package Details: php-codesniffer-drupal 8.x_2.12-2

Git Clone URL: https://aur.archlinux.org/php-codesniffer-drupal.git (read-only)
Package Base: php-codesniffer-drupal
Description: Drupal coding standard for PHP_CodeSniffer
Upstream URL: http://drupal.org/project/coder
Licenses: GPL
Submitter: jsst
Maintainer: sanduhrs
Last Packager: sanduhrs
Votes: 4
Popularity: 0.001948
First Submitted: 2013-04-19 16:49
Last Updated: 2017-06-27 13:03

Dependencies (2)

Required by (0)

Sources (1)

Pinned Comments

ram4nd commented on 2017-09-22 07:24

If you want to install the package: https://browse-tutorials.com/tutorial/archlinux-install-older-package-aur

sanduhrs commented on 2017-07-10 09:28

Currently upstream Drupal Coder is only compatible with php-codesniffer < 3.0.0.
See https://www.drupal.org/node/2863898 for details.

Latest Comments

ram4nd commented on 2017-09-22 07:24

If you want to install the package: https://browse-tutorials.com/tutorial/archlinux-install-older-package-aur

sanduhrs commented on 2017-07-10 09:28

Currently upstream Drupal Coder is only compatible with php-codesniffer < 3.0.0.
See https://www.drupal.org/node/2863898 for details.

dmp1ce commented on 2015-10-09 13:30

Thank you for updating this package! It works for me now without any modifications.

sanduhrs commented on 2015-10-07 14:03

Updated to latest upstream 8.x-2.4

dmp1ce commented on 2014-11-06 15:38

Looking at the PKGBUILD it looks like this is still using 7.x-2.1. Can we update to 7.x-2.2? https://www.drupal.org/node/2203251

jsst commented on 2014-06-26 14:31

Updated to 7.x-2.2, not sure if sniffs are changed.

dmp1ce commented on 2014-06-21 06:45

Nevermind. I had my previous error because I had manually updated Drupal/Sniffs and I had extra files. I deleted those files and the update worked fine.

dmp1ce commented on 2014-06-21 06:30

I cannot update with Yaourt. When I try to update with Yaourt I get

Packages (1): php-codesniffer-drupal-7.x_2.1-1

Total Installed Size: 0.24 MiB
Net Upgrade Size: -0.09 MiB

:: Proceed with installation? [Y/n] Y
(1/1) checking keys in keyring [#####################################################################] 100%
(1/1) checking package integrity [#####################################################################] 100%
(1/1) loading package files [#####################################################################] 100%
(1/1) checking for file conflicts [#####################################################################] 100%
error: failed to commit transaction (conflicting files)
php-codesniffer-drupal: /usr/share/pear/PHP/CodeSniffer/Standards/Drupal/Sniffs/Formatting/SpaceInlineIfSniff.php exists in filesystem
php-codesniffer-drupal: /usr/share/pear/PHP/CodeSniffer/Standards/Drupal/Sniffs/Semantics/ConstantNameSniff.php exists in filesystem
php-codesniffer-drupal: /usr/share/pear/PHP/CodeSniffer/Standards/Drupal/Sniffs/WhiteSpace/OperatorSpacingSniff.php exists in filesystem
Errors occurred, no packages were upgraded.
==> WARNING: Your packages are saved in /tmp/yaourt-tmp-david
==> ERROR: unable to update

jsst commented on 2014-02-03 21:09

Updated to 7.x-2.1, seems to work well with current phpcs. Thanks for the feedback.

grugnog commented on 2014-01-26 02:00

It appears that 2.1 is released, and includes this fix - URL/md5 at https://drupal.org/node/2156611

All comments