Package Details: php-language-server 5.4.6-4

Git Clone URL: https://aur.archlinux.org/php-language-server.git (read-only, click to copy)
Package Base: php-language-server
Description: PHP language server implementation
Upstream URL: https://github.com/felixfbecker/php-language-server
Keywords: language lsp php server
Licenses: ISC
Submitter: JJK
Maintainer: milouse
Last Packager: milouse
Votes: 0
Popularity: 0.000000
First Submitted: 2018-11-24 14:04 (UTC)
Last Updated: 2023-06-21 12:32 (UTC)

Dependencies (2)

Required by (0)

Sources (3)

Latest Comments

milouse commented on 2024-02-19 16:25 (UTC)

@vriktorious the upstream package is almost abandonned, and no decision has been made so far to either switch to one of the fork or definitely abandonned it here also.

In any case, this package is well flagged as requiring php74 (an AUR package) as upstream does not support php8 (only version available on official repositories).

So your error probably comes from the fact yay did not correctly pull/build the php74 dependency before trying to build this package. I don’t know yay at all, but as a generic work around, you should first install php74, then install this package, and finally flag php74 has a dependency of this one (pacman -D --asdeps php74)

vriktorious commented on 2024-02-10 17:16 (UTC)

When building i get an error

==> Starting build()...
/home/ant/.cache/yay/php-language-server/PKGBUILD: line 29: php7: command not found
==> ERROR: A failure occurred in build().
    Aborting...
 -> error making: php-language-server-exit status 4
 -> Failed to install the following packages. Manual intervention is required:
php-language-server - exit status 4

Is there some dependency i dont have installed or something? I also noticed that the maintainer specified in the PKGBUILD is the old one

JJK commented on 2023-06-21 12:57 (UTC)

I haven't been using Arch Linux for a while now, so I suggest that you make this decision on your own.

milouse commented on 2023-06-21 12:34 (UTC)

Actually, the upstream repository look abandonned. Maybe time to move to another fork?

milouse commented on 2022-07-26 16:22 (UTC)

I’ve fixed the PKGBUILD to make it buildable and usable again. Enjoy.

JJK commented on 2021-05-12 16:43 (UTC)

I no longer use this package. Since it is broken currently I think it is better that I disown it so someone who uses this software can fix it.

amael commented on 2021-05-12 08:55 (UTC)

Hello, I got the following errors while installing. I believe it's because composer is only available for php8 in the extra repository.

Your requirements could not be resolved to an installable set of packages.

  Problem 1
    - Root composer.json requires php ^7.0 but your php version (8.0.5) does not satisfy that requirement.
  Problem 2
    - phpdocumentor/reflection-docblock[4.0.0, ..., 4.3.4] require php ^7.0 -> your php version (8.0.5) does not satisfy that requirement.
    - Root composer.json requires phpdocumentor/reflection-docblock ^4.0.0 -> satisfiable by phpdocumentor/reflection-docblock[4.0.0, ..., 4.3.4].

nicolino commented on 2021-01-08 10:47 (UTC)

Non-resolved issue "upstream" https://github.com/felixfbecker/php-language-server/pull/756 prevents installation. Due to the fact that the problem deep down lies in a @deprecated not being treated, it is possible to still install the package by modifying /src/DefinitionResolver.php#L167 according to the link.