Package Details: php-oci8 3.3.0-1

Git Clone URL: (read-only, click to copy)
Package Base: php-oci8
Description: PHP extension for OCI8
Upstream URL:
Licenses: PHP
Submitter: nubs
Maintainer: nubs
Last Packager: nubs
Votes: 10
Popularity: 0.106583
First Submitted: 2014-07-16 12:04 (UTC)
Last Updated: 2024-01-16 20:57 (UTC)

Latest Comments

1 2 Next › Last »

pdynarowski commented on 2024-01-13 13:04 (UTC) (edited on 2024-01-13 13:04 (UTC) by pdynarowski)

I make pull request for latest oci-3.3.0 (PHP >= 8.2)

pdynarowski commented on 2023-01-30 19:28 (UTC) (edited on 2023-01-30 19:28 (UTC) by pdynarowski)

It also works for PHP 8.1, 8.2

nubs commented on 2021-01-31 22:27 (UTC)

Thanks @pdynarowski! I updated to oci8 3.0.1. Let me know if you run into any problems. Cheers!

pdynarowski commented on 2021-01-31 21:18 (UTC) (edited on 2021-01-31 21:21 (UTC) by pdynarowski)

Package works in PHP 8 when: in PKGBUILD change:


and don't update instant client! This works for instant client 19 and not 20 and its update for PHP8, its doesnt work for PHP7.4

More info:

pdynarowski commented on 2021-01-30 22:53 (UTC)

What about PHP8 ?

robin91 commented on 2019-12-12 11:00 (UTC)

Hello! A've updated php to 7.4.0-2 and got an error PHP Warning: PHP Startup: Unable to load dynamic library '' (tried: /usr/lib/php/modules/ (/usr/lib/php/modules/ undefined symbol: add_index_zval)

PHP 7.4.0 (cli) (built: Nov 30 2019 10:43:49) Zend Engine v3.4.0 with Xdebug v2.8.1

nubs commented on 2018-07-30 15:46 (UTC)

Hi @eklausmeier, could you submit a pull request at Cheers!

eklausmeier commented on 2018-07-29 11:34 (UTC)

Version 2.1.3 is out of date.

Current version is 2.1.8, which works out of the box using your current PKGBUILD. If you make me a co-maintainer I will adapt the file accordingly. Thanks.

nubs commented on 2016-04-08 12:53 (UTC)

Updated to require PHP 7.0. Thanks!

vdemin commented on 2016-04-08 10:58 (UTC) (edited on 2016-04-08 11:03 (UTC) by vdemin)

Please fix php dependency. Version 2.1.0 builds with PHP 7 only. For PHP 5.2 - PHP 5.6, it is necessary to use version 2.0.10.