Package Details: php53 5.3.29-4

Git Clone URL: (read-only)
Package Base: php53
Description: An HTML-embedded scripting language - Legacy 5.3 version
Upstream URL:
Licenses: PHP
Conflicts: php, php-curl, php-fileinfo, php-gmp
Provides: php, php-curl, php-fileinfo, php-gmp
Submitter: None
Maintainer: felixonmars
Last Packager: felixonmars
Votes: 7
Popularity: 0.113989
First Submitted: 2012-06-24 22:51
Last Updated: 2015-07-23 11:55

Required by (365)

Sources (24)

Latest Comments

zlatkig commented on 2016-09-26 08:42

I have modified this package along the lines of php56, allowing it to coexist with other PHP versions. The snapshot is here:

mindcat commented on 2016-07-17 15:18

cat <<EOF > /etc/systemd/system/
Description=The PHP FastCGI Process Manager

ExecStart=/usr/bin/php-fpm --nodaemonize --pid /run/
ExecReload=/bin/kill -USR2 $MAINPID

#fix no systemd service file

alpha.niner commented on 2016-06-15 18:46

Regarding the freetype issue, I think the correct solution is to not apply freetype-path.patch. TL;DR(ThePatch), it breaks the path now rather than fixing it. :P

Alad commented on 2016-05-10 16:29

Why not get the ubuntu .debian archive, and apply patches in it with quilt? That should simplify things.

Also you should quote srcdir and pkgdir so the build doesn't fail in directories with spaces.

LithiumPT commented on 2016-01-26 15:20

kamahl, this should make it compile cleanly:
ln -s /usr/include/freetype2/freetype/freetype.h /usr/include/freetype2/freetype.h

felixonmars, would it be possible to make this package compatible with standard php install? Having both php (currently at version 7) and php53 coexist would be awesome! Maybe you could take a look at how the php56 package does it, as it can be installed side by side with php(7).

kamahl commented on 2016-01-14 12:52

I am getting the following error during configure:

configure: error: freetype.h not found.

I have the package freetype2 installed.

felixonmars commented on 2014-11-07 06:36

Hrm, since I don't find an environment to test it myself, I'll add a working service file if suggested.

sysfu commented on 2014-10-24 04:44

The unmodified php-fpm.service file which I copied from the php-fpm-5.6.2 packagce does not work for some reason.

If I run the command specified in the service file manually; '/usr/bin/php-fpm --nodaemonize --pid /run/php-fpm/' it works.

If I try starting the service using 'systemctl start php-fpm' it fails with the following vague messages in the systemd journal

Oct 23 17:33:57 fs systemd[1]: Failed to start The PHP FastCGI Process Manager.
Oct 23 17:33:57 fs systemd[1]: Unit php-fpm.service entered failed state.

felixonmars commented on 2014-10-24 02:32

Does the unmodified version work for you? I don't use fpm myself, but I can add it if it just works.

sysfu commented on 2014-10-24 00:09

Here's the systemd service file that php-fpm 5.6.2-2 is using:

Description=The PHP FastCGI Process Manager

ExecStart=/usr/bin/php-fpm --nodaemonize --pid /run/php-fpm/
ExecReload=/bin/kill -USR2 $MAINPID


sysfu commented on 2014-10-24 00:06

If you get time could you please add a .service file to the package so it can easily be enabled and run via systemd?

Driadan commented on 2013-06-05 07:54

Due to

line 263 should be changed to:

install -D -m755 ${srcdir}/build-fpm/sapi/fpm/php-fpm ${pkgdir}/usr/bin/php-fpm

Anonymous comment on 2013-04-15 18:41

checking for DB4 major version... configure: error: Header contains different version


devoncrouse commented on 2013-04-09 02:36

Anyone tested this on a fresh Arch install lately? I've used it before successfully, but this time not so much:

Had to disable mcrypt, db4, sysv stuff, openssl, and finally quit when I ran into problems with sqlite, since I need that.

Spider.007 commented on 2013-03-01 18:31

Have a look at

d3x commented on 2013-03-01 18:15

checking whether build with IMAP works... no
configure: error: build test failed. Please check the config.log for details.
==> ERROR: A failure occurred in build().

Driadan commented on 2013-02-22 17:02

had to remove both imap flags to get it to compile :S

Spider.007 commented on 2013-01-14 14:32

@jwa, I wouldn't mind adding a dependency, but I don't have json-glib installed (I do have json-c) and can still build this package, so I am unsure what dependency to add.

I have added the json extension

jwa commented on 2013-01-11 13:19

I'm with elamskoy on the JSON part. Also please add a line to the default php.ini.

Anonymous comment on 2012-10-30 10:34

I am orphaning my packages since I am no longer using Arch. Feel free to adopt.

el_aur commented on 2012-10-11 20:14

You have --with-json=shared in configure options
Problem: if there's no json-glib package installed in system, won't build.
Include this one package in dependencies please.

el_aur commented on 2012-10-08 19:44

Very useful package. Thanks!

Anonymous comment on 2012-09-22 17:44

The packages will conflict.

Anonymous comment on 2012-09-21 20:15

Will installing this override php5.4, or can it be installed in tandem?

Geoffroy commented on 2012-07-30 11:32

PHP 5.3 may still be usefull, for example I've got a problem with MantisBT SOAP API and I need to downgrade PHP

gtmanfred commented on 2012-06-26 18:16

you really shouldn't use php 5.3 mostly because of the security flaws, just fix your scripts and move on

Anonymous comment on 2012-06-24 22:51

Split package, so nevermind the bogus description.