Package Details: php56-pgsql 5.6.36-2

Git Clone URL: https://aur.archlinux.org/php56.git (read-only)
Package Base: php56
Description: PostgreSQL modules for PHP
Upstream URL: http://php.net
Keywords: php
Licenses: PHP
Provides: php-pgsql=5.6.36
Submitter: mickael9
Maintainer: mickael9 (foxxx0)
Last Packager: mickael9
Votes: 46
Popularity: 0.040223
First Submitted: 2016-01-03 21:26
Last Updated: 2018-07-08 09:49

Required by (24)

Sources (10)

Pinned Comments

mickael9 commented on 2016-04-06 11:51

PLEASE READ : For those who are getting "unknown public key" errors, this is NOT caused by this package. It means GPG is not configured to fetch public keys automatically (which is normal by default)

Please read the instructions at
https://wiki.archlinux.org/index.php/Makepkg#Signature_checking

The easiest way to overcome this is to manually import the keys from a keyserver :
$ gpg --keyserver hkp://hkps.pool.sks-keyservers.net --recv-keys C2BF0BC433CFC8B3 FE857D9A90D90EC1

mickael9 commented on 2016-01-14 01:53

foxxx and I have been working together and this package can now be installed along PHP 7 from the official repos.

Everything has been moved into separate directories :

Config : /etc/php56
Extensions : /usr/lib/php56/modules
Binaries : /usr/bin/php56, /usr/bin/php56-cgi, /usr/bin/phar56, etc.

If you were previously using this as a replacement for php7, you'll have to adjust the new configuration files in /etc/php56/ to reflect the current ones in /etc/php/.

Apache module (provided by php56-apache) also has a specific configuration and CAN NOT cohabit with php7_module. Use php-fpm, fcgi or cgi if you need both versions.

The apache module is installed as libphp56.so, so you should use the following lines your httpd.conf :

# Load php 5.6 module
LoadModule php5_module modules/libphp56.so

# Use it for .php extensions
Include conf/extra/php56_module.conf

Please let me know if you encounter any problem or have a suggestion.

Latest Comments

aznyouth commented on 2018-07-08 11:53

@mickael9 thanks dude, it was indeed the path issue. I changed it and it works!

mickael9 commented on 2018-07-08 10:05

@ludo.silvestre @gissf1 @aznyouth I guess it happened because /bin comes before /usr/bin in your PATH? It should work now.

aznyouth commented on 2018-07-07 23:19

I'm having trouble to install php56. I'm getting an error in check(). Can someone help me ?

gissf1 commented on 2018-05-30 22:53

I'm getting an error when checking sendmail in check(). Running the command manually shows that it returns "/bin/sendmail":

$ ./php -n -r 'echo ini_get("sendmail_path");'

/bin/sendmail -t -i

On my system, /bin is a symlink to /usr/bin, so its effectively the same file.

I have postfix installed and it owns /usr/bin/sendmail:

$ pacman -Qo /usr/bin/sendmail

/usr/bin/sendmail is owned by postfix 3.3.1-1

$ pacman -Qo /bin/sendmail

/usr/bin/sendmail is owned by postfix 3.3.1-1

Maybe I'm not quite understanding the purpose of the grep test.

ludo.silvestre commented on 2018-05-29 13:43

Check fails when checking for sendmail's path. This happens when the user have msmtp-mta installed instead of sendmail.

For some reason I have both /bin/sendmail and /usr/bin/sendmail. Only the first one is returned by "echo ini_get('sendmail_path');". With PHP 7.2, the path returned is /usr/bin/sendmail, so it's probably a configuration issue.

ChrisMorgan commented on 2018-05-28 06:09

The default configuration in this php56 package deviates from the extra/php package in a rather important way that took me some time to figure out: php.ini contains an arbitrary open_basedir restriction. I urge you to remove it from your php.ini.patch, because it is very surprising and fairly difficult to diagnose—for me the result was simply that as soon as I switched from stock php-fpm to stock php56-fpm it started failing with the mysterious “No input file specified.” error.

Remember that the default is nothing, rather than something containing a php that needs to be changed to php56.

foxxx0 commented on 2018-05-20 09:07

I added a patch to fix freetype2 >= 2.9.1 compatibility.

Should compile and work again :)

irreleph4nt commented on 2018-05-14 22:32

Does anyone know how to fix the libgd error? It's not compiling due to that.

checking for gdSetErrorMethod in -lgd... no

configure: error: Unable to find libgd.(a|so) >= 2.1.0 anywhere under /usr

gd obviously is installed.

IdleGandalf commented on 2018-05-11 02:35

There is a open bug [1] on the php tracker for this exact issue, but it doesn't look like they are gonna port this back to 5.6 (not even the other stable branches to be exact). The php package in the official repos got a patch [2] to detect freetype via pkg-config, maybe it can be backported to 5.6?

[1] https://bugs.php.net/bug.php?id=76324 [2] https://git.archlinux.org/svntogit/packages.git/tree/trunk/freetype.patch?h=packages/php

azero commented on 2018-05-10 11:03

Building php56 requires freetype-config executable which is no longer in freetype2 package. I have a freetype-config in my github.

wget https://raw.githubusercontent.com/Azero-NG/archlinux/master/freetype-config

chmod +x freetype-config

cp freetype-config /usr/bin

All comments