Package Details: php70-odbc 7.0.30-3

Git Clone URL: https://aur.archlinux.org/php70.git (read-only)
Package Base: php70
Description: ODBC modules for PHP
Upstream URL: http://www.php.net
Licenses: PHP
Provides: php70-odbc=7.0.30
Submitter: betrixed
Maintainer: wget
Last Packager: wget
Votes: 8
Popularity: 0.166116
First Submitted: 2017-02-05 08:12
Last Updated: 2018-07-03 16:00

Pinned Comments

wget commented on 2018-04-24 22:41

PGP keys from PHP maintainer (upstream) (src.: http://php.net/downloads.php#gpg-7.0) If you trust them, you can import the keys with $ gpg --recv-keys 1A4E8B7277C42E53DBA9C7B9BCAA30EA9C0D5763 6E4F6AB321FDC07F2C332E3AC2BF0BC433CFC8B3 Receiving GPG keys might fail with the following error message: $ gpg: keyserver receive failed: Connection refused If this happens, just check your DNS or use another one.

Latest Comments

wget commented on 2018-07-03 16:01

Thanks tunght13488! Package update with your fixes. And indeed this is working :) On my side I realized the compilation of this package was happening on one CPU core and tweaked a bit the PKGBUILD in order to improve it even further.

tunght13488 commented on 2018-06-18 03:04

I managed to get configure using pkg-config instead of freetype-config: https://github.com/tunght13488/aur-php70/commit/4a0db6535088bac262560aa7378092586da3b533

tunght13488 commented on 2018-06-18 02:23

I tried adding --with-freetype-dir=/usr \ after --with-enchant=shared,/usr \ but the build failed with freetype-config not found. Looks like freetype-config is no longer available in freetype2 and we should use something like pkg-config --cflags freetype2 instead of freetype-config --cflags. I'm still trying to figure out how to do that during the build.

tunght13488 commented on 2018-06-18 02:06

Looks like v7.0.30 removed freetype support. Function imageftbbox is no longer available

wget commented on 2018-06-13 15:41

Thanks el_aur for the patch! I appreciate it. It has been applied. Anything else I should replace/correct?

el_aur commented on 2018-06-07 13:14

There's issue with -embed package can you add there instrtuction to PKGBUILD:

mv ${pkgdir}/usr/lib/libphp7.so ${pkgdir}/usr/lib/libphp-70.so

just after

make -j1 INSTALL_ROOT=${pkgdir} PHP_SAPI=embed install-sapi

/usr/lib/libphp7.so is already owned by php package from native repo

wget commented on 2018-05-14 14:00

@rdoursenaud I started to implement the fix, but even with my bunch of regex to force the rename (see related commented lines in PKGBUILD), the build process still produce libphp7.so. Any help would be appreciated.

wget commented on 2018-05-14 13:59

@betrixed No problem.

betrixed commented on 2018-05-13 12:56

Thanks for taking over. I have lost interest in php 7.0, I was only updating versions. .29 PKGBUILD could be updated to .30 , edit VERSION, replace 2 sha512sums for new sources.

rdoursenaud commented on 2018-05-12 16:30

In package php70-embed, /usr/lib/libphp7.so conflicts with php-embed from extra. Please rename to libphp70.so.

All comments