Package Details: php72-sysvmsg 7.2.34-18

Git Clone URL: https://aur.archlinux.org/php72.git (read-only, click to copy)
Package Base: php72
Description: sysvmsg module for php72
Upstream URL: http://www.php.net
Keywords: 7.2 php php7
Licenses: PHP
Submitter: el_aur
Maintainer: el_aur
Last Packager: el_aur
Votes: 11
Popularity: 0.000004
First Submitted: 2019-01-31 20:58 (UTC)
Last Updated: 2024-07-07 09:13 (UTC)

Dependencies (55)

Required by (0)

Sources (21)

Pinned Comments

el_aur commented on 2022-02-03 18:56 (UTC) (edited on 2022-02-04 11:28 (UTC) by el_aur)

Created binary repository on build.opensuse.org

https://build.opensuse.org/project/show/home:el:archphp

For Arch Linux, edit /etc/pacman.conf and add the following (note that the order of repositories in pacman.conf is important, since pacman always downloads the first found package):

[home_el_archphp_Arch]
Server = https://download.opensuse.org/repositories/home:/el:/archphp/Arch/$arch

Then run the following as root

key=$(curl -fsSL https://download.opensuse.org/repositories/home:el:archphp/Arch/$(uname -m)/home_el_archphp_Arch.key)
fingerprint=$(gpg --quiet --with-colons --import-options show-only --import --fingerprint <<< "${key}" | awk -F: '$1 == "fpr" { print $10 }')
pacman-key --init
pacman-key --add - <<< "${key}"
pacman-key --lsign-key "${fingerprint}"

Refresh packages database

pacman -Syy

Now search for php packages you need:

pacman -Ss php72

Install with pacman -S packages you need or all PHP 7.2 packages with:

sudo pacman -S $(pacman -Ssq | grep '^php72')

el_aur commented on 2022-01-27 12:11 (UTC) (edited on 2022-01-27 15:19 (UTC) by el_aur)

Read Carefully! Breaking changes in compare with native PHP package

  1. Console version /usr/bin/php72 is installed with php72-cli subpackage, php72 doesn't include it anymore!!!

  2. PEAR and PECL are available as php72-pear and php72-pecl subpackages

  3. All shared modules are respresented as stand-alone subpackages and are not included with php72 package anymore.

  4. No more extensions in php.ini itself!

Separate INI files for each extension are placed in /etc/php72/conf.d

They are loaded in correct order according to priority

Latest Comments

1 2 3 4 5 6 .. 9 Next › Last »

Zerebratox commented on 2024-07-16 09:17 (UTC)

I have the same issue as @bastiendurel and @df8oe

df8oe commented on 2024-07-15 04:57 (UTC)

Same issue as @bastiendurel

bastiendurel commented on 2024-07-12 08:20 (UTC)

Hello,

There's a problem with readdir in the last version :

/tmp/tmp.qNyTZarEwn/php72/src/php-7.2.34/main/reentrancy.c: In function ‘php_readdir_r’:
/tmp/tmp.qNyTZarEwn/php72/src/php-7.2.34/main/reentrancy.c:139:9: warning: ‘readdir_r’ is deprecated [-Wdeprecated-declarations]
  139 |         readdir_r(dirp, entry);
      |         ^~~~~~~~~
In file included from /tmp/tmp.qNyTZarEwn/php72/src/php-7.2.34/Zend/zend_virtual_cwd.h:78,
                 from /tmp/tmp.qNyTZarEwn/php72/src/php-7.2.34/main/php.h:470,
                 from /tmp/tmp.qNyTZarEwn/php72/src/php-7.2.34/main/php_reentrancy.h:24,
                 from /tmp/tmp.qNyTZarEwn/php72/src/php-7.2.34/main/reentrancy.c:28:
/usr/include/dirent.h:185:12: note: declared here
  185 | extern int readdir_r (DIR *__restrict __dirp,
      |            ^~~~~~~~~
/tmp/tmp.qNyTZarEwn/php72/src/php-7.2.34/main/reentrancy.c:139:9: error: too few arguments to function ‘readdir_r’
  139 |         readdir_r(dirp, entry);
      |         ^~~~~~~~~
/usr/include/dirent.h:185:12: note: declared here
  185 | extern int readdir_r (DIR *__restrict __dirp,
      |            ^~~~~~~~~
make: *** [Makefile:2427: main/reentrancy.lo] Error 1

kasugano commented on 2024-06-08 00:59 (UTC)

@Zeph Much appreciated, helped with both "php56" and "php74".

Zeph commented on 2024-05-30 20:39 (UTC)

@continum4 add -fpermissive flags in build function of PKGBUILD

build() {
    export CFLAGS="${CFLAGS} -fPIC"
    export CXXFLAGS="${CXXFLAGS} -fPIC"
...

to

build() {
    export CFLAGS="${CFLAGS} -fPIC -fpermissive"
    export CXXFLAGS="${CXXFLAGS} -fPIC -fpermissive"
...

continum4 commented on 2024-05-14 20:15 (UTC)

When compiling, an error occurs in libxml.c; error: argument 2 of 'xmlSetStructuredErrorFunc' is passed from an incompatible pointer type [-Wincompatible-pointer-types] 1007 | xmlSetStructuredErrorFunc(NULL, php_libxml_structured_error_handler); | ^~~~ | | | void ()(void , xmlError ) {aka void ()(void , struct _xmlError )}

The same thing happens with other versions of php: php56, php70, php71, at least those are the ones I tried to install. Any ideas about it?

d3x0r commented on 2023-08-04 04:14 (UTC)

I had to modify /etc/httpd/conf/extra/php72-module.conf

It starts as:

<IfModule dir_module>
    <IfModule php_module7>
        DirectoryIndex index.php index.html
        <FilesMatch "\.php$">
            SetHandler application/x-httpd-php
        </FilesMatch>
        <FilesMatch "\.phps$">
            SetHandler application/x-httpd-php-source
        </FilesMatch>
    </IfModule>
</IfModule>

and I changed it to

<IfModule dir_module>
    <IfModule php_module7>
    </IfModule>
</IfModule>
        DirectoryIndex index.php index.html
        <FilesMatch "\.php$">
            SetHandler application/x-httpd-php
        </FilesMatch>
        <FilesMatch "\.phps$">
            SetHandler application/x-httpd-php-source
        </FilesMatch>

which just moves it out of the modules, and then it started working (after trying a bunch of other things) There are other changes that could be made in /etc/httpd/conf/httpd.conf

el_aur commented on 2023-02-21 12:23 (UTC)

Fixed build against dblib. Added c-client to aur. Forced openssl1.1

el_aur commented on 2023-01-16 18:23 (UTC)

@joao.sa yes, have idea. Will prepare patch soon

joao.sa commented on 2023-01-16 08:31 (UTC)

checking for DB4 major version... configure: error: Header contains different version ==> ERROR: A failure occurred in build().

Any idea how to fix?