Package Details: php74-dblib 7.4.33-4

Git Clone URL: https://aur.archlinux.org/php74.git (read-only, click to copy)
Package Base: php74
Description: pdo_dblib module for php74
Upstream URL: http://www.php.net
Licenses: PHP
Submitter: tompear
Maintainer: el_aur
Last Packager: el_aur
Votes: 11
Popularity: 0.052776
First Submitted: 2021-01-31 11:48 (UTC)
Last Updated: 2023-11-23 15:18 (UTC)

Pinned Comments

el_aur commented on 2022-02-02 08:43 (UTC) (edited on 2022-02-02 18:11 (UTC) by el_aur)

Created binary repository on build.opensuse.org

https://build.opensuse.org/project/show/home:el:archphp

Import PGP key first:

curl -s https://download.opensuse.org/repositories/home:/el:/archphp/Arch/x86_64/home_el_archphp_Arch.key | sudo pacman-key -a /dev/stdin

Append to /etc/pacman.conf:

[home_el_archphp_Arch]
SigLevel = Required TrustAll
Server = https://download.opensuse.org/repositories/home:/el:/archphp/Arch/x86_64/

Refresh packages database

pacman -Sy

Now search for php packages you need:

pacman -Ss php74

Install with pacman -S packages you need or all PHP 8.1 packages with:

sudo pacman -S $(pacman -Ssq | grep '^php74')

el_aur commented on 2022-01-27 12:06 (UTC) (edited on 2022-02-01 21:33 (UTC) by el_aur)

Read Carefully! Breaking changes in compare with native PHP package

  1. Console version /usr/bin/php74 is installed with php74-cli subpackage, php74 doesn't include it anymore!!!

  2. PEAR and PECL are available as php74-pear and php74-pecl subpackages

  3. All shared modules are respresented as stand-alone subpackages and are not included with php74 package anymore.

  4. No more extensions in php.ini itself! Separate INI files for each extension are placed in /etc/php74/conf.d They are loaded in correct order according to priority

  5. Modules: mysqlnd, mysqli and pdo_mysql are moved to single package php74-mysql

  6. php74-xsl requires php74-xml and php74-dom to be installed

  7. php74-enchant build with dependencies: libvoikko, hspell, hunspell, nuspell, aspell

Latest Comments

1 2 3 4 5 6 .. 10 Next › Last »

el_aur commented on 2023-12-05 14:08 (UTC)

@tompear patch is here now with support of modern libxml version

tompear commented on 2023-11-26 17:24 (UTC)

You have to downgrade libxml2 to version 11.5 if you want to build it. Current Arch Linux version of this package is incompatible with php74 code.

Switch to php 8.x or change OS if you have to use PHP 7.4, there be more problems like this in the future, PHP 7.4 has end-of-life status.

fjavierjp commented on 2023-11-25 10:52 (UTC) (edited on 2023-11-25 10:54 (UTC) by fjavierjp)

Excuse me if anything does not make much sense, I'm a newbie using AUR.

Everytime I try to install this package via yay, I get an error related to xmlSaveNoEmptyTags not being declared twice under function zif_dom_document_save and zif_dom_document_savexml of .cache/yay/php74/src/php-7.4.33/ext/dom/document.c:

line 1611:29 saveempty = xmlSaveNoEmptyTags;

line 1664:37 saveempty = xmlSaveNoEmptyTags;

Compilation fails and installation is cancelled. Any idea?

Thanks!

nargil commented on 2023-11-20 09:32 (UTC) (edited on 2023-11-20 09:33 (UTC) by nargil)

I have the same issue as balornt. I see your comment el_aur but i don't know how to do.

I tried to delete all php74:
git pull
makepkg -risc

can someone help me ? thanks

tompear commented on 2023-09-22 06:14 (UTC)

Just rebuild php74-intl, thats all.

balornt commented on 2023-09-22 03:40 (UTC) (edited on 2023-09-22 03:42 (UTC) by balornt)

I'm new to posting to the AUR for package support so please forgive and correct me if this is the wrong place, but php74-intl seems to no longer work. When I type php7 -v i get the following:

PHP Warning: PHP Startup: Unable to load dynamic library 'intl' (tried: /usr/lib/php7/modules/intl (/usr/lib/php7/modules/intl: cannot open shared object file: No such file or directory), /usr/lib/php7/modules/intl.so (libicuio.so.72: cannot open shared object file: No such file or directory)) in Unknown on line 0

The icu package has been updated to version 73.2-1 so libicuio.so.72 no longer exists. icu is used by other software packages on my system and I would prefer not to downgrade. What do you suggest I do?

fffx commented on 2023-07-31 23:22 (UTC)

Okay, I executed this line and this slave earned curl -s https://download.opensuse.org/repositories/home:/el:/archphp/Arch/x86_64/home_el_archphp_Arch.key | sudo pacman-key -a /dev/stdin

fffx commented on 2023-07-31 23:19 (UTC)

What is the signature error, everything is broken again

error: home_el_archphp_Arch: signature from "home:el OBS Project <home:el@build.opensuse.org>" is invalid
error: failed to synchronize all databases (invalid or corrupted database (PGP signature))

tompear commented on 2023-06-30 06:54 (UTC)

https://php.net/distributions/php-7.4.33.tar.xz is no longer available to download so building package will fail.

crinklecutter commented on 2023-04-02 14:52 (UTC)

Hi, pgp signature invalid...