Package Details: phpdocumentor2 2.9.0-1

Git Clone URL: https://aur.archlinux.org/phpdocumentor2.git (read-only)
Package Base: phpdocumentor2
Description: Documentation Generator for PHP
Upstream URL: http://www.phpdoc.org/
Licenses: custom
Conflicts: phpdocumentor
Submitter: Bevan
Maintainer: JonnyJD
Last Packager: JonnyJD
Votes: 11
Popularity: 0.416253
First Submitted: 2012-04-13 14:54
Last Updated: 2016-05-23 20:50

Latest Comments

dsohler commented on 2016-05-26 08:37

@coderkun: The Phar version o fit ships anything you need to run phpDocumentor (currently version 2). Phar basically is a way to include binaries into PHP scripts and call them in a defined way. The only dependency is PHP version 5.3 or greater for Phar support.

http://de.php.net/phar

coderkun commented on 2016-05-26 07:14

dsohler: Does this mean that the phar-version is shipping its own versions of the necessary libraries (e. g. graphviz)?

dsohler commented on 2016-05-25 17:18

Using the Phar version has zero dependencies (except php in any version that is not in it’s EOL) and comes in only one single file which makes it incredibly easy to maintain the package. For the end user the result will be the same though.

JonnyJD commented on 2016-05-23 20:52

Thanks, updated this package.

Not sure what's the real gain using phar when it is installed as an arch package though.

dsohler commented on 2016-05-23 18:38

So fresh, so clean, so new :3

And it works with PHP7, too …

https://aur.archlinux.org/packages/phpdoc-phar/

Sorry for not adopting this package here.

Bevan commented on 2016-02-05 19:57

Indeed it does not work with PHP7. I currently don't use this package myself and I don't want to install a second php version just for testing so I disown this package. Feel free to adopt it and adjust it to use php56.

JonnyJD commented on 2016-02-04 17:39

Please update the PKGBUILD and patch the program.

phpDocumentor needs php56, not php (wich is php 7 currently).