Package Details: pianobar-git 711.b534a3b-1

Git Clone URL: https://aur.archlinux.org/pianobar-git.git (read-only)
Package Base: pianobar-git
Description: A free/open-source, console-based replacement for Pandora's Flash player
Upstream URL: http://6xq.net/projects/pianobar/
Licenses: MIT
Conflicts: pianobar
Provides: pianobar
Submitter: mutantmonkey
Maintainer: mutantmonkey
Last Packager: mutantmonkey
Votes: 51
Popularity: 0.150556
First Submitted: 2009-01-17 22:39
Last Updated: 2015-06-09 03:27

Latest Comments

mutantmonkey commented on 2014-12-30 22:02

cirrus: That's not an issue with this package, but it looks like your cower is linked against an older version of libalpm (included with pacman). Try recompiling it and it should work.

cirrus commented on 2014-12-30 20:12

cower: error while loading shared libraries: libalpm.so.8: cannot open shared object file: No such file or directory

mbostwick commented on 2014-05-13 03:11

"Makefile:107: *** Please choose a valid libav implementation at the top of this file. Stop."

0112358 commented on 2014-05-11 07:54

As with Cinelli below, libao-svn fixed issues I was having with with libao.conf.

chetgray commented on 2014-04-20 21:59

@AbrarSyed :

From pianobar/Makefile:
# choose your libav implementation.
# supported: ffmpeg2.2, ffmpeg2.1, ffmpeg1.2, libav10, libav9
LIBAV:=undefined


See https://github.com/PromyLOPh/pianobar/commit/0ba07406f7348605d82373bf43d43099033c9447

Upstream, since moving to using ffmpeg/libav instead of libfaad2 (https://github.com/PromyLOPh/pianobar/commit/c872f00508ce4afe3b8ec863b23595c31fd8b4be), requires that the Makefile be edited to set the variable LIBAV, as there is no good way to detect if ffmpeg or libav are to be used.

AbrarSyed commented on 2014-04-20 01:21

==> Starting build()...
Makefile:103: *** Please choose a valid libav implementation by setting LIBAV. Stop.
==> ERROR: A failure occurred in build().

I get the above error when trying to install this with Packer. To my knowledge, I dont have multiple versions of libAV.

mutantmonkey commented on 2013-04-21 20:24

I just updated this package to use the new VCS packaging options from pacman 4.1 (https://wiki.archlinux.org/index.php/VCS_PKGBUILD_Guidelines), so you'll now need pacman>=4.1 to build it. I also added libgcrypt and gnutls as dependencies.

Cinelli commented on 2013-03-06 07:06

In case anyone else was having issues with /o\ could not load audio device error's even with libao.conf correct.

libao-svn seemed to fix the issue on my end. Might want to add it to depends array.

mutantmonkey commented on 2012-12-06 07:12

No problem, just wanted to make sure you knew.

Are you using pulseaudio? I had the same problem initially; try changing /etc/libao.conf to look like this:
default_driver=pulse

nhasian commented on 2012-12-06 07:02

sorry for flagging it, I thought it hadn't been updated since July. I just installed arch (64bit) and when I try to use pianobar I get this error message:

ao_alsa ERROR: Unable to open ALSA device 'default' for playback => Invalid argument
/!\ Cannot open audio device

also cat /etc/libao.conf shows:
default_driver=alsa

All comments