Package Details: pidgin-light 2.14.1-1

Git Clone URL: https://aur.archlinux.org/pidgin-light.git (read-only, click to copy)
Package Base: pidgin-light
Description: A light pidgin version: msn, jabber, irc supported protocols without gstreamer, tcl, tk, xscreensaver support.No video/voice. Includes finch
Upstream URL: http://pidgin.im/
Keywords: pidgin
Licenses: GPL
Conflicts: finch, libpurple, pidgin, pidgin-msn, pidin-light-msn
Provides: finch, libpurple, pidgin
Replaces: gaim
Submitter: None
Maintainer: funilrys
Last Packager: funilrys
Votes: 59
Popularity: 0.005753
First Submitted: 2008-09-07 15:57 (UTC)
Last Updated: 2020-12-06 12:00 (UTC)

Required by (115)

Sources (2)

Latest Comments

kluwe commented on 2019-12-02 20:50 (UTC) (edited on 2019-12-02 20:52 (UTC) by kluwe)

/usr/include/glib-2.0/gobject/gparam.h:271:8: note: declared here 271 | struct _GParameter /* auxiliary structure for _setv() variants */ | ^~~~~~~~~~~ CCLD finch /sbin/ld: ./libgnt/.libs/libgnt.so: undefined reference to `_Py_Dealloc' /sbin/ld: ./libgnt/.libs/libgnt.so: undefined reference to `PyList_Insert' /sbin/ld: ./libgnt/.libs/libgnt.so: undefined reference to `PyUnicode_FromString' /sbin/ld: ./libgnt/.libs/libgnt.so: undefined reference to `PyErr_Print' /sbin/ld: ./libgnt/.libs/libgnt.so: undefined reference to `PySys_GetObject' /sbin/ld: ./libgnt/.libs/libgnt.so: undefined reference to `PyRun_SimpleFileExFlags' /sbin/ld: ./libgnt/.libs/libgnt.so: undefined reference to `Py_SetProgramName' /sbin/ld: ./libgnt/.libs/libgnt.so: undefined reference to `Py_Finalize' /sbin/ld: ./libgnt/.libs/libgnt.so: undefined reference to `Py_Initialize' /sbin/ld: ./libgnt/.libs/libgnt.so: undefined reference to `Py_IsInitialized' /sbin/ld: ./libgnt/.libs/libgnt.so: undefined reference to `PyErr_Occurred' collect2: error: ld returned 1 exit status make[3]: *** [Makefile:696: finch] Error 1 make[3]: Leaving directory '/home/arch/AUR/pidgin-light/src/pidgin-2.13.0/finch' make[2]: *** [Makefile:803: all-recursive] Error 1 make[2]: Leaving directory '/home/arch/AUR/pidgin-light/src/pidgin-2.13.0/finch' make[1]: *** [Makefile:641: all-recursive] Error 1 make[1]: Leaving directory '/home/arch/AUR/pidgin-light/src/pidgin-2.13.0' make: *** [Makefile:545: all] Error 2 ==> ERRO: Uma falha ocorreu em build(). Abortando...

someone with the same error? https://pastebin.com/RWaw88Uf

funilrys commented on 2016-11-14 20:48 (UTC)

Thanks @skunkos, Fixed ! For fast contact : https://gitter.im/funilrys_/PKGBUILD

skunkos commented on 2016-10-17 18:05 (UTC)

Solved by installing pkg-config, maybe it should be added to makedeps.

skunkos commented on 2016-10-17 17:57 (UTC)

Last version gives error: http://pastebin.com/BfMd1wLJ Probably some missing deps in PKGBUILD?

funilrys commented on 2016-10-06 20:39 (UTC)

Updated to v2.11.0 ! If there's a problem please let me know ! For fast contact : https://gitter.im/funilrys_/PKGBUILD

gbc921 commented on 2016-08-10 16:17 (UTC)

Please update version to 2.11.0 pkgver=2.11.0 I have build and it installs fine here (x64). Tks,

webdawg commented on 2016-05-24 04:14 (UTC)

How is anyone flagging this out of date when it is the git?

PedsXing commented on 2014-02-03 14:53 (UTC)

XMPP login issues are apparently fixed in 2.10.9: https://developer.pidgin.im/ticket/15879

PedsXing commented on 2014-02-02 21:44 (UTC)

XMPP has stopped working (does not log in) for me since the last update. Works with the same configuration and pidgin from [Extra].

commented on 2012-10-09 15:50 (UTC)

Seems like "farsight" is now called "farstream". Please, add --disable-farstream to ./configure

erdbeer commented on 2012-08-15 20:16 (UTC)

:) another thing: this package depends on dbus-glib. Please add it to depends or ./configure with --disable-dbus

commented on 2012-04-11 23:36 (UTC)

erdbeer: Nice catch thkx, fixed. Also a BIG thank you for NOT marking pkg out of date....

erdbeer commented on 2012-04-10 22:38 (UTC)

The aur helper I'm using (packer) can't find the make-dependency perlxml because it is provided by perl-xml-parser. Please rename it in the PKGBUILD.

commented on 2011-11-20 01:14 (UTC)

Tenzer again, pkg_config is part of base-devel group; which MUST be installed to build/install AUR packages See https://wiki.archlinux.org/index.php/AUR_User_Guidelines#Prerequisites

commented on 2011-11-19 23:04 (UTC)

I had to install the "pkg-config" package in order to install the package, otherwise it gave me the following error message: You must have GLib 2.16.0 or newer development headers installed to build. If you have these installed already you may need to install pkg-config so I can find them. Perhaps it could be added to the make dependencies?

deimos commented on 2011-07-28 11:42 (UTC)

please add --disable-farsight to the ./configure string as mentioned previously by mar77i.

semeion commented on 2011-05-15 06:55 (UTC)

i don know the reason, but this package not working for me... i can finish all yaourt proccess, compile and make all, but he don´t install. he finish all yaourt proccess and ask-me if i want to install... i ans yes, and done. but not install. o.0 he only install gtkspell library...

commented on 2011-01-31 04:26 (UTC)

For those who do not want gstreamer dependencies, just remove farsight2 from the list of dependencies in the PKGBUILD. This is a requirement, however, for those who want audio/videoconferencing.

mikeym commented on 2011-01-28 21:47 (UTC)

PKGBUILD (http://pastebin.com/zYEHx8MK) the required changes to remove farsight2 as a dependency and add libxml2 (tested and found to be required). Now gstreamer is truly not a dependency (or dependency of a dependency).

tzok commented on 2010-11-30 12:41 (UTC)

During make, I got: configure: error: GNU gettext tools not found; required for intltool I can see that gettext package is from base group, so I have no idea why is it not installed at my Arch ;), but either way, you can add it to dependencies section IMO.

mar77i commented on 2010-11-28 19:09 (UTC)

oh, and while we're at it, farsight2 is superfluous... if compiling would fail, add --disable-farsight to the ./configure string and add libxml2 to the deps :)

commented on 2010-11-28 17:22 (UTC)

that was wierd, I'm pretty sure i've NEVER quoted anything like that before.... Perhaps was left over from orig PKGBUILD and I just never caught it?? No matter how it got there fixed now. Good eye and thanks (again)

mar77i commented on 2010-11-28 16:30 (UTC)

provides= and conflicts= are quoted wrong, too... http://mywiki.wooledge.org/BashFAQ/005

commented on 2010-09-20 03:32 (UTC)

fixed my idiocy. thanks mar77i

mar77i commented on 2010-09-18 11:42 (UTC)

umm, gstreamer is included, although the description states differently

commented on 2010-06-18 22:32 (UTC)

Adopted/updated/maintaining..... As you were.

gaougalos commented on 2010-06-01 09:22 (UTC)

Bump to version 2.7.1 Pre-compiled package: http://rapidshare.com/files/393958525/pidgin-light-2.7.1-1-i686.pkg.tar.xz.html

anrxc commented on 2010-05-26 16:02 (UTC)

gaougalos, it does not build that way if you don't have gstreamer. Like --disable-gstreamer means nothing, there's an error about gs.h.

gaougalos commented on 2010-05-23 09:34 (UTC)

Change the pkgver=2.6.6 to pkgver=2.7.0 and the md5sums to md5sums=('63a36f91d29f5ac5a402ffd2d7dbbb72')