Package Details: pike 8.0.240-1

Git Clone URL: https://aur.archlinux.org/pike.git (read-only)
Package Base: pike
Description: Dynamic programming language with a syntax similar to Java and C
Upstream URL: http://pike.lysator.liu.se/
Licenses: GPL2, MPL, LGPL
Submitter: None
Maintainer: grodzik
Last Packager: grodzik
Votes: 5
Popularity: 0.216762
First Submitted: 2007-06-16 23:21
Last Updated: 2016-05-16 07:00

Latest Comments

haawda commented on 2016-03-08 12:42

The package is orphaned, just go ahaid and apply the suggested changes yourself.

grodzik commented on 2016-03-08 12:08

There's a new version available: 8.0.182
And link to 8.0.164 is not working anymore. Switch maybe to those links:
http://pike.lysator.liu.se/pub/pike/all/8.0.164/Pike-v8.0.164.tar.gz
http://pike.lysator.liu.se/pub/pike/all/8.0.182/Pike-v8.0.182.tar.gz
Those are kept since version 0.1

EDIT: and that issue with /usr/lib64 would be nice to get fixed ;)

xyproto commented on 2016-02-26 07:27

the_jk, will fix. Please adopt if you have the occasion to fix it first. :)

the_jk commented on 2016-02-25 09:35

I don't know how you avoid:
error: failed to commit transaction (conflicting files)
pike: /usr/lib64 exists in filesystem

But I still need the libdir_reset patch, uploaded an updated version here:
http://www.spawned.biz/the_jk/pike-disable_libdir_reset-1.patch

(patch(1) incorrectly detects the old patch as already applied)

xyproto commented on 2015-10-26 21:09

Thanks, the_jk! Updating the package now.

the_jk commented on 2015-10-20 14:23

Some fixes needed for me to install successfully:
1) pike.ida.liu.se no longer exists, use pike.lysator.liu.se instead
2) compile error about missing memcmp, patch: http://www.spawned.biz/the_jk/pike-add_static_memcmp-0.patch
3) pkg install error because of pike using /usr/lib64, patch: http://www.spawned.biz/the_jk/pike-disable_libdir_reset-0.patch

xyproto commented on 2013-08-05 15:52

Updated the package, it now installs fine both after being built with makepkg and after being built/installed with an AUR helper like yaourt.

xyproto commented on 2013-07-30 20:52

This package builds if built with "makepkg", but fails if built as root. I'll try to look into the reasons.

xyproto commented on 2013-07-30 15:46

This package currently has some issues, but I'll try to resolve them as quickly as possible.

xyproto commented on 2013-07-19 08:21

Adopted the package, removed the dependency on rpl. Cleaned up the PKGBUILD somewhat, but the package() function is still quite original.

All comments