Package Details: piklab 0.16.2-3

Git Clone URL: https://aur.archlinux.org/piklab.git (read-only)
Package Base: piklab
Description: IDE for applications based on Microchip PIC and dsPIC microcontrollers similar to the MPLAB environment
Upstream URL: http://piklab.sourceforge.net
Licenses: GPL
Submitter: mouse256
Maintainer: ivanovp
Last Packager: ivanovp
Votes: 12
Popularity: 0.000000
First Submitted: 2006-04-25 15:53
Last Updated: 2016-11-23 17:43

Dependencies (9)

Required by (0)

Sources (1)

Latest Comments

fenugrec commented on 2018-01-31 20:41

Hi, just thought I'd mention I've added a Qt-only PKGBUILD for this (search for piklab-qt-svn), which is incomplete (no GUI ! apparently there's still some hard dependencies on KDE) but provides the very useful piklab-prog binary.

mah0x00 commented on 2017-11-20 11:05

Thank you for that but I already hade installed MPLABX but the reason for installing the piklab is that I have a clone for ICD2 and it doesn't work on MPLABX and piklab was the only software to operate it, I tried other programs but none of them seems to be working.

ivanovp commented on 2017-11-19 06:19

@mah0x00: There is Linux version of MPLABX, try to install that.

mah0x00 commented on 2017-11-13 20:11

is there is another program like piklab yesterday I tried to install it but there is a missing Dependencies (kdebase-katepart) if someone still working on it please tell me if there is a fix and how?

ivanovp commented on 2016-11-23 17:45

@jaracil: Thanks, fixed.

jaracil commented on 2016-11-11 12:58

It was needed to add (-D 'CMAKE_CXX_FLAGS=-Wno-narrowing') to cmake params to bypass narrowing conversion errors.

Thanks.

ivanovp commented on 2015-03-15 09:30

Fixed: it tried to use /lib directory, but it is a symlink to /usr/lib in Arch Linux. Consider using microchip-mplabx-bin, as it is actively developed.

pendor commented on 2015-03-15 00:16

Tried to compile. System up-to-date.
Error message when trying to install:

error: no se pudo realizar la operación (archivos en conflicto)
piklab: /lib existe en el sistema de archivos
Ocurrieron errores, por lo que no se actualizaron los paquetes

Translation:
error: could not perform operation (conflicting files)
piklab: /lib exists in filesystem
Errors occurred, no packages were upgraded

I remember something like this with other packages some time ago... but don't know what to do right now.

Thanx!

bxs commented on 2012-09-01 12:38

@ivanovp,
I know that piklab is based of pikdev that is based on kate but didn't know that kdebase-katepart dependency was needed, I dropped the maintenance of piklab so you can adopt it and make the dependency change.

ivanovp commented on 2012-09-01 05:14

Please, add dependecy: kdebase-katepart

All comments