Package Details: piklab 0.16.2-3

Git Clone URL: https://aur.archlinux.org/piklab.git (read-only)
Package Base: piklab
Description: IDE for applications based on Microchip PIC and dsPIC microcontrollers similar to the MPLAB environment
Upstream URL: http://piklab.sourceforge.net
Licenses: GPL
Submitter: mouse256
Maintainer: ivanovp
Last Packager: ivanovp
Votes: 12
Popularity: 0.000000
First Submitted: 2006-04-25 15:53
Last Updated: 2016-11-23 17:43

Dependencies (9)

Required by (0)

Sources (1)

Latest Comments

« First ‹ Previous 1 2 3 4 Next › Last »

bxs commented on 2012-07-24 02:02

Updated to version 0.16.1, now uses Qt4.

Anonymous comment on 2011-08-30 13:38

Thanks to janserv for his patches.
For those who did not understand how to install piklab when the conversion error comes up when compiling with gcc 4.6:
Download the 2 packages that I made based on the comments bellow :

http://www.multiupload.com/Z6BXT87AKJ
piklab-0.15.10-6-i686.pkg.tar.xz (1.68 MB)


http://www.multiupload.com/VZAIU4IO3U
qt3-3.3.8-20-i686.pkg.tar.xz (7.7 MB)


Then install them:
su -c 'pacman -U qt3-3.3.8-20-i686.pkg.tar.xz'
su -c 'pacman -U piklab-0.15.10-6-i686.pkg.tar.xz'

Anonymous comment on 2011-05-12 01:13

Success!!!!!
Now, why? who knows? Maybe the last yauourt -Syu, or the cleaning up, or your PKGBUILD, or the moon phase...
Nevertheless, thanx a whole lot for your help, pal!!!!

janserv commented on 2011-05-10 06:01

Clear the md5sums array in the PKGBUILD and create a new array.
makepkg -g >> PKGBUILD

Anonymous comment on 2011-05-09 23:06

Cleaned everything, using your PKGBUILD and now I got md5sum error for the patch... that was copied and paste from your link, or downloaded as raw data... Could this be related??

Anonymous comment on 2011-05-09 22:39

I did that. Twice.

janserv commented on 2011-05-09 22:00

I don't know what this can be.
Did you try a fresh build, meaning after you removed all the source files and the src dir in your piklab build dir?

Anonymous comment on 2011-05-09 20:08

I can see no differences between my PKGBUILD and yours.
Besides, the problem is with libqt-mt...
I´m flabbergasted (is that the correct word??).

I only built qt3 from ABS, are there any other qt related packages I should check???
Or, looking at the error messages again, can it be related to the xml_to_data patch?

janserv commented on 2011-05-09 04:27

http://pastebin.com/WSK8824m

Anonymous comment on 2011-05-09 00:21

Could you post the PKGBUILD with your corrections? just for checking...